One-way audio with PAP2

Discussion in 'UK VOIP' started by simon, Apr 25, 2010.

  1. simon

    simon Guest

    I've had my PAP2 working fine to sipgate in the past on sipgate. Now
    for an incoming call then handset rings and I can answer it. But audio
    is one way only (caller can hear me but I can't hear caller).

    I read somewhere that this is probably caused by being behind NAT
    router and some parameters need tweaking. On my NAT router I have
    several services set-up a long time ago and I don't know where I got
    them from or what exactly they do. They are:
    SIP UDP 5060..5061
    RTPLang UDP 5004
    Voice UDP 8000..8012
    iax UDP 4569
    STUN UDP 3478
    pap2-rtp UDP 16384..16482

    Where are these parameters documented and which (if any) is likely to
    be the cause of my one-way audio?
     
    simon, Apr 25, 2010
    #1
    1. Advertisements

  2. simon

    Woody Guest

    I've had my PAP2 working fine to sipgate in the past on sipgate.
    Now
    for an incoming call then handset rings and I can answer it. But
    audio
    is one way only (caller can hear me but I can't hear caller).

    I read somewhere that this is probably caused by being behind NAT
    router and some parameters need tweaking. On my NAT router I
    have
    several services set-up a long time ago and I don't know where I
    got
    them from or what exactly they do. They are:
    SIP UDP 5060..5061
    RTPLang UDP 5004
    Voice UDP 8000..8012
    iax UDP 4569
    STUN UDP 3478
    pap2-rtp UDP 16384..16482

    Where are these parameters documented and which (if any) is
    likely to
    be the cause of my one-way audio?



    If you haven't already done so go dig on the Sipgate web site.
    There certainly used to be (if not now) the setup for quite a
    range of ATA's to use with the Sipgate service - including the
    PAP2T which I used.
     
    Woody, Apr 26, 2010
    #2
    1. Advertisements

  3. simon

    Dave Saville Guest

    It might not be - Either have a quick look at "page Source" or try
    dragging the mouse over the page as if highlighting.
     
    Dave Saville, Apr 26, 2010
    #3
  4. simon

    Woody Guest

    I've looked there and:
    1 the PAP2 configuration section on Sipgate now seems to be 95%
    white
    font on white paper. It is basically a blank page with a few
    snatches
    of red writing scattered about and cannot be read.
    2 Before the above colour cock-up I don't it saying anything
    about the
    following parameters on my NAT router:

    SIP UDP 5060..5061
    RTPLang UDP 5004
    Voice UDP 8000..8012
    iax UDP 4569
    STUN UDP 3478
    pap2-rtp UDP 16384..16482

    Are these parameters required? Where are they documented and what
    does
    each of them do?



    I've just logged in to the Sipgate page and the full config is
    present and correct.

    Browser setting problem your end maybe?
     
    Woody, Apr 26, 2010
    #4
  5. simon

    simon Guest

    I am 99% certain that it's not my PAP2 configuration. This has not
    changed for many months and it used to work. What has changed is that
    I have updated the firmware for my NAT router and had to tinker with
    my router settings. I come back to the question what are these
    settings and where are they documented:
    :
    SIP UDP 5060..5061
    RTPLang UDP 5004
    Voice UDP 8000..8012
    iax UDP 4569
    STUN UDP 3478
    pap2-rtp UDP 16384..16482

    I do not recall ever seeing any documentation to tell me what they are
    and what the values should be. I must have acquired them from
    somewhere to put into my route many years ago. The Sipgate site does
    not mention these parameters at all. Is there anywhere I can look them
    up?

    I have tried to widen the pap2-rtp ports as suggested by Vicktor
    Whieste but it makes no difference. Since, like the other parameters,
    I don't know what pap2-rtp is (except that it is set as an Inbound
    Service) I have difficulty is moving the problem on.
     
    simon, Apr 26, 2010
    #5
  6. simon

    Bodincus Guest

    simon:
    That's why VoIP is a bitch.

    If you set up properly your SIP accounts, with all outbound proxies
    properly configured, you don't need any port forward at all.

    I assume the above are NAT settings, where the inbound traffic on these
    ports is routed to the private IP the PAP2 is on.

    Let's go through each one:
    Correct, they're the ports the PAP2 is using for the the incoming SIP
    (data) traffic. ***KEEP***.
    Port 5004 UDP is usually the UDP port used by Grandstream devices for
    the RTP (voice) traffic. No need for it. ***REMOVE***.
    UDP 8000 to 8012 is another range of ports used by many VoIP phones for
    the RTP (Voice) traffic, but nothing to do with the PAP. ***REMOVE***.
    If you don't have an Asterisk server in your private network, you don't
    need this. ***REMOVE***.
    You must NOT forward STUN traffic to an internal IP, whatsoever. STUN
    needs to bounce against the public IP of your router to report correctly
    your public IP. ***REMOVE***.
    This is the RTP range that is set in your PAP2 for the voice traffic. If
    you didn't change the RTP ports in the PAP2 advanced configuration,
    these are OK. ***KEEP***.

    Remember that you don't need ANY port forward, NAT or open firewall
    ports if you have correctly set up your SIP accounts using an Outbound
    Proxy.

    Double check that the remaining services ("SIP UDP 5060..5061" and
    "pap2-rtp UDP 16384..16482") are forwarded to the IP address the PAP is
    given by the router DHCP server, or that the PAP is on a static IP and
    that IP is used for the forward.

    Knowing what brand, make and model of router you have might help tho.
    --
    Bodincus - The Y2K Druid
    ************************
    Law 42 on computing:
    Anything that could fail, will break at the worst possible mom%*= [email protected]@
    # Access Violation - Core dumped
    # Kernel Panic
     
    Bodincus, Apr 26, 2010
    #6
  7. simon

    alexd Guest

    Checking the router logs for dropped packets to high UDP ports might be
    of interest too. If it logs them, that is.
     
    alexd, Apr 27, 2010
    #7
  8. simon

    simon Guest

    On Mon, 26 Apr 2010 22:24:09 +0100, Bodincus wrote:

    ) I have difficulty is moving the problem on.
    Thank you for your helpful comments. The router is Netgear FR114P. In
    the configuration all the outgoing services are set to:
    Default ALLOW always
    All the incoming services are set to:
    Default BLOCK always
    except that I have the various STUN, RTPLang services set as ALLOW
    always as detailed in my earlier post.

    I have now discovered the way of avoiding the one-way audio..This was:
    pap2-rtp UDP 16384..16482
    As a result of a router firmware upgrade the PAP2 IP address changed.
    I have now changed the corresponding pap2-rtp line on the router to
    point to the correct PAP2 IP address and it appears to have cured the
    problem.

    For the moment I have left all the other parameters STUN, RTPLang etc
    but as they all point to the wrong IP address for the PAP2 it agrees
    with your suggestion that these are not required.

    So yes, It seems pap2-rtp is the only router parameter that has any
    effect. Given that you say a correctly configured PAP2 would not even
    need the pap2-rtp line what would I need to change in the PAP2 set-up
    to remove the need of the pap2-rtp line in my router?
     
    simon, Apr 28, 2010
    #8
  9. simon

    Bodincus Guest

    simon:
    This is OK
    Still OK
    Change also the SIP UDP 5060..5061 line to the new PAP2 IP address.
    I'm afraid you'll have to remove ASAP at least the STUN parameter, with
    that in place any STUN server might see its packets drop in the void and
    won't be able to verify your external IP. This can lead to the PAP2
    using the wrong IP to register with, and you missing inbound calls.
    Furthermore, as all other open ports lead to nowhere, but are open, your
    public IP will become target of interest for all the creepy crawlies out
    there.
    Your router responds differently to probes on open or closed ports,
    where probes to closed ports bounce back with a "closed port" message,
    but open ports leading to non existing internal IPs look like "stealth
    ports", and this attracts a lot of attention from anybody that tries to
    break in into your network.
    As a matter of fact, remove ALL unused port forwards ASAP, to reduce
    your attack surface.
    If you want to remove the necessity for ALL port forwards on the router,
    you must use an Outbound Proxy and a STUN server.
    Check first that your provider offers both (almost all do), and then set
    up their parameters correctly in the PAP2 interface.
    As this can be different depending on the provider itself, you need to
    find the instructions for your device on the provider's website.
    Sorry I can't be of further help, but as the PAP2 is quite a common
    device you should be able to find help online without too much trouble.
    Once you have the Outbound Proxy and the STUN Server properly
    configured, you will be able to remove all of the port forwards from
    your router.

    To resume:
    - SIP UDP 5060-5061 to point to the PAP2 new IP
    - Remove ASAP ALL unused port forwards
    - If it isn't broken, don't fix it: if it's working as it is, leave the
    Outbound Proxy matter out of the equation until later.
    --
    Bodincus - The Y2K Druid
    ************************
    Law 42 on computing:
    Anything that could fail, will break at the worst possible mom%*= [email protected]@
    # Access Violation - Core dumped
    # Kernel Panic
     
    Bodincus, Apr 28, 2010
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.