Not seeing all VLANS

Discussion in 'Cisco' started by Scooty, Oct 12, 2007.

  1. Scooty

    Scooty Guest

    Hi
    I have several switches, a 3750 Catalyst, a 3650 and 2 2960's
    The 2 2960's are not seeing all the VLANs and I can't work out why
    All switches are using VLAN1 and all are in the same subnet
    10.200.200.0

    Here is the config bits

    3750
    sh vtp status
    VTP Version : 2
    Configuration Revision : 2
    Maximum VLANs supported locally : 1005
    Number of existing VLANs : 10
    VTP Operating Mode : Server
    VTP Domain Name : AFF
    VTP Pruning Mode : Enabled
    VTP V2 Mode : Disabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x28 0xDE 0x37 0xB2 0xF6 0xE9 0x36
    0x7A
    Configuration last modified by 10.200.200.1 at 11-7-06 04:43:32
    Local updater ID is 10.200.200.1 on interface Vl1 (lowest numbered
    VLAN interface found)

    sh int trunk
    Port Mode Encapsulation Status Native vlan
    Gi1/0/2 on 802.1q trunking 1
    Gi2/0/2 auto n-802.1q trunking 1
    Gi2/0/4 on 802.1q trunking 1
    Gi3/0/1 on 802.1q trunking 1

    Port Vlans allowed on trunk
    Gi1/0/2 1-4094
    Gi2/0/2 1-4094
    Gi2/0/4 1-4094
    Gi3/0/1 1-4094

    Port Vlans allowed and active in management domain
    Gi1/0/2 1,5,11,26,100-101
    Gi2/0/2 1,5,11,26,100-101
    Gi2/0/4 1,5,11,26,100-101
    Gi3/0/1 1,5,11,26,100-101

    Port Vlans in spanning tree forwarding state and not pruned
    Gi1/0/2 1,5,11,26,100-101
    Gi2/0/2 1,5,11,26,100-101
    Gi2/0/4 1,26
    Gi3/0/1 1,5,11,26,100-101

    sh run int g3/0/1
    interface GigabitEthernet3/0/1
    description Trunk to WA-3560-01 Port Gi0/2 via Patch 214
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    speed 1000
    mdix auto
    spanning-tree portfast
    end

    sh run int g1/0/2
    interface GigabitEthernet1/0/2
    description Link to Cisco 2960-2 Port Gi0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no mdix auto
    end

    sh run int g2/0/4
    interface GigabitEthernet2/0/4
    description Link to Cisco 2960-1 Port Gi0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    no mdix auto
    spanning-tree portfast
    end


    3560
    sh vtp status
    VTP Version : 2
    Configuration Revision : 0
    Maximum VLANs supported locally : 1005
    Number of existing VLANs : 7
    VTP Operating Mode : Client
    VTP Domain Name : AFF
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Disabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x9C 0xBE 0x0D 0x2E 0x18 0x97 0xEA
    0x51
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

    #sh int trunk
    Port Mode Encapsulation Status Native vlan
    Gi0/2 desirable n-802.1q trunking 1
    Port Vlans allowed on trunk
    Gi0/2 1-4094
    Port Vlans allowed and active in management domain
    Gi0/2 1,26,100
    Port Vlans in spanning tree forwarding state and not pruned
    Gi0/2 1,26,100

    sh vlan bri
    VLAN Name Status Ports
    ---- -------------------------------- ---------
    -------------------------------
    1 default active Gi0/25, Gi0/26,
    Gi0/27, Gi0/28
    26 USERVLAN active Gi0/1, Gi0/3, Gi0/4,
    Gi0/5, Gi0/6, Gi0/7, Gi0/8, Gi0/9, Gi0/10, Gi0/11, Gi0/12
    Gi0/13, Gi0/14,
    Gi0/15, Gi0/16, Gi0/17, Gi0/18, Gi0/19, Gi0/20, Gi0/21, Gi0/22
    Gi0/23, Gi0/24
    100 SERVERVLAN active
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup


    One of the 2960's
    sh vtp status
    VTP Version : 2
    Configuration Revision : 0
    Maximum VLANs supported locally : 255
    Number of existing VLANs : 6
    VTP Operating Mode : Client
    VTP Domain Name : AFF
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Disabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x05 0x61 0xE0 0x2C 0xEB 0x96 0xF4
    0x47
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

    sh vlan bri
    VLAN Name Status Ports
    ---- -------------------------------- ---------
    -------------------------------
    1 default active Gi0/2
    26 USERVLAN active Fa0/1, Fa0/2, Fa0/3,
    Fa0/4
    Fa0/5, Fa0/6, Fa0/7,
    Fa0/8
    Fa0/9, Fa0/10, Fa0/11,
    Fa0/12
    Fa0/13, Fa0/14,
    Fa0/15, Fa0/16
    Fa0/17, Fa0/18,
    Fa0/20, Fa0/21
    Fa0/22, Fa0/23,
    Fa0/24, Fa0/25
    Fa0/26, Fa0/27,
    Fa0/28, Fa0/29
    Fa0/30, Fa0/31,
    Fa0/32, Fa0/33
    Fa0/34, Fa0/35,
    Fa0/36, Fa0/37
    Fa0/38, Fa0/39,
    Fa0/40, Fa0/42
    Fa0/43, Fa0/44,
    Fa0/45, Fa0/46
    Fa0/47, Fa0/48
    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup


    sh int trunk
    Port Mode Encapsulation Status Native vlan
    Gi0/1 on 802.1q trunking 1
    Port Vlans allowed on trunk
    Gi0/1 1-4094
    Port Vlans allowed and active in management domain
    Gi0/1 1,26
    Port Vlans in spanning tree forwarding state and not pruned
    Gi0/1 1,26

    Port Fa0/19 has switchport access vlan 100 set on it but I am not
    seeing VLAN100 in the list

    If anyone could offer any ideas it would bemost appreciated

    Scott
     
    Scooty, Oct 12, 2007
    #1
    1. Advertisements

  2. Okay, so first part, is your VTP isn't working. Not sure if you are
    thinking it should..
    So, they aren't seeing any pushdowns of VTP data, so they won't learn
    of VLANs automatically. The displays show that they should be doing VTP,
    but something isn't working there, since the config rev's are 0 on the clients
    and not matching the config rev on the VTP server.
    With the switch in VTP client mode, it won't automake the VLAN into
    the list when applied on a switch port.

    Either figure out what in VTP isn't working, or manually create all
    VLANs on each switch and ignore VTP altogether with the 'vlan xx'
    config item.
     
    Doug McIntyre, Oct 12, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.