Not enough server storage is available to process this command

Discussion in 'Windows 64bit' started by mapi-user, May 14, 2008.

  1. mapi-user

    mapi-user Guest

    I am running into an application that does a lot of local file IO activity. I
    was able to narrow it to a simple operation that fails consistently.

    The system is Windows Server 2003 x64 bit edition, with Service Pack 2
    installed. When copying several files using Windows Explorer, the copy
    operation proceeds for sometime and almost always fails with a file -
    ususally over 100MB in size.

    Cannot copy file.exe: Not enough server storage is available to process this
    command

    I have tweaked registry entry for IRPStacksize (set to 20, 40, 50). Always
    the same result. I read somewhere that a few folks installed SP1 and the
    problem went away. We are actually using SP2. Any help would be appreciated.

    Thanks.
     
    mapi-user, May 14, 2008
    #1
    1. Advertisements

  2. I honestly don't know what's causing this, but I wouldn't be surprised to
    learn it was insufficient disk space on your system drive.
     
    Charlie Russel - MVP, May 15, 2008
    #2
    1. Advertisements

  3. mapi-user

    mapi-user Guest

    Charlie,

    Thanks for your reply. I do not think it is the system drive available space
    issue. The C: drive has about 30GB space, and the D: Drive has about 1TB
    space.

    Thanks.
     
    mapi-user, May 16, 2008
    #3
  4. Hello,
    The system is running out of a resource, what isn't obvious is which one of
    the resources it's running out of.
    Paged Pool is certainly a suspect and cause this error message. ( More
    common with backup programs but not limited to them)
    See the following article which points to the registry setting to change
    Paged Pool to see if that help out.

    304101 Backup program is unsuccessful when you back up a large system volume
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;304101

    Also some network settings can generate this error:

    Try Disabling TCP chimney, RSS and TCPA

    1. Click Start - Run, Regedit
    2. Locate the following registry subkey
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

    3. Right-click EnableTCPChimney, and then click Modify.
    4. In the Value data box, type 0 , and then click OK.
    5. Right-click EnableRSS, and then click Modify.
    6. In the Value data box, type 0 , and then click OK.
    7. Right-click EnableTCPA, and then click Modify.
    8. In the Value data box, type 0 , and then click OK.
    9. Exit from the Registry editor
    10. Restart the Server.


    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
    | >Thread-Topic: Not enough server storage is available to process this
    command
    | >thread-index: Aci28N3MUP/HkKB3QXy4yfq5J8YFmg==
    | >X-WBNR-Posting-Host: 207.46.193.207
    | >From: =?Utf-8?B?bWFwaS11c2Vy?= <>
    | >References: <>
    <>
    | >Subject: Re: Not enough server storage is available to process this
    command
    | >Date: Thu, 15 May 2008 18:05:00 -0700
    | >Lines: 43
    | >Message-ID: <>
    | >MIME-Version: 1.0
    | >Content-Type: text/plain;
    | > charset="Utf-8"
    | >Content-Transfer-Encoding: 7bit
    | >X-Newsreader: Microsoft CDO for Windows 2000
    | >Content-Class: urn:content-classes:message
    | >Importance: normal
    | >Priority: normal
    | >X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
    | >Newsgroups: microsoft.public.windows.64bit.general
    | >Path: TK2MSFTNGHUB02.phx.gbl
    | >Xref: TK2MSFTNGHUB02.phx.gbl microsoft.public.windows.64bit.general:17498
    | >NNTP-Posting-Host: tk2msftibfm01.phx.gbl 10.40.244.149
    | >X-Tomcat-NG: microsoft.public.windows.64bit.general
    | >
    | >Charlie,
    | >
    | >Thanks for your reply. I do not think it is the system drive available
    space
    | >issue. The C: drive has about 30GB space, and the D: Drive has about 1TB
    | >space.
    | >
    | >Thanks.
    | >
    | >"Charlie Russel - MVP" wrote:
    | >
    | >> I honestly don't know what's causing this, but I wouldn't be surprised
    to
    | >> learn it was insufficient disk space on your system drive.
    | >>
    | >> --
    | >> Charlie.
    | >> http://msmvps.com/blogs/xperts64
    | >> http://mvp.support.microsoft.com/profile/charlie.russel
    | >>
    | >>
    | >> | >> >I am running into an application that does a lot of local file IO
    activity.
    | >> >I
    | >> > was able to narrow it to a simple operation that fails consistently.
    | >> >
    | >> > The system is Windows Server 2003 x64 bit edition, with Service Pack
    2
    | >> > installed. When copying several files using Windows Explorer, the
    copy
    | >> > operation proceeds for sometime and almost always fails with a file -
    | >> > ususally over 100MB in size.
    | >> >
    | >> > Cannot copy file.exe: Not enough server storage is available to
    process
    | >> > this
    | >> > command
    | >> >
    | >> > I have tweaked registry entry for IRPStacksize (set to 20, 40, 50).
    Always
    | >> > the same result. I read somewhere that a few folks installed SP1 and
    the
    | >> > problem went away. We are actually using SP2. Any help would be
    | >> > appreciated.
    | >> >
    | >> > Thanks.
    | >> >
    | >> >
    | >>
    | >
     
    Darrell Gorter[MSFT], May 19, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.