No packets exchanged and cannot repair IP/DHCP address

Discussion in 'Wireless Networking' started by BTInternet, Dec 12, 2004.

  1. BTInternet

    BTInternet Guest

    In addition to the below situation I should add that despite the connection
    showing as "connected" and signal strength showing as "excellent" the laptop
    cannot get an IP address or DHCP gateway when "Repair Connection" is used.
    This is an ad-hoc peer to peer connection. Any ideas?
    -----------------
    I have set up an ad-hoc wireless network between a laptop and desktop. Both
    are running win XP. The networks connect to each other and show as
    "Connected" with excellent signal strength but no packets are exchanged only
    packets are attempted to be sent from both ends. Ad Hoc peer to peer is set
    up at both ends.

    The laptop assigns a Automatic Private Address but cannot get a Default
    Gateway. When the wireless connection is replaced with a traditional wired
    link between the two everything works just fine!

    I have tried switching off WEP & Network Authentication at both ends - no
    change, good connection but no packets exchanged.

    Why can the laptop not negotiate a Default Gateway with the Desktop. The
    laptop wireless link works fine when connected with other networks (though
    probably mostly wireless access points).

    Any help? Thanks John I
     
    BTInternet, Dec 12, 2004
    #1
    1. Advertisements

  2. BTInternet

    Guest Guest

    Hi,
    For a a peer to peer n/w it is better to assign a static IP instead of
    Automatic Private Address.Please do the following in both the laptop to
    assign a static IP.
    1) Go to Control Panel, Network connections
    2) Then Right click the wireless n/w and click on properties
    3) Then, highligt internet prtocol/TCPIP and then click properties
    4) Select, use the following IP address and put in 192.168.1.5 as the IP
    5) The subnet mask will be automaticall filled. Do the same in the ohter
    laptop too.

    Then, you also need to check a setting in ur wireless n/w tab in wireless
    coneection properties. Make sure that you slecet your SSID and then click
    configure. MAke sure that the check box "This is an Adh hoc nw" Is checked.
    Also under the same wire n/w's tab, click on the advanced button and then
    check the"Thsi is an Adhoc n/w radio button" Then you should be able to
    connect provided both the workgroups are the same.
    Regs
    VInay.S
     
    Guest, Dec 14, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.