No file system on USB drive.

Discussion in 'Computer Information' started by zaqxws, Jun 8, 2014.

  1. zaqxws

    zaqxws Guest

    OK back on the 500GB drive OK and I have the failed drive in this new machineas you can see here.

    It seems in better shape here as you can see 3 partitions however I don't recall partitioning it ever so news to me.

    However it does look kind of 'healthier', however it just shows up as a drive in 'my compuer' no other info.

    I think I will try downloading disk utilities to this machine to see they can shed any light on it. XP should not support a drive that size anyway butit was via USB so maybe that is different?

    Just and HDtune on it and it seems fine physically, kind of look like a normal drive!!

    Maybe it IS the power supply, or maybe that is part of it? However the dataseems to be lost,
    Maybe I can try that recura program on it.
    Will have to try but I don't have anywhere to recover to yet unless I put the 2 TB drive in the USB enclosure. However there is not really lot worth recovering on it, ie a few similar/duplicate backups.
    zaqxws, Jun 10, 2014
    1. Advertisements

  2. zaqxws

    Paul Guest

    The 3TB drive shows "RAW" for the first partition.
    That isn't good. It means F: can't mount. We don't know
    how much of that partition is sick or healthy. For example,
    it could be the file system header (64 sectors or so) which
    is damaged.

    I interpret your 3TB drive this way.

    1) It's an MBR setup, with a 2.2TB limitation. The upper section
    is marked "unallocated", because in fact WinXP can't access it.
    It takes the Acronis capacity manager driver, to make that part
    useful. So the third partition is an artifact of the 2.2TB limitation.

    2) The second partition is unallocated, meaning it's just space with
    no partition in it.

    3) The first (and only) partition is 350GB. Verify whether that
    size is correct or not. If the partition used to have much different
    dimensions, you could be in a real mess.

    Remember that Photorec and Recuva are tools of last
    choice. A scavenger might not get all files in one piece.
    It might not even get the majority of files in one piece.
    I would sooner fix things up, than scavenge.

    You can try running TestDisk.

    I'll have to dig up a drive, and see if I can take
    some pictures of it, to illustrate.

    Paul, Jun 10, 2014
    1. Advertisements

  3. zaqxws

    Paul Guest

    OK, first, this is PTEDIT32 (running as administrator),
    showing a single NTFS partition on my 3TB drive. Since
    the system is WinXP, only the bottom 2.2TB of the drive
    is visible. And my test partition for these pictures,
    uses that space.

    (using )

    Note that PTEDIT32 is only suited to legacy setups.
    A disk formatted in Windows 7, with megabyte offsets,
    may cause the program to report errors. So it's hardly
    a modern tool, and you have to be a "lucky person"
    for it to display stuff without complaint.


    Next, is a TestDisk run. If the thing seen in PTEDIT32
    was "totally ruined", TestDisk can work out that the
    partition type is 0x07, the dimensions are X,Y,Z and
    so on. And offer to put that information back for you.
    If the info in PTEDIT32 looks "sane", then you would
    not need that aspect of TestDisk.

    In that picture, the scan has finished. The single partition
    is currently selected. If I press "P", it's time to get
    TestDisk to show the partition is actually sane.

    Now I can see the top level files on that partition.

    Paul, Jun 10, 2014
  4. zaqxws

    zaqxws Guest

    OK I just ran recuva just to see what it showed I have not attempted to
    to recover anything though. It shows the partitions to be different
    Not sure if you can see that.

    It has one big partition of 2445 GB not 1689GB and 756GB

    Worse still some of the partitions are shown to be on DIFFERENT DRIVES!!!

    So not sure what is going on there!

    Also something which has been bugging me for a while si disk 2 removable disk :Z
    (I changed the drive letter from a lower letter) I am not sure what that is..
    I don't have a removable disk whatever that is, there are no other drives connect apart from the DVD. I do also connect my mobile phone to upload picsvia USB from time to time.
    I am wondering if I removed a USB drive with out doing a a safely remove hardware I would get a 'ghost drive' like that? Anyway that's a minor issue.

    So it's kind of a big concern with partition being shows on different drives, I am not very familiar with a lot of the terms.

    Also 9 partitions are shown in disk management but only 3 have a drive letter. I though everyone would have a drive letter. The fact recuva shows someof those partitons as being on different drives is kind of worrying.

    I am kind of thinking maybe the wrong description of the partitions got wrote to the drive.

    There is also this BIOS screen which pops up sometimes at start-up after I have switched drives. When ever I try to exit that it just won't go it stays there so I have to reboot. That is not a prob though, I should get familliar with that bios, I am scared of it at the moment incase I do anythg wrong lol. I could not see the drives connected in there, they must be under advanced but again I was scared to click that given I could not exit properly..

    Anyway back to the drive stuff, 350 Gb sounds about the size of the data that was on the drive.
    It looks like I never backup up my new machine (this one) when I got it about 9? months ago which is kind of weird, it;s still not backed up now (lol)well actually it is as I cloned the drive yesterday ;O) but that is the first time it has had a backup, guess I was too busy trying to fix my old machine and forgot about it. The old machine is now actually in pretty good shape especially since I got the second GB of ram working on it.

    I want to try and connect them via the router/hub but never managed to do that.
    I did previous managed to connect my old machine to an even older now deadmachine via a Ethernet and an NIC card, worked really well and seemed easyto do. Never managed to do it with the newer machines, seems so confusing.#

    But I need to get back on topic and discover why the partitions are showingup differently, I also need to learn more about what I am talking about such as the difference between raw and unallocated.

    I do not recall ever partitioning the drive myself , mind you there is lotsof stuff I do not remember. However if I wanted to partition a USB drive right now I'd have to look up how to do it so I am pretty Sure I never did it.

    Indeed I think I intended to partition it but just put some temporary backups on it whilst I decided what to do and then kind of just forgot about it.

    I will do a bit more investigation of whatever and see what I Can find or not as the case may be lol.

    I if it is just a power supply problem that might be good news.

    Actually I have changed my mind maybe I did partition the drive?

    Here is a good pic with a lot of stuff shown at once, ie diskk management recuva
    hd tune etc..

    I may have miss read some of the stuff earlier about what is on which driveor have I changed my mind again, whatever it seem to things which should be correct report different results? How can that be?
    zaqxws, Jun 10, 2014
  5. zaqxws

    zaqxws Guest

    Ha ha I am lucky I just remembered I had those two programs on a USB stick from
    previous disasters. However PTEDIT wont run.

    Error 5 starting powerquest engine

    Also I can't get much out of testdisk so far, not sure how to use it and a bit wary of using it,I will try reading the documentation.

    I did get some sort of log file but it is very hard to read due to no formatting, I will post it here non the less!!

    Wed Jun 11 00:04:44 2014
    Command line: TestDisk

    TestDisk 6.14, Data Recovery Utility, July 2013
    Christophe GRENIER <>
    OS: Windows WorkStation 6.2.9200
    Compiler: GCC 4.7, Cygwin 1007.17
    Compilation date: 2013-07-30T14:08:52
    ext2fs lib: 1.42.2, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20120504
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=3000592982016
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=500107862016
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdd)=7811891200
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=3000592982016
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=500107862016
    filewin32_getfilesize(\\.\PhysicalDrive2) GetFileSize err Incorrect function.

    filewin32_setfilepointer(\\.\PhysicalDrive2) SetFilePointer err Incorrect function.

    Warning: can't get size for \\.\PhysicalDrive2
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive3)=7811891200
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=160589414400
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\D:)=316806266880
    filewin32_getfilesize(\\.\E:) GetFileSize err Incorrect function.

    filewin32_setfilepointer(\\.\E:) SetFilePointer err Incorrect function.

    Warning: can't get size for \\.\E:
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\F:)=375072768000
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\G:)=7810625536
    disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\Z:)=0
    Warning: can't get size for \\.\Z:
    Hard disk list
    Disk /dev/sda - 3000 GB / 2794 GiB - CHS 364801 255 63, sector size=512 -ST3000DM001-9YN166, S/N:S1F0D4ZS, FW:CC9E
    Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63, sector size=512 - WDC WD5000AAKX-22ERMA0, S/N:WD-WCC2EER54702, FW:17.01H17
    Disk /dev/sdd - 7811 MB / 7450 MiB - CHS 949 255 63, sector size=512, S/N:1, FW:8.07
    Drive G: - 7810 MB / 7448 MiB - CHS 949 255 63, sector size=512, S/N:1, FW:8.07

    Partition table type (auto): Intel
    Disk /dev/sda - 3000 GB / 2794 GiB - ST3000DM001-9YN166
    Partition table type: Intel

    Analyse Disk /dev/sda - 3000 GB / 2794 GiB - CHS 364801 255 63
    Geometry from i386 MBR: head=255 sector=63
    check_part_i386 failed for partition type 07
    Current partition structure:
    Invalid NTFS or EXFAT boot
    1 P HPFS - NTFS 0 32 33 45600 32 32 732564000
    1 P HPFS - NTFS 0 32 33 45600 32 32 732564000
    No partition is bootable

    Disk /dev/sda - 3000 GB / 2794 GiB - CHS 364801 255 63
    NTFS at 1/5/5
    Warning: number of bytes per sector mismatches 4096 (NTFS) != 512 (HD)
    filesystem size 732564000
    sectors_per_cluster 1
    mft_lcn 786432
    mftmirr_lcn 366281999
    clusters_per_mft_record 1
    clusters_per_index_record 1
    HPFS - NTFS 1 5 5 364801 5 4 5860512000 [Expansion Drive]
    NTFS, blocksize=4096, 3000 GB / 2794 GiB
    file_pread(4,2,buffer,1565566976(364801/98/34)) lseek err Invalid argument
    file_pread(4,1,buffer,1565566976(364801/98/34)) lseek err Invalid argument
    file_pread(4,8,buffer,1565565952(364801/82/18)) lseek err Invalid argument
    file_pread(4,1,buffer,1565565952(364801/82/18)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566080(364801/84/20)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566208(364801/86/22)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566336(364801/88/24)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566464(364801/90/26)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566592(364801/92/28)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566720(364801/94/30)) lseek err Invalid argument
    file_pread(4,8,buffer,1565566848(364801/96/32)) lseek err Invalid argument
    file_pread(4,1,buffer,1565566975(364801/98/33)) lseek err Invalid argument
    file_pread(4,1,buffer,1565566976(364801/98/34)) lseek err Invalid argument
    file_pread(4,14,buffer,1565566977(364801/98/35)) lseek err Invalid argument
    file_pread(4,3,buffer,1565566991(364801/98/49)) lseek err Invalid argument
    file_pread(4,3,buffer,1565567038(364801/99/33)) lseek err Invalid argument
    file_pread(4,8,buffer,1565567054(364801/99/49)) lseek err Invalid argument
    file_pread(4,11,buffer,1565567101(364801/100/33)) lseek err Invalid argument
    file_pread(4,2,buffer,1565569023(364801/131/2)) lseek err Invalid argument

    * HPFS - NTFS 1 5 5 364801 33 32 5860513792 [Expansion Drive]
    NTFS, blocksize=4096, 3000 GB / 2794 GiB

    1 * HPFS - NTFS 1 5 5 364801 33 32 5860513792 [Expansion Drive]
    simulate write!

    write_mbr_i386: starting...
    write_all_log_i386: starting...
    No extended partition

    TestDisk exited normally.


    WOW that was magic, suddenly it is perfectly formatted when I posted it (via google groups)!!!!
    zaqxws, Jun 11, 2014
  6. zaqxws

    Paul Guest

    Again, that says "Unallocated". It is the sum total of "left over
    hard drive" above the 349.31GB partition. It should not be
    called a partition, as it is just unallocated space.
    Check to see if you have an optical drive, a USB pen drive, if you
    have a USB card reader that will contribute four drive letters, and so on.

    I'm a bit puzzled why your machine insists on listing unallocated
    areas as "partitions". It should not be doing that. An unallocated
    space has no properties of its own. It is a "non-entity".

    Not using Safely Remove, a side effect might be a partition that
    needs a CHKDSK run. But other than that, the properties should
    still be well behaved. When the device was mounted, the serial number
    was entered in the Registry. And later, when it is plugged in again,
    the OS should notice it has the same serial number, and not create
    duplicate information for it. It would be "recognized".
    I am not very familiar with a lot of the terms.
    I don't know what the hell is going on with your partitions and allocations.

    Think about whatever unique software you have running. Truecrypt ?
    Some "magic backup software" ? There's got to be something on your
    machine, which is not on mine, and is making a royal mess.
    You use Disk Management, and Start : Run : diskmgmt.msc
    will get you there.
    Right now, I see "strange" results, but not "different" results.
    All your presentations seem to be consistent with one another.
    What should *not* be happening, is unallocated sections should
    not be called partitions! An unallocated section is... unallocated.
    It doesn't have an identity.

    I mean, I've seen stranger things (try to figure out partitioning
    on a Macintosh disk sometime), but whatever is going on with your
    machine is pretty weird.

    The disktype utility from sourceforge, is pretty good as a
    cross-check of what other things see. But to run it in Windows
    you'd need Cygwin, and otherwise, you'd need to run a Linux LiveCD.
    That tool really needs an independent PC port, one with no
    DLL dependencies or other crap like that.

    Paul, Jun 11, 2014
  7. zaqxws

    zaqxws Guest

    Note the new drive listed is my USB key!
    zaqxws, Jun 11, 2014
  8. zaqxws

    Paul Guest

    The program is likely using Linux/Unix line terminations, which
    counteracts Google Groups tendency to use whatever line termination
    it wants to use.

    I have no idea what the "lseek err Invalid argument" is, unless it is
    areas of the disk that are unreadable. What could be happening, is
    there aren't an integral number of cylinders on the disk, and that's
    what the scan is hitting. The software already knows the drive
    size, so it shouldn't be LSEEKing past the end.

    I don't understand why you have two of these lines in your log.
    That's probably not a copy/paste error. My log only shows
    one entry for my single partition, in my test scan.

    1 P HPFS - NTFS 0 32 33 45600 32 32 732564000

    It refers to both a /dev/sdd and a drive G:. It implies
    based on size, that G: is the partition on the /dev/sdd USB key,
    but still pretty weird. Looking at my log, mine does something
    similar for a "non HDD" drive.

    The software should be using only block-level naming when doing
    stuff, so it would make sense for it to be using the /dev consistently.

    OK, so going in we have
    StartCHS <..EndCHS...> Length

    HPFS - NTFS 1 5 5 364801 5 4 5860512000 [Expansion Drive]

    and the scan result says

    * HPFS - NTFS 1 5 5 364801 33 32 5860513792 [Expansion Drive]

    The scan has concluded that your 350GB partition needs to be a tiny bit
    larger to properly contain the partition. It almost looks like
    a "GParted accident", where someone does a resize from Linux,
    and the physical and virtual partition lengths don't properly
    match. The physical never exactly matches the virtual, but the
    physical envelope has to be big enough to hold the virtual.
    (A partition can be a fraction of a cluster larger than the
    nice round number of clusters used by the actual file system.
    You can't have declared clusters "hanging outside" the partition
    space, or attempts to write them will fail and the partition
    will be corrupted.)

    This would be the desired situation - physical same size or
    larger than the virtually declared file system size. According
    to TestDisk, currently your virtual is a tiny bit bigger
    than your physical. That's my interpretation of what it is
    telling us.

    <---------- Physical ----------> (as recorded in the MBR)
    <------- Virtual --------> (as recorded in the file system header)

    If I were doing it, my next steps would be:

    1) Make a backup of the drive. I would use a "dd" backup, and pipe
    it to gzip so it'll fit on some other storage. Otherwise, I'd
    never be able to fit a 3TB drive onto any other storage I have.
    And hope that the "unused" parts of your disk are easily
    compressible. Making backups is for safety. If I were to use
    Acronis or Macrium, I don't know if they would deal with the
    current mismatch properly, which is why I would use "dd".
    I would treat it as if the "drive was in trouble".

    2) Go back to TestDisk, do the scan as before, accept the new
    computed MBR and write it to the drive.

    3) Reboot (so we can be sure the OS sees the new relationship
    between physical and virtual file system geometry)

    4) Once we're back in there, run an initial CHKDSK and see if
    it complains. If all OK, do another run where you let CHKDSK
    attempt to repair stuff.

    If (4) fails, return to the backup in (1) and restore it.

    Paul, Jun 11, 2014
  9. zaqxws

    zaqxws Guest

    Just a quick response to report where I am I will reply in more detail later.

    Firstly I ran a full scan in hdtune and it reported bad blocks 0.5% bad blocks
    pretty much all in the third quarter of the disc. Would running something like checkdisc cure them or mark them as out of bounds?

    Also I downloaded something called seagate tools, not supposed to work on 3TB and above but I game it a go anyway and it completely froze my PC very early on, so so much for that, hard to power off, about the first time I've had to do that on this machine.

    Not to sure what the lseek error is, maybe something to do with this

    "_lseek returns the offset, in bytes, of the new position from the beginning of the file. _lseeki64 returns the offset in a 64-bit integer. The function returns -1L to indicate an error. If passed an invalid parameter, such as a bad file descriptor, or the value for origin is invalid or the positionspecified by offset is before the beginning of the file, the invalid parameter handler is invoked, as described in Parameter Validation. If executionis allowed to continue, these functions set errno to EBADF and return -1L.On devices incapable of seeking (such as terminals and printers), the return value is undefined."

    So not too sure what is happening, I think it positioning a file pointer tocertain positions in a file, but because it has previously read rubbish form the disc it is passing invalid values perhaps. Just guessing at that.

    Here is another description

    I think I might have used that myself when I used to do some programming, but that was a long time ago and I can't remember much lol.

    Regarding the two identical lines I think that the documentation says that is because things are real bad. Definitely remember reading that and it said it was because it was a bad partition. I don't remember the exact wording...

    Found it!!

    "The first partition is listed twice which points to a corrupted partition or an invalid partition table entry.
    Invalid NTFS boot points to a faulty NTFS boot sector, so it's a corrupted filesystem.
    Only one logical partition (label Partition 2) is available in the extendedpartition. One logical partition is missing"

    I have looked at the drive via Linux, well connected it anyway, maybe that did something, but I don't think it should have, I only tried to read it. (my memory is terrible!!) pretty sure I didn't do anything not least becauseI would not know how to.

    As for the rest of of it I don't have a drive big enough to back up only the 2TB whcih is less than that and also in 2 partitions, plus it is not in the machine, so I won't be attempting to do anything like that for a while not least because I am not familiar enough with so of what you are talking about yet, ie dd? is that linux??

    Anyhow I will post this now because it might change things somewhat, ie thepartition info might be invalid or whatever.
    But I will just post this for the time being, I need to let some of the stuff sink in!

    Thinking also about running a hdtune on my new 2TB drive as that has made some unpleasant noises!! Thin I will start doing that because they take a long time!
    zaqxws, Jun 11, 2014
  10. zaqxws

    zaqxws Guest

    Just a quick up date I note HD tune says the 3TB drive is 2199GB? Is that significant? Isn't that the XP drive size limit.

    Also I remember now the drive same with some backing up software on it so it must already have been partitioned and formatted? I mean all USB drives probably arrive formatted? I can't remember about the 500GB external USB drive I had before.

    The only time I ever remember doing anything to do with partitions is when I have been cloning a drive in ACRONIS? or some other similar program, I ampretty sure I have never partitioned any drive, other than via a clone.
    zaqxws, Jun 11, 2014
  11. zaqxws

    zaqxws Guest

    Oh an d I won't be doing hdtune on the 2TB drive now because it is not in the machine and it takes ages to run which means I can't look at the 3TB drive, unless I put both in, not sure I want to do that yet though.
    zaqxws, Jun 11, 2014
  12. zaqxws

    zaqxws Guest

    Oh this is interesting I think it is the source code for testdisk or some of it.
    zaqxws, Jun 11, 2014
  13. zaqxws

    Paul Guest

    You were only using a small percentage of the 3TB drive. And
    this makes it easy to back up your drive. The backup might
    even fit on one of your smaller drives.

    The 350GB partition is near the front of the drive. The HDTune errors
    you see later on the drive, may not overlap the 350GB partition.

    CHKDSK can only work with the 350GB portion. The unallocated portion
    of the disk, CHKDSK has no reason to be doing anything to that
    area of the disk.

    If the 3TB drive is bad, you want to get the files off it.

    If the 2TB drive is bad, you *don't* want your backups on there,
    no matter how you make them.

    Whether the 3TB drive can be backed up, depends on a few things:

    1) Drives are split into two piles. "Healthy" drives, can be backed
    up with Macrium Reflect Free, Acronis, or similar. These programs
    make the partition "quiet" using VSS, then they do "intelligent copies".
    In an intelligent copy, only a fraction of the drive is copied. In
    the case of your 3TB, you have a 350GB partition, and it might not even
    be full. To use Macrium to back that up to a .mrimg file, would take
    less than 350GB, guaranteed. If the partition had 175GB of files on it,
    you need 175GB of storage space for a backup.

    2) Drives that are "unhealthy", must be treated differently. Backup software,
    if run on such drives, will easily error out, half way through the partition.
    If a read error happens, most utilities of that sort, stop the backup.
    You currently seem to have no read errors in the 350GB area, so it might
    still be worthwhile using Macrium or Acronis. The partition *must* be
    mountable, and healthy enough to pass CHKDSK without a problem. If a
    partition can't do that, it may not be healthy enough for a regular
    "intelligent" backup.

    3) For a partition that is known to have read errors in it, you use
    ddrescue. You would be doing sector by sector backup. Sectors with errors,
    you attempt to copy them on a second (or subsequent) pass. I think a
    downside to ddrescue, is the storage area for the copy, would need to be
    as big as the thing being copied.

    Since your valid partition is in the first 350GB, you could ask
    ddrescue or any other flavor of "dd", to copy just slightly more than
    350GB. The other part of the 3TB drive, at the moment, is irrelevant.
    There is no data in it. And no need to copy it. Copying the MBR and
    the first 360GB or so, should be plenty. And that would mean your backup
    would occupy 360GB on your 2TB backup drive.

    So for me, the backup attempt is do-able with the materials at hand.

    And definitely, test your new 2TB drive. If it's sick, take it back.


    As a result of this thread, I started shopping for another drive
    for myself. I discover that the WD FAEX family is now out of production
    (a 512 byte/512 byte drive), to be replaced by some other Advanced Format
    crap (4096 byte/512 byte). I wouldn't have minded the AF part of this,
    except user reviews say the new drives are "laggy" and slow. Just what
    a customer expects in a new drive :-( So it means I have to re-think my
    backup strategy, throw away several terabytes of backups, and start again
    using just the drives I currently own. Rats! If I need new drives in
    the future, I don't know where to go next. I expected WD to maintain the
    same philosophy in drive design (considering the price they want for
    those drives), and instead they just want to make crap. Screw them.

    Paul, Jun 11, 2014
  14. zaqxws

    zaqxws Guest

    I am not sure if that partition is mountable or not, indeed how do I know if it is? It is assigned a drive letter in disk management but does not looktoo good in the folder listing just shown as local dick F: with no other info regarding the size of anything.

    I am thinking maybe I could put the 2 TB drive in an older USB2 enclosure and back up onto it like that. Alternatively I could put in the machine as the boot drive. I'd probably want to figure out how to use the bios to set the boot order first.

    Also I need to be confident enough to use the programs, ie to know what to do, I can try can back up to USB perhaps?

    Regarding drives, I am a bit wary about large drives, don't seem to have had much luck with them. perhaps first thing I should do is check the 2TB drive has no bad blocks on it. I think I cam do that in the USB, it's easier than installing in the comp (I hope!).

    As for drives being slow, slow and safe is better than fast and unreliable,I always used to look for fast drives and was disappointed if I found minewas one of the slower ones, but a working slow drive is better than a fastdead one.

    OK I have the 2TB in the USB drive and it seems OK, passed a quick scan, could not seem to read the smart stats though, maybe becuase it is USB? also the temperature comes up as -C, but again because in USB.
    Running a proper scan however I think it will take forever as it is at USB2speed.

    Worse still it has already found 2 bad blocks out of 6 (5th and 6th) and now 7th!!and 8th!!, although it does say "damaged blocks 0.2%" but I guess it is assuming all the rest are healthy (pretty unlikely by the looks of it)9th is also bad now, and hdtune keeps '(not responding)'. 10th also came up as bad!!
    I am wondering if it would be better ran in the machine.
    I will let it run for a while, put I think I will have to abort it as it isso slow.
    I want to check the 500GB drive that came with this new machine to see whatthat is like. 11th block came up bad to.
    zaqxws, Jun 11, 2014
  15. zaqxws

    zaqxws Guest

    Aborted that scan every block was coming up red. Then I could not quit hdtune found I had 3 td tune processes running.
    There is a possibility the USB cable was not connected correctly, but I am not sure.
    I am about 20% through the 500GB drive that came with the new machine and no errors so far. When that is finished I will try scanning the 2TB drive with it in machine to confirm the errors are real. Will have to return it if it gives the same errors. Would want to scrub any data on it first assuming I can write to it. Looks like this scan will take nearly another hour.
    zaqxws, Jun 11, 2014
  16. zaqxws

    Paul Guest

    When I give a recipe, my approach is cautious, because
    I'm not there in person. So when I say "make a backup" of
    the busted item, I'm trying to hedge my bets, and maybe
    give you two opportunities to get the files back.

    I don't know what is wrong with the partition. The physical
    dimension of the partition seems to be smaller than the virtual.
    TestDisk could fix that for us.

    Without a backup, we could try a "baby step". TestDisk does not
    do any more than write to the MBR. You can snapshot the MBR
    before and after your TestDisk session.

    Use PTEDIT32 to get the "table of numbers" from the 3TB drive.
    Only one row of numbers should be currently filled out. The
    others should be empty and all-zeros.

    This sample picture of PTEDIT32, shows two partitions, whereas
    yours will have a single line, similar to the one for entry #2
    in the table. The entry #2 is an NTFS partition.

    Now, when you run TestDisk and have it write a new MBR,
    you can go back to using PTEDIT32 after a reboot, and have
    another look at the table. The LBA size should increase
    slightly (based on your log file posted). And that would be
    proof of the changes. If you were unhappy at that point in
    time with the results, you can actually type the numbers
    into PTEDIT32 and edit the MBR. The text turns red to help
    you track what you've changed.

    So if you write down the PTEDIT32 numbers *before* using
    TestDisk, you can use PTEDIT32 later to put those numbers
    back if you want.

    But I would still feel happier with a backup in place.


    Now that the 2TB drive seems to be crappy, we'd look at using
    your 500GB drive for a backup.

    This is "dd.exe", a sector by sector copy utility.

    You can get GZIP here for Windows.

    Click the ZIP item in the line shown:

    Binaries Zip 135350 15 October 2007 b24802293f74ab11aaa5786f36c59819

    You can unpack the resulting file
    and look in the bin\ folder for "gzip.exe". You put a copy
    of "dd.exe" from the first package and a copy of "gzip.exe"
    from the second package into your working directory.

    For this example, I've placed my "dd.exe" and "gzip.exe"
    in my C:\Downloads\Example folder. I specified a backup
    of the first 262144*100000 = 26GB of disk sectors. You
    would need to use a larger second number, to get 360GB
    total. My 26GB of disk, was compressible to only take
    17GB. The compression would vary with the type of files.
    If your 350GB partition had 350GB of .vob files from
    DVDs, then the compression would produce 350GB total
    output (movies can't be compressed). The 26GB I tested
    with, was a C: drive, so no hard-to-compress movies
    were used in my test. Notice how the status report
    when the backup and compression is finished, shows
    100000 chunks were input and output - if your drive
    has bad blocks, the transfer could stop early, and
    the two numbers would not match. That's how you can
    tell when a backup is botched (broken).

    Now, in your case, you want to snapshot the first 350GB
    of disk on the 3TB drive. As that is where your data is
    stored. I would take an extra 10GB just to be safe.
    360,000,000,000 divided by 262144 is 1373291.015625.
    I would just round that, and use 262144 and 1370000
    or 359,137,280,000 bytes worth of backup.
    It would help if there was 359GB of space on the
    hard drive. If your data was compressible as was
    mine in the example, you would need (17/26)*359 = 234GB.
    Any estimates on compression are purely speculative, and
    we don't really know what will happen. All we know
    is, in our example, it cannot be more than 359GB.

    Paul, Jun 11, 2014
  17. zaqxws

    zaqxws Guest

    Well maybe some good news at last, I am scanning with HDtune the 2TB with it in the machine and so far no errors, only done 39GB though, but I am well past the point where I got bad blocks, so hopefully it maybe OK.

    What I think happened was the USB connector came loose, of course that will seem like an error is the program is badly designed or does not know what it is doing because of the general all round bad design of software and computers!!!

    No errors so far but gonna take a long time to scan the drive, several hours. 4.5 hours to go I estimate. But will be worth the wait if the disk is 100%

    Just seen you post arrive so I will post this now.
    zaqxws, Jun 11, 2014
  18. zaqxws

    Paul Guest

    So if you wanted to backup the 350GB, you'll have
    room on the 2TB drive. Just leave it inside the
    machine until finished. You can also dispense with the
    compression step, and do a straight copy of the 350GB, like this.
    That's because you have "room to burn" and removing the compression
    step lets it run faster.

    dd if=\\?\Device\Harddisk2\Partition0 of=Y:\mybackup.bin bs=262144 count=1370000

    In that example, you'd need to run "dd --list" first to
    check the names of the various drives, so you know for
    sure you're getting a backup of the first part of the
    broken drive. On my machine, I know I need to backup
    the Harddisk2 disk drive.

    There could be something wrong with the USB enclosure,
    enclosure power supply, or the USB cable itself.

    Paul, Jun 11, 2014
  19. zaqxws

    zaqxws Guest

    Regarding the enclosures, it's hardly a surprise it has problems, the enclosure is just a plastic case, with a few holes in the bottom none elsewhere,so it is practically oven the rising air can't escape and heat can't conduct through the plastic case. Furthermore it is 7200 rpm so it's got more heat to lose and nowhere to lose it.
    My older USB drive had a metal case with holes in the side and was only 5400rpm so less heat and mush easier to get rid of it.

    Is dd a windows command or linux?
    zaqxws, Jun 11, 2014
  20. zaqxws

    Paul Guest

    I gave you links to Windows versions.

    On Linux, those commands are built-in.


    One difference in Linux, is a disk is /dev/sdb
    instead of \\?\Device\Harddisk2\Partition0. But
    much of the rest of it, is the same.

    In Linux you use

    sudo fdisk /dev/sdb

    to list the details of a disk. That gives
    you stuff like size information, so you can verify
    that /dev/sdb is the right one. You can also use
    things like the hwinfo program, which can provide
    a lot of data if you pass the right command line option.

    And "dd" needs administrator or root privileges.
    So a dd with compression in Linux would be something like:

    sudo dd if=/dev/sdb of=- bs=252144 count=1370000 | gzip -c -3 > ~/mybackup.bin.gz

    You pick a naming convention for the files, so you have some idea how
    to undo them later. The disk dump, you could call it mybackup.dd
    if you want. And then tack on .gz to that, to indicate you've compressed
    it. The GZIP compressor is the best space/time tradeoff.
    There are faster compressors, but they don't compress as well.
    Something like LZO or FastLZ perhaps. GZIP isn't as good
    as 7ZIP compression (LZMA) but it's a hell of a lot faster.

    And in Linux, there is a nice port of PIGZ around somewhere,
    which is GZIP, only uses multiple cores of your processor.
    So a dual core processor compresses twice as fast. The Windows
    version of PIGZ, needs an update. I'm forced to use the Linux
    version when I want to do stuff like that.

    Paul, Jun 11, 2014
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.