No connection with WPA PSK - TKIP protection in Vista

Discussion in 'Wireless Networking' started by Mike, Jan 12, 2010.

  1. Mike

    Mike Guest

    Despite all the efforts, I have not been able to connect to a router that has a WPA PSK -
    TKIP protection. I am using Windows Vista. I have read that this is one of Vista's
    unresolved issues, and a registry key change is the only way to fix it. Is it true ? Is
    there a workaround ?? Some help would be appreciated.
    Thanks in advance.

    Mike
     
    Mike, Jan 12, 2010
    #1
    1. Advertisements

  2. Jack [MVP-Networking], Jan 12, 2010
    #2
    1. Advertisements

  3. Mike

    Mike Guest

    Mike, Jan 12, 2010
    #3
  4. Mike

    Mike Guest

    I tried to get to the registry path mentioned in the Microsoft article but I got stuck in
    the "GUID" thread: how do I know which one is which ?? There are many keys coded in hex
    values. :-(
     
    Mike, Jan 12, 2010
    #4
  5. Mike

    Pavel A. Guest

    If you can get dhcp from that router without security,
    probably the registry issue is not relevant.
    --pa
     
    Pavel A., Jan 16, 2010
    #5
  6. Mike

    KWook125

    Joined:
    Feb 19, 2011
    Messages:
    1
    Likes Received:
    0
    I am having the same problem, however this did not fix my issue!

    Helper Class (RNWF MSM Helper Class) Event:

    Wireless Diagnostic Helper Class Event

    For complete information about this session see the Wireless Diagnostic Informational Event.

    Helper Class: Native WiFi MSM
    Initialize status: Success

    Information for connection being diagnosed
    Interface GUID: 899bfcb3-9a85-4da9-baf2-2ca9ef830154
    Interface name: Atheros AR5008X Wireless Network Adapter
    Interface type: Native WiFi
    Profile: Discovery connection
    SSID: RHP 06B
    SSID length: 7
    Connection mode: Infra
    Security: Yes
    Connect even if network is not broadcasting: No

    Result of diagnosis: Problem found

    Root cause:
    Windows cannot connect to "RHP 06B"
    Wireless association failed due to an unknown reason.

    Detailed root cause:
    802.11 connection failed due to status code 1: unspecified failure

    Repair option:
    Try connecting to "RHP 06B" again
    If the problem continues, contact your network administrator or hardware manufacturer for further assistance.



    Event Verbosity:0



    I have tried many suggested fixes, but nothing has worked thus far!



    Fixes attempted: Driver uninstall, reinstall; bios flash; base engine filtering; auto tuning; hkey registry fix



    Machine is a Toshiba Satellite A215 running Vista Home Premium. Router is WPA TPIK encrypted.
     
    KWook125, Feb 19, 2011
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.