NIC connection mystery

Discussion in 'Computer Support' started by nottoman, Mar 19, 2006.

  1. nottoman

    nottoman Guest

    Running Win2k. My onboard NIC stopped working a couple of months ago,
    so I finally installed a USB NIC. It's been working OK but once in
    awhile I have to enable and disable it to get it running. Now I can't
    get online on with my PC, but all other PC's on my home network thorugh
    a Linksys router are connecting fine. With ipconfig/all I get a proper
    IP address and the LAN ip address of 192.168.1.1, but I can't ping the
    router. How can I get an IP assigned to me and not be able to ping the
    router? I've uninstalled the NIC, run WinsockFix, and reset all
    networking hardware several times. There's something down inside this
    beast that needs fixing but I can't figure it out. Share your
    knowledge, this is embarrassing that I can't solve this.
    Thanks in advance
     
    nottoman, Mar 19, 2006
    #1
    1. Advertisements

  2. nottoman

    nottoman Guest

    Could it be that easy?? Read a post where the user uninstalled
    ZoneAlarm and it worked fine. I did and it did. Sheesh. "Wolf"
    "Wolf" Sorry.
     
    nottoman, Mar 19, 2006
    #2
    1. Advertisements

  3. nottoman

    02befree Guest

    Test
     
    02befree, Mar 19, 2006
    #3
  4. Trying to get things clear.
    you said that the IP of your computer with the potentially bad NIC is
    192.168.1.1 ? (I'm only asking because this IP is conventially the router /
    gateway address..) ... in any case, that doesn't really matter. I just want
    to make sure I'm referring to the right devices when we're working on this.

    are you running DHCP service on your router? ... or somewhere else? have you
    tried assigning an IP manually instead of DHCP and see if that makes any
    difference?
    Did you look for any updated drivers for your NIC, or firmware updates
    perhaps?

    I don't think you are doing anything wrong with this, something is not
    working right.

    By the way... you did say that in the beginning, your USB NIC would stop
    working until you disable and reenable it, and now it's not working any
    more? so basically it went from bad to worse to not working? (that might be
    a sign that your hardware might be bad) ... go ahead and try the couple of
    things I suggested first and then we'll go from there..
     
    Georges Khairallah, Mar 19, 2006
    #4
  5. nottoman

    Mike Easter Guest

    Why USB instead of PCI? The PCI bus seems like a better place for a nic
    than usb.
    That does seem strange.

    On my system, the router is 192.168.1.1 and each of the machines is
    assigned .100 and .101 etc
    My first choice would be a PCI nic. The last time I had something
    spooky going on I needed to flash my router's firmware. That was
    interesting. Very different from a bios flash.
     
    Mike Easter, Mar 19, 2006
    #5
  6. nottoman

    02befree Guest

    Thanks for all the suggestions. Working now. We'll see if ZoneAlarm
    was the only culprit.
     
    02befree, Mar 19, 2006
    #6
  7. Ooh yeah that actually makes sense. I haven't used Zone Alarm in a long time
    so I'm not sure how it works, but the Software firewall I use (Kerio
    Personal Firewall) requires to explicitely specify an trusted interface, and
    if you don't it blocks all traffic to it .. so I wouldn't be surprised if
    that actually solves your problem..
    Now you should be able to reinstall Zone Alarm (although I do recommend KPF
    instead :) ).. and then look at your settings to see if you can allow that
    adapter to be trusted by the ZA.
     
    Georges Khairallah, Mar 19, 2006
    #7
  8. nottoman

    02befree Guest

    Thanks. ZoneAlarm has worked well for me, but somehow the settings got
    changed or corrupted to create the problem.
     
    02befree, Mar 19, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.