Newbie: Cisco Routing Subnet Zero - Inconsistent Address and Mask

Discussion in 'Cisco' started by gseedy, Apr 11, 2005.

  1. gseedy

    gseedy Guest

    Hi All,
    Im new to cisco and I am trying to configure a new cisco 1721 router.
    My intention is to keep our 2 networks more or less seperate except to
    send small amounts of data to and from each other when necessary (i.e.
    keep network traffic seperate). One network is using the range - with the sunet mask of and
    uses a DHCP server. The other network, which hasn't been setup yet, I
    would like to use the range - with the same
    subnet mask of but IP's will be statically assigned.

    I need the DHCP'ed PC's to be able to access the statically assigned
    PC's on the other network for data sharing.

    As I'm new to cisco I was hoping someone would be able to give me some
    pointers as to what needs to be configured on the router.

    So far what I have done is:
    Enabled fastethernet0 with a no shutdown command
    Issued ip subnet-zero command in the config section
    Set the ip address of the interface to
    'Tried' to map route to switch using

    This last command fails and returns the message inconsistent address
    and mask. Whilst experimenting I got it to map successfully using the
    mask but as I want both networks on the subnet I need to get it working with the other subnet.
    zero subnets although a ip subnet-xero command show allow this. I've
    tried this and am still getting an inconsistent address and masak

    Anyone got any ideas??
    gseedy, Apr 11, 2005
    1. Advertisements

  2. gseedy

    RobO Guest


    Looks to me like you are not putting the correct route statement in,

    If the networks + are directly connected to the
    router then you dont need to add a route statement.
    But if its not then your route statement would look like this:
    ip route [interface]

    If you type:
    "show ip route"
    What is the output of the command.

    Do you have an extra WIC-1ENET on the 1721 and where is the switch
    connected to?


    RobO, Apr 11, 2005
    1. Advertisements

  3. The "inconsistent address and mask" message means that the address part
    of a static route included some bits that are masked off by the mask.

    ip route ...

    the .1 at the end of the address is masked off by the .0 in the mask.
    This is an error check that Cisco added, to catch cases where you used a
    too-large mask. The correct statement would be:

    ip route ...

    But, as the other poster said, you don't need to create static routes
    for subnets that are ddirectly connected to the router.
    You're not using the zero subnet, so why do you think this is relevant?
    In fact, you're not using *any* subnets, you're using ordinary class C
    address blocks.
    Barry Margolin, Apr 12, 2005
  4. gseedy

    G Guest

    Thanks for your help. The main problem I was having was not knowing
    about the interface part of the ip route statement, and I was trying
    to figure out the ip address of the interface rather than the name.
    Anyhow, despite a crash of the IOS which had to be reinstalled, I have
    now got it working as I wanted it to be working.

    Thanks for your help.
    G, Apr 15, 2005
  5. gseedy


    Mar 25, 2009
    Likes Received:
    (config)#ip route
    %Inconsistent address and mask

    Any idea?
    rex.mbr, Mar 25, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.