New HD help needed please

Discussion in 'Computer Information' started by dfrog, Sep 25, 2004.

  1. dfrog

    dfrog Guest

    Trying to help a friend with IBM PC - Win 98ME - AMD 600 - 32mb ram - to fit
    a new hard drive.
    his other one had developed lots of currupted areas, and we were advised to
    fit a new hard drive
    New hard drive is WD 40GB (identified by BIOS on primary ide master)
    From IBM Recovery Disk I chose 'Format and reload original system'
    'Recovery Proceedure' flashes briefly on screen, then very quickly vanishes
    followed by ' Computer will now restart' as part of process.
    This proceedure then continues to loop.

    Then tried a Win ME bootup floppy which reports 'No FAT or FAT32 partition'
    use FDISK at prompt to format.
    This reports 'No drive installed'

    Within the Diagnostics feature of the IBM recovery disc, the WD 40Gb hard
    drive is identified, but there is also a 'Not installed' report alongside
    'Fixed disks'?

    Have connected an old 2GB hard drive with Win 98 OS to the same Ide cable
    and this boots up OK, which makes me think there is not a problem anywhere
    else.

    There is probably a simple part of the proceedure which I am missing and I
    would really appreciate any help you can offer.

    dfrog
     
    dfrog, Sep 25, 2004
    #1
    1. Advertisements

  2. dfrog

    Anan Amis Guest

    Have you set the hd jumpers correctly?
    Did you leave the old hd in as slave?
    You need more than 32mb ram, 98 will run with 8 but not very well, I don't
    know about ME as I installed it once and it didn't work as well as 98 so I
    went back to 98.

    If you still get 'No drive installed' with FDISK at prompt to format after
    you do the following, You might have a bad drive.
    Have you used the WDDIAG? It should be on the disk that came with the new
    drive.


    The following is from a previous post. I don't remember who originally
    posted it,. Wizard?

    You must "sys" the drive to
    correctly load the OS onto the drive, first. You must also set the drive
    active, first. Here is the way to do it all:

    1) Remove original drive and install new one as C:
    2) Booting from a (win 98) floppy use Fdisk.exe to create partition & set
    active
    3) Use Format.com to format drive
    4) Use sys.com to make it bootable
    5) Shut down again and reinstall your original drive as C: (Master) and
    now install the new drive as D: (Slave)
    6) Reboot your OS. It should boot up exactly as it did before, only now
    your new drive should be there as D:
    7) Open a DOS window (not shut down & restart in DOS mode)
    8) Type "xcopy32.exe c:\*.* d:\ /E /H /R /Y /C" (no quotes)
    9) Shut down once again and Remove C: drive and replace with D: (copied)
    setting the jumpers to stand-alone (or master).
    10 Reboot. If you followed these instructions to the letter you will be
    just as you were originally.
     
    Anan Amis, Sep 25, 2004
    #2
    1. Advertisements

  3. dfrog

    Payne747 Guest

    I would dump the IBM tools and try a newly created Win98 boot disk (made
    from another win98 machine), then fdisk the disk. Delete all partitions
    and recreate the primary partition. Then format c:.

    If that does not work let me know and i'll send you the IBM Hard disk
    fitness test utility. It will let you know if anything is physically
    wrong with the new disk.

    btw, what make of disk is it?
     
    Payne747, Sep 25, 2004
    #3
  4. dfrog

    dfrog Guest

    Anan Amis,
    Thanks for your response.
    I have set the jumper to 'master' (this is verified in BIOS)
    I didn't leave the old hard drive in because I considered it to be goosed
    (friend told me that he had used computer OK and when he next tried to start
    up, got a 'No system Disk' error and could not start up)
    His Win ME OS has been up and running for about 1 year or so with 32MB ram
    and this configuration, without problem.
    Didn't get a disk with the new drive. Bought locally at a reputable shop and
    so will persue this.
    Thanks for the 'previous post info' but, my problem lies at stage 2, ie when
    I try FDISK I get a report saying 'No Disk installed' (GULP) so that seems
    to prevent me going any further.
    Am I right in thinking that 40GB is not too big?
    Still in need of help

    dfrog
     
    dfrog, Sep 25, 2004
    #4
  5. dfrog

    dfrog Guest

    Payne747
    Thanks for your response.
    I downloaded a winME bootdisk from bootdisk.com and used that to try to
    start the machine.
    I got the 'there is no partition' report and to FDISK, which I did, and then
    got the 'No Disk Installed', which stopped me going any further.
    The Hard disk is a Western Digital 40 GB
    Appreciate your help and still need more

    thanks
    dfrog
     
    dfrog, Sep 25, 2004
    #5
  6. dfrog

    Thor Guest


    Your system BIOS may have a >32GB drive size limitation. Try setting the
    and instructions) and then see if the system can detect and format the
    drive. If it can, then you have the limitation, and you may want to seek out
    a BIOS update to try and resolve it.
     
    Thor, Sep 25, 2004
    #6
  7. That old computer probably cannot use a hard drive that large. (People
    need to check those specifications first, but seldom do.) I had a
    Compaq once, and the manufacturer said 6.8 GB was maximum. If you
    don't have the book, maybe the IBM site has some insight.
    It may be possible to use the fdisk process to manually define your C
    drive to that maximum allowable size. Then use FAT32 assuming it is
    more than 2 GB.
    Sounds like he should trade that 40 GB for the 2 GB that works. <g> KK

    In response to:
     
    keith kichefski, Sep 25, 2004
    #7
  8. dfrog

    dfrog Guest

    Thanks for that Thor,
    It's going to be tomorrow now before I can get 'hands on'. Yours is an issue
    I'll follow up
    dfrog
     
    dfrog, Sep 25, 2004
    #8
  9. dfrog

    dfrog Guest

    Thanks Keith,
    It's going to be tomorrow before I can get any further with this job now.
    The idea of the 2Gb drive has already flashed through my mind also <g>, but
    I'm determined not to be beaten.

    dfrog
     
    dfrog, Sep 25, 2004
    #9
  10. dfrog

    Ross Durie Guest

    1. Western Digital drives have a master(+ slave), slave and single disk(+ no
    slave) jumper setting.

    2. EZBios can be dowloaded from WD to configure the drive under a non
    supported BIOS it won't then allow booting from the CDROM drive in install
    recovery.

    3. Recovery CDs only install to partitioned and formatted drives.

    You may need a HDD that can be jumpered to 32 GB, e.g., Samsung.
     
    Ross Durie, Sep 26, 2004
    #10
  11. dfrog

    Payne747 Guest

    Another messy way round it (after making sure your BIOS is updated) is
    to prepare the disk in another machine with Windows XP or 2000, simply
    connect it up as slave and then use Window's Disk management tools
    (Right click My Computer->Manage, Disk Management) to format the
    partition as FAT32.

    The new disk will then have a clean partition and correctly formatted,
    getting round the FDISK problem. Other then that, Keith is most likely
    correct in that the machine most likely does not support large disks.

    Have you need enabling large disk support when FDISK first loads? It
    should detect a large disk and ask if you want to enable support for it,
    if you are saying 'no' here, the disk will not be detected.
     
    Payne747, Sep 26, 2004
    #11
  12. dfrog

    dfrog Guest

    Payne747
    Thanks for your continued help.
    I've got to the stage now where my head hurts!
    This is what I've done today:-
    I DID have a jumper problem. I found conflicting positions for jumper on
    drive itself and from Western Digital website, so I changed to website
    advice for the WD400BB hard drive.
    I downloaded Data Life Gaurd from WD site on my machine and used it (floppy)
    to format and partition the new hard drive. Drive is now shown and shown as
    installed.
    I set BIOS to boot from CD first and put IBM Recovery Disk1 in & powered up.
    Went for a Full Recovery - Easy Restore (??)
    Got an Error # 91 - Disk Mgr has been detected on Drive 0 but Disk Mgr not
    running. If you are booting from a floppy remove and reboot, press and hold
    Spacebar as computer restarts. When prompted insert your boot floppy and
    continue booting.
    Tried this 'hold spacebar' and it didn't work.
    Got back to same stage again and hit OK which took me into Product Recovery.
    I then got an error# 1826 - Error : free space not found
    Hit OK and recovery continued.
    Computer rebooted and than asked for IBM recovery disk2. Lots of files were
    unzipped, request to remove floppy and Cd and press Enter to restart.
    Only to be asked then for Recovery Disk1 and for it to go into the full
    recovery process again.
    I've tried every configuration in BIOS for Start up sequence, and without
    the Win ME boot floppy in get 'No OS can be found', with the boot floppy in
    I get to a Dos prompt A:\ , and no matter what I enter here (CD ROM:\ setup
    or setup.exe or oemsetup........or C:\ setup or setup.exe or oemsetup......I
    just get 'Bad Command'
    At the dos prompt, a 'C:\dir' shows an IBM folder, a couple of other
    folders and a WIN DIR
    I really really hope that you or someone else can help

    dfrog
     
    dfrog, Sep 26, 2004
    #12
  13. dfrog

    Robert Baer Guest

    One of the things that you did that creates problems, is to use HD
    software provided by the HD maker as well as using *any* so-called
    recovery system.

    You *might* be able to recover by using FDISK to remove all drives and
    partitions from that HD.
    Make sure it is the only HD in the system as Primary Master and
    jumpered accordingly (Master only).
    Then set the BIOS to boot from CD, and using your WinME CD, boot and
    start installation.
    If all is OK, WinME will ask about formatting and partition type; as
    previously mentioned, select FAT32.
    Be advised, that when it re-boots, *quickly* go into the BIOS and
    re-set for Floppy #1, HD #2 and no others; quit & save BIOS settings,
    and then let it boot the second time.
    Also pay attentionto the messages; at some point it will say to remove
    the CD (if you do not, it will loop and re-do from the second part of
    the install procedure).

    IF use of FDISK does not help, you must completely wipe the hard drive
    and start from scratch ("..the only HD in the system as Primary
    Master..").
     
    Robert Baer, Sep 26, 2004
    #13
  14. dfrog

    dfrog Guest

    Thanks Robert,
    I'll go with your advice tomorrow when I can get at the machine again. Your
    *any* so called recovery recovery system comment makes me think you're not
    overjoyed by such. The only Win ME there is, is on IBM's recovery CDs so I'm
    limited by that.
    Thanks agian

    dfrog
     
    dfrog, Sep 27, 2004
    #14
  15. dfrog

    Robert Baer Guest

    ------------ SNIPped for brevity -----
    Do you mean that if you boot from that CD, you do not get options
    something like to "boot to DOS with CD support", "boot to DOS without CD
    support" and something like "boot to install"??
    And then using that third mentioned option (actual order may be
    different), WinME is not installed?
    Perhaps I should send you a "pure" WinME CD..
     
    Robert Baer, Sep 27, 2004
    #15
  16. dfrog

    dfrog Guest

    Robert,

    sent you mail

    dfrog
     
    dfrog, Sep 27, 2004
    #16
  17. dfrog

    Robert Baer Guest

    I may have missed it; earthlink traps a lot of messages as spam.
    Please try again either at robertbaerATearthlinkDOTnet or
    bobbaerATearthlinkDOTnet or both, making the obvious symbol
    replacements.
    Also use "New HD help needed" for the subject line; that may help as
    well.
     
    Robert Baer, Sep 28, 2004
    #17
  18. dfrog

    dfrog Guest

    Robert,
    sent email to 'bob' at 10.13 am GMT

    regards
    dfrog
     
    dfrog, Sep 28, 2004
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.