new 6509 "Gigabit Ethernet x/x not a switching port"

Discussion in 'Cisco' started by thejayman, Nov 14, 2005.

  1. thejayman

    thejayman Guest

    Hi all,
    Need a bit of you expert advise on the 6509 I have just got my mits on.
    First of all, I have connection via the console port on the sup720-3b,
    even though the set interface sc0 x.x.x.x x.x.x.x just give me an
    error.
    I cannot connect to the router via the switch console 15 command. I
    assume that i am runnign in NATIVE mode as the "set" commands seem to
    be non-existant.

    I thought i would push on and get some vLans set up etc to see how far
    we could get.
    When I try to put an intyerface in to a vLan

    switchport access vLan x
    I get the "Gigabit Ethernet x/x not a switching port".
    Not be an expert at all here, am i running in Layer2 mode? How to I get
    it Layer3?
    I did not have this problem witht the 6519 we have.

    Please help a know nothing IT guy.
    Thanks
     
    thejayman, Nov 14, 2005
    #1
    1. Advertisements

  2. thejayman

    Rex Johnson Guest

    Turn the port into a layer 2 port by:

    config t
    int gi x/x
    switchport
    switchport access vlan y
    no shut

    Then you create a layer 3 vlan interface

    int vlan y
    ip add a.a.a.a b.b.b.b
     
    Rex Johnson, Nov 14, 2005
    #2
    1. Advertisements

  3. thejayman

    thejayman Guest

    Thanks Rex,

    In my rush to get this done completly forgot to add the first plain
    "swithport" command.
    J
     
    thejayman, Nov 14, 2005
    #3
  4. thejayman

    stretch Guest

    You need to enter switchport like this:
    SWAITC6513(config)#Interface fa4/1
    SWAITC6513(config-if)#switchport
    SWAITC6513(config-if)#switchport access VLAN 21

    The switchport is enabled by the first entry of the command
    "switchport" by itself.
     
    stretch, Nov 14, 2005
    #4
  5. thejayman

    stretch Guest

    You need to enter switchport like this:
    SWAITC6513(config)#Interface fa4/1
    SWAITC6513(config-if)#switchport
    SWAITC6513(config-if)#switchport access VLAN 21

    The switchport is enabled by the first entry of the command
    "switchport" by itself.
     
    stretch, Nov 14, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.