Networking only one way

Discussion in 'Home Networking' started by Blair, Jun 12, 2006.

  1. Blair

    Blair Guest

    I have a laptop and a desktop connected via a router and I can see and
    access information from the laptop to the desktop.(Both XP)
    But when |I try and access the informatuion from the desktop I get a message
    that I may not have permission to access the files on the desktop
    I have checked the settings on the laptop and desktop and they appear to
    give permision but I may be missing something
    Can anyone help please
    Blair
     
    Blair, Jun 12, 2006
    #1
    1. Advertisements

  2. Blair

    OhNo Guest

    Firewall..........do you have your Firewalls set to accept each comp
    (Trusted Zones).
     
    OhNo, Jun 12, 2006
    #2
    1. Advertisements

  3. Blair

    Blair Guest

    Thanks I have looked at the Firewall settings and alltered them but I can't
    find how to add the respsective PCs as allowable exceptions. I tried
    browsing but can't define it that way
    Also after all my alterations I cannot access the desktop from the laptop
    So I feel completely lost.
    Can you help?
    Blair
     
    Blair, Jun 12, 2006
    #3
  4. Blair

    robert Guest

    Disable the Firewalls and see if that helps - if it does its your
    firewall settings, if not look elsewhere.

    Robert
    Robert
     
    robert, Jun 12, 2006
    #4
  5. Blair

    OhNo Guest

    try this info first

    http://www.echolink.org/firewall_solutions.htm
     
    OhNo, Jun 12, 2006
    #5
  6. Blair

    Trev Guest

    add the ip adress of laptop somthing like 192.0.0.2
     
    Trev, Jun 13, 2006
    #6
  7. Blair

    MED Guest

    Hi,

    Do what the guy said above and disable the firewalls.

    Next, check to see if you are using simple or advanced file sharing. If you
    use advanced file sharing, you are just being able to modify the NTFS
    permissions on the file system.

    If you DO have access to the security tab on the properties page of the
    folder, check to see if there is a user or group that can access the
    folder/files at the desired level. Also, remember to check the permissions
    of the shared folder (from the share tab).

    The other solution is to connect the root of the drive that holds the
    information via the administrative share (c$, d$ etc). Either add a network
    drive and use the c$ as the sharename and change the user that connects to
    that of one on the other computer that would have access, or access the
    share directly via \\ipaddressofmachine\c$ from windows explorer. You
    should be prompted for a username/password.

    HTH
    Mike.
     
    MED, Jun 14, 2006
    #7
  8. Blair

    Blair Guest

    Thanks to all who sugested disabling the Firewalls. I have done this on
    both PCs
    I also read "Setting up a small ntework on Windows XP Home Edition" and
    there it was recommended to have the IP Address done automatically.
    I found that on one PC the IP address was given and on the other it was
    automatic.
    Having made them both automatic I now have both PCs listed on the desktop
    and available. also both are listed on the Laptop but when I click desktop I
    get \\Desktop is not accessable. You might not have permission to use the
    network resource. The network path was not found
    I am grateful to you Mike for your help but I can't follow all your
    instructions because I don't understand the terms
    Where do I look for advanced or simple file sharing
    As far as sharing is concerned |I have made all 4 partitions able to be
    shared on both PCs.
    ,.I am lost on the last paragraph.
    Sorry to be so slow on the uptake
    Regards
    Blair
     
    Blair, Jun 15, 2006
    #8
  9. Blair

    John Steele Guest

    What firewall are you using on each of the computers?

    I have seen a problem ,with similar symptoms, that happened when the Windows
    Firewall is used. If this is the case I posted the solution in a newsgroup
    somewhere about 12 months ago. I should be able to find it via Google.
     
    John Steele, Jun 15, 2006
    #9
  10. Blair

    Blair Guest

    I am using the Windows Firewall on both PCs
    I would be obliged if you could find it
    Blair
     
    Blair, Jun 16, 2006
    #10
  11. Blair

    John Steele Guest

    The problem I had was confusing - it depended on what order I booted up my
    three networked computers!

    Here is the link. The same post has been repeated several times.

    http://www.google.com/url?sa=D&q=ht...ccessible+fixed&rnum=2&hl=en#613208f1691dd510

    I recommend however that you use an alternative firewall. I am now using
    Kerio/Sunbelt free firewall.
     
    John Steele, Jun 17, 2006
    #11
  12. Blair

    Blair Guest

    Thanks for your help. It was most interesting.
    But in my case I have turned of both Windows Firewalls
    Unfortunately I believe there is a firewall in my Wanadoo browser but I
    don't know how to turn it off
    Blair
     
    Blair, Jun 17, 2006
    #12
  13. Blair

    Blair Guest

    Just found out how to turn the Wanadoo Firewall off which I have now done
    but makes no difference.
    I still get the message \\Desktop is not accessable. You might not have
    permission
    Also turned each PC on first alternatively but no difference.
    It's so frustrating and probably because of some minor setting!
    Blair
     
    Blair, Jun 17, 2006
    #13
  14. Blair

    OhNo Guest

    Now I read that one sees the other,

    disable ALL Firewalls as you have done now the real test is to ping each
    comp..........open Command Prompt and type ping 192.168.1.* where * is the
    other comps last ip digit............now do you get 4 replies back on either
    comp..........you should on the desktop........as you can access the laptop.

    this is the test I used after changing any Network settings in my first
    attempts to set up.

    the other thing I learned, the painful way, was that some settings take a
    reboot before they come into play.
     
    OhNo, Jun 17, 2006
    #14
  15. Blair

    M60 Guest

    well its taken me some time to find it so here it is.....yes I know it for
    wireless but some bits might help
    System:
    BT Voyager 2000 Wireless Router.
    Clone Desktop (AMD 1200), Windows XP Home, BT 1010 USB Wireless TX.
    Dell Notebook (M60), Windows XP Pro, Intel 2100 MiniPCI TX Card.
    Norton Internet Security 2006 on both.
    Three very good Network webs to also use are,

    1. http://www.practicallynetworked.com/qa/qa20040722.shtml
    2.
    http://compnetworking.about.com/cs/windowsnetworkin1/ht/findaddrwinxp.htm
    3. http://www.michna.com/kb/WxNetwork.htm


    1. Disable ALL Firewall applications, including XPs
    2. Disable Antivirus software.
    3. Set Netbios to enable over TCP.
    4. Run Network Setup Wizard for all computers. This I found to be an
    automatic procedure and the software selected the correct options for each
    system.
    5. Check that Simple File Sharing is enabled (XP Pro only) Start>My
    Network Places>Tools>Folder Options>View Tab. Scroll down to the bottom
    where you will see "use simple file sharing (Recommended)". Tick the box for
    file sharing. Windows Home Edition is pre set and does not require any user
    interface.
    6. Locate and note each computers IP address which should typically be
    192.168.*.*, each computers name and the Network name. See web 2.
    7. At this stage, try pinging each computer to check that they are
    sensing each other. To do this, Start>All Programs>Accessories>Command
    Prompt. At the flashing curser, type in the IP address of the other computer
    then hit the Enter key. Pinging will try 4 attempts to recognise the other
    computer. You will see immediately if contact has been made by the data
    given. Failure to contact will result in Failure to respond statements.
    Another method of attempting contact is to type the other Computers name at
    the command prompt then hit Enter. Again contact is evident by the data
    reported or not so by a failure report.
    8. OK, I am going to assume you have made contact with the other
    computer and visa versa. For each computer, set up the files that you want
    to share. Open Windows Explorer, select the drive that contains the
    file/folder you want to share, right click on the file/folder and select
    Sharing and Security. Under the Sharing tab, in the lower section, tick the
    box that says Share this file. Close Explorer.
    9. Now an Intermediate trial, Start>My Network Places. Within the My
    Network Places window you should see all files/folders that are available on
    the Network that you have just established. In the left plane select View
    workgroup computers and you should see all the computers that are on the
    Network.
    10. If you can see ALL computers and files your ALMOST home and dry. Close
    down the My Network Places window. Go back and enable ONE of the Firewalls
    that you disabled in the beginning. Perhaps start with XPs own. It's better
    to do this one at a time then you can determine which is giving most grief,
    if any. Run step 11 again. If you can still see the files/folders and
    computers then this Firewall is not preventing access. If you cannot see
    files/folders/drives then you need to go into that Firewalls settings and
    look for a Network section that will allow adding IP addresses or names to
    Permit Network Access. If you have located this setup and entered the data,
    try Step 11 again. Norton Internet Security has Network and Firewall
    settings that enable you to add either single, group or a range of
    acceptable IP addresses. For some unknown reason entering individual
    computer IP addresses gave me problems. After much time wasting I used the
    range setting ie 192.168.1.1 to 192.168.1.10. This allowed all computers
    with those addresses access to my Network. Lets say Step 12 was a success.
    enable another Firewall and repeat Step 12.
    11. Lets again assume with ALL Firewalls enabled the Network is 100% and you
    can see ALL files/folders/drives on ALL computers. Shut down ALL computers
    and make a cup of tea or coffee in preparation for the BIG trial. Now, Start
    up ALL computers and try Step 11 again. Lets hope you still see ALL
    file/folders/drives.
    12. If you do not see ALL or some parts don't work correctly, you need to
    double check the Firewall settings to make sure they have not reset back to
    a default setting after the restart.


    When I first went about setting up my wireless Network, I failed to carry
    out Steps 1 to 3 until the very end. This gave me numerous problems and many
    wasted hours of chasing about......so make sure you follow the above
    sequence.

    For further information please refer to these, very useful, web pages. They
    have everything that is required to provide a Network setup. It also helps
    if you read them carefully, slowly and more than once to understand and take
    in the information.

    dj
     
    M60, Jun 17, 2006
    #15
  16. Blair

    Blair Guest

    Thanks for your help
    I pinged the Laptop from the desktop OK with 192.168.1.1
    I then pinged the desktop from the laptop and tried 1.0 and 1,2 but with no
    success
    I then checked the IP address of the desktop and it was 192.168.1.117
    and I tried that but no success
    I pinged the Livebox Router with its IP address of 84.68.87.113 successfully
    from the Desktop
    The IP addresses are both set to be automatically selected but I noticed the
    following
    Laptop IP address 192.168.1.132
    Default gateway 192.168.1.1
    Desktop
    IP address 192.168.1.117
    Default gateway 192.168.1.1
    So both default gateways are the same
    I don't understand the difference between Default gateway and IP address but
    I assume that the two default gateways should not be the same?
    How do I fix this?
    Blair
     
    Blair, Jun 18, 2006
    #16
  17. Blair

    OhNo Guest

    sorry I am green on gateways but Google assisted

    http://www.microsoft.com/technet/community/columns/cableguy/cg0903.mspx
     
    OhNo, Jun 18, 2006
    #17
  18. Blair

    Blair Guest

    1 Thanks for your help. I will reply section by section
    2 Have disabled all XP Firewalls and also my router Firewall Have already
    deleted all my Antivirus software
    3 Set Netbios to enablle over TCP
    4 Ran setup on each PC. In the case of the Laptop it found disconnected
    network hardware and listed the Local Area Connection Broadcom 440
    Since this PC uses a wireless connection I ticked "ignore disconnected
    network hardware
    5 I have XP Home so assumed that it did not have this setting


    6 The laptop IP address is 192.168.1.132
    default gateway is 192.168.1.1
    The desktop IP address is 192.168.1.117
    default gateway is 192.168.1.1
    I can ping the laptop from the desktop but not the otger way round.
    I wondered if the default gateway should be the same?

    Have already shared the partitions

    I can see and access all files on Laptop from desktop
    I can see only home when I look at the laptop and when I press home I am
    informed that home is not accessable. You might not have permission.
    At one time I did have both PCs shown but the desktop was not accessable.

    I have yet to read the articles you listed but thought I would let you know
    the present position in case you might spot something
    Blair
     
    Blair, Jun 18, 2006
    #18
  19. Blair

    MED Guest

    Hi Blair,

    Not sure if you are still there, but in case you are...

    The first thing is to make sure you are not vunrible to external attack
    because you have switched off all of your firewalls! When testing the
    connectivity, you can stop the internet connection but leave the router on
    and plugged in.

    The error you get when you try to connect from the desktop to the laptop
    means that:

    1. TCPIP is working fine.
    2. There is something on the laptop stopping you from connecting.

    I assume the following, please change as needed:
    C1 = desktop = 192.168.1.10
    C2 = laptop = 192.168.1.20

    The first thing I would do is (from the desktop):
    1. double click on my computer.
    2. click on 'tools' then 'map network drive'
    3. in the drive field, choose a letter in the folder field type:
    \\192.168.1.20\c$
    4. click on 'Connect using a different user name'
    5. type the username and password you use on the laptop to connect.
    6. click OK, then Finish.
    7. You should have a network drive that points to the c drive of the laptop.

    If the above does not work and you have followed it correctly, change the
    user name to connect with by prepending the computername of the laptop to
    the user name seperated with a backslash "\".

    Again, if this does not work, use Administrator as the user name, with the
    correct password. If that does not work, then there is a program on the
    laptop that stops you from accessing it.

    HTH,
    Mike.
     
    MED, Jul 3, 2006
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.