netvmini.sys still not working on Windows 7 even after driver signing disabled ?! (Windows debug mod

Discussion in 'Windows 64bit' started by Skybuck Flying, Aug 9, 2009.

  1. Hello,

    I installed the netvmini.sys "debug/checked" driver on Windows 7 x64.

    I learned how to deactive "driver signing enforcement" during boot of
    Windows 7 x64.

    Now I boot into Windows 7 and the virtual network adapters are present in
    connection settings and such.

    They have IPv4 and IPv6 bindings and such and local area network addresses.

    I open the "test program". They ("Microsoft Virtual Ethernet Adapter") show
    up in the list.

    I try to sent "IOCTL"'s to them but it says:

    "Failed read".
    "Failed write".

    I suspect this might be because I booted into "normal mode".

    Maybe checked/debug drivers only work in "windows debug mode" ???

    I shall now attempt to:

    1. Boot Windows 7 x64 RTM in debug mode.

    and

    2. Disable driver signing.

    and

    3. Test again to see if this helped ?!

    Bye,
    Skybuck.
     
    Skybuck Flying, Aug 9, 2009
    #1
    1. Advertisements

  2. Ok,

    This time I booted into "windows debug mode" with "driver signing disabled".

    I used WinDbg to make sure that it was in windows debug mode.

    I open the "netvmini" test program.

    It lists a couple of network adapters and such...

    And then I click Action->"ioctl to control device".

    It says:

    "Failed to open the control device: Microsoft Virtual Ethernet Adapter".

    I wonder if this is maybe a problem with "dos symbolic links" ?

    Maybe it can't find it ?

    Bye,
    Skybuck.
     
    Skybuck Flying, Aug 9, 2009
    #2
    1. Advertisements

  3. Second part of solution:

    Test program must be "run as administrator".

    Bye,
    Skybuck.
     
    Skybuck Flying, Aug 9, 2009
    #3
  4. Mystery solved see other post for more details.

    Apperently the example contains no code for the ioctl...

    It just does a "trace message"/dbgprint and a break.

    Bye,
    Skybuck.
     
    Skybuck Flying, Aug 9, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.