netgear wireless router https problem

Discussion in 'Wireless Networking' started by bershtman, Nov 9, 2005.

  1. bershtman

    bershtman Guest

    I have a NETGEAR wgr614v5 wireless router connected to cable internet.
    My desktop connected by wire & laptop wireless.
    I have a problem with laptop to see any of the https sites.
    Please note:
    1.no firewall on notebook
    2.desktop connected with no problem
    3.on laptop SSL ,TSL and so on enabled

    Help, please !
     
    bershtman, Nov 9, 2005
    #1
    1. Advertisements

  2. bershtman

    Malke Guest

    This is not because of the wireless connection. Assuming you have XP,
    you have to re-register the following dll's at the command prompt.

    If you have SP2, you can do it all in one go:

    Start>Run cmd [enter]
    iexplore.exe /rereg [enter]

    Without SP2:

    Start>Run cmd [enter]
    regsvr32 mshtml.dll [enter]

    Click OK when you get the message that DLLRegisterServer in FileName
    succeeded and type "exit" to quit cmd.

    Repeat the same with:

    regsvr32 mshtmled.dll
    regsvr32 urlmon.dll
    regsvr32 softpub.dll
    regsvr32 wintrust.dll
    regsvr32 initpki.dll
    regsvr32 dssenh.dll
    regsvr32 rsaenh.dll
    regsvr32 gpkcsp.dll
    regsvr32 sccbase.dll
    regsvr32 slbcsp.dll
    regsvr32 cryptdlg.dll

    More information about this:

    Troubleshooting Secure Site (WinXP/IE6 SP2)
    http://support.microsoft.com/?kbid=870700

    Troubleshooting Secure Sites (WinXP/IE6 SP1)
    http://support.microsoft.com/default.aspx?scid=kb;en-us;813444

    Sandi's Secure Sites Page
    http://inetexplorer.mvps.org/ie_2.html

    Malke
     
    Malke, Nov 9, 2005
    #2
    1. Advertisements

  3. bershtman

    phi11yphan

    Joined:
    Mar 22, 2008
    Messages:
    1
    Likes Received:
    0
    Actually, had same problem here, and the previous solution listed here did not work for me. Netgear model WNR834M. Couldn't connect to certain HTTPS/secure websites -- mostly of the financial kind.

    My resolution was something I would have never figured, had it not been for a web search. I had to go into the netgear wireless router configuration, navigate to the WAN setup section, and change the MTU settings. Imagine that -- the MTU setting was the problem. I was set on 1500, and that wasn't working for the https website (Chase and Washington Mutual.) Neither did 1492. So, I changed it to 1400... and BINGO. I was finally able to visit the website and pay my mortgage! (Doubt they'd let me use that technical pain as an excuse for a late payment....)

    At any rate, this is really only a workaround; because it's inconvenient to toy with the MTU settings each time I need to visit specific HTTPS websites. And leaving the MTU at 1400 was causing the Verizon router to crash (or drop my internet connection) too frequently; so that wasn't a long-term solution either.

    Good luck!
     
    phi11yphan, Mar 22, 2008
    #3
  4. bershtman

    YoshQ

    Joined:
    Mar 15, 2010
    Messages:
    1
    Likes Received:
    0
    I have this same problem but my router is linksys and the site i'm trying to connect to is secure.mlgpro.com/store/

    what should I set my mtu to?

    and Start>Run cmd [enter]
    regsvr32 mshtml.dll [enter] didn't work, but the rest did

    edit: oh great, 2008... sorry guys lol
     
    Last edited: Mar 15, 2010
    YoshQ, Mar 15, 2010
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.