Netgear DG834G - setting up emailing of logs to an AOL address

Discussion in 'Home Networking' started by Martin Underwood, Jun 9, 2005.

  1. Here's a really stupid question. How do you set up this router to email its
    logs to an AOL address? I've set loads of these routers to send to other
    addresses via other SMTP servers, but I can't make it work to AOL.

    Email address <screen name>@aol.com
    Outgoing email server SMTP.uk.aol.com

    I've tried with authentication disabled and with it enabled using the user's
    screen name and password.

    Without authentication, there's no error message in the log but the email
    does not arrive.

    With authentication turned on, I immediately get an error "use port 587 for
    email". Given that the email facilities built into the router don't allow a
    port to be specified, what do I do? THe user doesn't have any other email
    account whose SMTP server I could use. I'm reluctant to configure it with my
    ISP's SMTP server and my username/password for authentication, though this
    probably would work.
     
    Martin Underwood, Jun 9, 2005
    #1
    1. Advertisements

  2. Martin Underwood

    Spack Guest

    Martin wrote on Thu, 9 Jun 2005 17:16:21 +0100:
    Apparently if you set the email address to use the same domain name as the
    SMTP server the logs will be discarded, hence no error when you don't use
    authenticated SMTP:

    http://kbserver.netgear.com/inquira...m/kb_web_files/n101237.asp&answer_id=81661911

    "In some circumstances NETGEAR routers check that the source and destination
    of email messages are not the same. If this happens, the router's logging
    messages are discarded. (The Reference Manual is not clear on this.) An easy
    way to solve this is to choose a different email server for the router's
    "Send to This E-mail Address" field. So if "Your Outgoing Mail Server" is
    mail.myisp.com (as shown in the manual) then DO NOT use
    for the "Send to This E-mail Address" field. Instead, use an email account
    you have on another server, such as hotmail. E.g., make the send field
    . The other way to solve this is to explicitly open the
    ports for SMTP and POP, 110 and 25. By default, these ports are closed on
    NETGEAR routers. (Other, non-NETGEAR related email problems are also solved
    by opening these ports.)"

    It suggests that opening the SMTP and POP3 ports will cure this - and as the
    email is going to an AOL address on the AOL mail server it should accept it
    mail for delivery on port 25.

    Dan
     
    Spack, Jun 9, 2005
    #2
    1. Advertisements

  3. This KB entry begs the question: "Why does the router check the domain of
    the destination address against the domain of the SMTP server?" Surely the
    usual way that emails would be sent would be to the user's own email address
    which will be on the same ISP as is being used to connect to the internet.
    Not everyone has the luxury of a separate email account.

    It works for my setup but that is because by chance I define my email
    address as 9.co.uk (I could equally well have defined it as
    9.co.uk which is a synonym) whereas the SMTP server is
    relay.force9.net.

    The KB entry vaguely refers to opening ports 25 and 110, but what exactly is
    involved in doing this? I presume I'm opening *outbound* ports. Do I simply
    add a new rule with

    Service: SMTP (25)
    Action: Allow always
    LAN user: Any
    WAN user: Any

    The dropdown service list doesn't mention POP (110), but I presume it's SMTP
    that I need to open anyway and that the KB's reference to POP (110) is
    irrelevant to my problem.
     
    Martin Underwood, Jun 9, 2005
    #3
  4. Martin Underwood

    NBT Guest

    AOL uses port 587 for its SMTP and does require authentication.

    Try :-

    SMTP
    Port 587
    Allow always
    LAN "IP of Router"
     
    NBT, Jun 10, 2005
    #4
  5. Ah. So it doesn't use port 25. Trust AOL to be different. Have they never
    heard of standards?

    Bugger it! The router doesn't offer port 587 as an option. I really don't
    want to have to open up all the ports just to allow non-standard SMTP
    traffic to get through :-(

    I presume it's going to be the same for the customer's DG834G V2 as it is
    for my DG834GT that I've just checked.

    Actually it's worse than that. Even if I was able to open up port 587,
    wouldn't the SMTP program in the router than sends the logs still try to use
    the proper port 25 - it's not configurable.
     
    Martin Underwood, Jun 10, 2005
    #5
  6. : Bugger it! The router doesn't offer port 587 as an option. I really don't
    : want to have to open up all the ports just to allow non-standard SMTP
    : traffic to get through :-(

    Just add it! While the DG834G has a built-in list of "well known services"
    and their ports you can add others. For example I added VNC on port 5900
    and I can then refer to it by name in the firewall rules.
     
    Brian McIlwrath, Jun 10, 2005
    #6
  7. That is not useful in emails sent by the router both because the router
    can not be configured to send mail to TCP Port 587 and also because the
    router's firewall settings do not affect the router's own activities for
    DNS resolution, time setting and mailing.

    If I were an AOL subscriber trying to send mail to an AOL address I would
    try using the MX addresses for aol.com as the mail server, i.e.:

    mailin-01.mx.aol.com
    mailin-02.mx.aol.com
    mailin-03.mx.aol.com
    mailin-04.mx.aol.com

    and do NOT configure the router to use authentication.

    Tony
     
    Anthony R. Gold, Jun 10, 2005
    #7
  8. Martin Underwood

    Bob Evans Guest

    [Port 587]
    RFC 2476 perhaps?
     
    Bob Evans, Jun 10, 2005
    #8
  9. Martin Underwood

    [ste parker] Guest

    Just define your own custom port, then open that.
     
    [ste parker], Jun 10, 2005
    #9
  10. Martin Underwood

    Spack Guest

    NBT wrote on Fri, 10 Jun 2005 12:18:19 +0000 (UTC):
    Only if you are attempting to send message to a non AOL address. If you are
    sending to an aol.com address then port 25 without authentication will work
    fine (or else no AOL.com user would ever receive any email). ;)

    Dan
     
    Spack, Jun 10, 2005
    #10
  11. Unless I'm missing something, you can't do that. The dialogue box has a
    drop-down for the "Service" (ie the port) and does not allow the port number
    to be typed in as an alternative:

    http://www.martinunderwood.f9.co.uk/netgear rule.jpg

    Or am I being a pillock?
     
    Martin Underwood, Jun 10, 2005
    #11
  12. I'll try that, but I suspect that I'll fall foul of the Netgear's idiotic
    rule that you cannot send to an address which is in the same domain as the
    SMTP server's.

    At present I've got

    username =
    outgoing server = smtp.uk.aol.com

    I presume the router finds that both end "aol.com" and quietly discards the
    email. I presume it will also do that if the outgoing server is
    "mailin-01.mx.aol.com". I could try replacing the domain name of the SMTP
    server with its IP address. Maybe that will fool it into letting the email
    go out ;-) Let's hope the router doesn't do a reverse lookup and then match
    the email address against that :-(

    This is a classic case of Netgear documenting a restriction rather than
    removing the restriction or giving a proper workaround like the use of the
    IP address instead of the server name. Given that most people will want to
    send to an email address which is on the same domain as the SMTP server for
    their WAN connection to their ISP, they really should allow email to get
    through.
     
    Martin Underwood, Jun 10, 2005
    #12
  13. What does that say? Does it permit SMTP on ports other than 25? If so, it's
    bad luck on simple SMTP mailers such as the one built into this router for
    emailing its logfiles which can't have its port configured.
     
    Martin Underwood, Jun 10, 2005
    #13
  14. Martin Underwood

    [ste parker] Guest

    Thats why you need to define one first. Go to services (the option
    below firewall rules) and add a custom service for the port(s) you want
    then go back to firewall rules and add a service - your newly defined
    service will be at the top of the dropdown.
     
    [ste parker], Jun 10, 2005
    #14
  15. What leads you to that understanding and what version of the software are
    you running? Although versions later than 1.05.00 are called Beta, they
    are very stable and they have important corrections and improvements.

    If you want to test, feel free to send some logs to my reply-to address.
    You can do instant sends with the "Send Log" button on the Logs screen.
    Where is this documented? I didn't find it in the "Reference Manual for
    the 54 Mbps Wireless ADSL Firewall Router DG834G". Which page?

    Tony
     
    Anthony R. Gold, Jun 10, 2005
    #15
  16. It's not in the reference manual. That's half the problem. It's on a KB
    entry that Spack quoted earlier in the thread:

    [begin quote from Spack]
    Apparently if you set the email address to use the same domain name as the
    SMTP server the logs will be discarded, hence no error when you don't use
    authenticated SMTP:

    <http://kbserver.netgear.com/inquira.../kb_web_files/n101237.asp&answer_id=81661911>

    "In some circumstances NETGEAR routers check that the source and destination
    of email messages are not the same. If this happens, the router's logging
    messages are discarded. (The Reference Manual is not clear on this.) An easy
    way to solve this is to choose a different email server for the router's
    "Send to This E-mail Address" field. So if "Your Outgoing Mail Server" is
    mail.myisp.com (as shown in the manual) then DO NOT use
    for the "Send to This E-mail Address" field. Instead, use an email account
    you have on another server, such as hotmail. E.g., make the send field
    . The other way to solve this is to explicitly open the
    ports for SMTP and POP, 110 and 25. By default, these ports are closed on
    NETGEAR routers. (Other, non-NETGEAR related email problems are also solved
    by opening these ports.)"

    It suggests that opening the SMTP and POP3 ports will cure this - and as the
    email is going to an AOL address on the AOL mail server it should accept it
    mail for delivery on port 25.
    [end quote from Spack]
     
    Martin Underwood, Jun 11, 2005
    #16
  17. As I suggested before, take this step by step. If you suspect that remark
    describes a documented feature and not a bug which was corrected in later
    software, first try getting the mailing working with another destination
    address. I offered mine. Solve the server issue and then take on this
    destination one. That destination matter is just a trivial distraction
    which can easily be overcome by opening a new GMail account to which logs
    can be sent in the first instance and then have GMail forward those
    emailed Logs back to your preferred final mail destination.

    Tony
     
    Anthony R. Gold, Jun 11, 2005
    #17
  18. Martin Underwood

    Bob Evans Guest

    Why not read it and find out?

    I would not have mentioned it otherwise :)
    Possibly, if the mailer in question can't handle direct-to-MX sending
    and the ISP concerned requires authentication prior to message
    submission to its smarthosts.
     
    Bob Evans, Jun 12, 2005
    #18
  19. Thanks you. I wasn't being lazy - I just wanted a URL to a site that
    contains definitions of RFCs. I reasoned that searching for "RFC" on Google
    might return a VERY large number of *references* to them, in addition to
    actual definitions.
    RFC 2476 only mentions ports 587 and 25 fairly briefly. I presume one of the
    cross-referenced documents goes into port usage in greater detail.

    I thought at first that 587 was a port that AOL had plucked out of thin air,
    but at least it is enshrined in the RFC. The paragraphs that describe it are
    a bit confusing: they say

     
    Martin Underwood, Jun 12, 2005
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.