NETGEAR DG834 ADSL and CISCO VPN Client

Discussion in 'Cisco' started by Alan Fay, Nov 27, 2003.

  1. Alan Fay

    Alan Fay Guest

    This is a very new NETGEAR ADSL router. It looks like a
    really good router, it's got VPN pass thru, and everything.

    I've just installed this ADSL router (connected with Demon)
    and it works great for normal internet access.

    However, when I try to do a CISCO Client VPN connect (which
    works over a simple modem connection) I can connect and
    negotiate, but then the internet connection dies (all
    access).

    The CISCO VPN client is v4.0. I tried this on windows
    it didn't even negotiate. On Linux it did negotiate
    and connect successfully. But then no internet access.

    Cisco VPN client:-

    -rw-r--r-- 1 root root 3696640 Nov 27 18:46 vpnclient-linux-4.0.Rel-k9.tar

    Netgear allowed inbound ports:-

    Any(ALL)(TCP/UDP:1,65535)
    ALLOW always
    Send to: 192.168.0.2 (Linux Server)

    Yes everything. No other special rules, NO DMZ, etc.

    I have to actually reboot my linux 2.4.21 v7.2 Redhat
    machine to be able to connect back to the internet
    (not very good, this is a windows type requirement).

    Has anyone else had better luck with this ?

    Please CC: me on any replies, I can receive them very
    fast.

    Alan
     
    Alan Fay, Nov 27, 2003
    #1
    1. Advertisements

  2. Alan Fay

    Rik Bain Guest

    Sounds as if the vpn policy does not have split tunneling enabled, in
    which case, only the ipsec traffic will be allowed. This is configured
    on the vpn termination device, not on the client.

    Rik Bain
     
    Rik Bain, Nov 28, 2003
    #2
    1. Advertisements

  3. Alan Fay

    Jimmy Dubke Guest

    If you're using a firewall the router IP address needs to be added to the
    firewall, as the modem will already be configured to get through the
    firewall, but the router's IP will not - if in doubt turn the FW,
    temporarily, off.

    I just put a NETGEAR cable router on, and the Cisco client worked fine after
    re-configuring the the FW, and configuring the router.

    I did have one slight operator error. When done configuring my router I
    just killed the browser that is used to configure the router instead of
    using the logoff button on the router's configuration program. While that,
    indeed, did kill the browser, it didn't terminate the router's configuration
    program. The result was that then nothing worked. All I had to do was
    cycle the router's power then everything was ok. As a precaution I went
    back to the router and verified that everything was ok; after verifying
    everything was ok, I then used the correct logoff button to place the router
    into normal service, and everything worked.

    JD
     
    Jimmy Dubke, Dec 1, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.