netapp Metro Cluster via Nexus Switches - FibreChannel

Discussion in 'Cisco' started by fote98cisco, Oct 4, 2013.

  1. fote98cisco

    fote98cisco Guest

    Hi,

    I have a more complex thing for you guys.

    We're running a netapp Metro Cluster in our datacenter with two direct connections between the Filer (FC/VI ports) and are in the need to relocate
    one half of the cluster to an other datacenter. In each datacenter there are two Cisco Nexus 5548UP. On each, an additional 8 port FibreChannel license is installed.

    Nexus switches are configured with several VSANs, each VSAN is mapped to a VLAN (FCOE).

    We're already running four ESX server and two Fujitsu storages within VSAN 1, which are connected to different Nexus Switches (FC). That's working fine.

    Now we tried to move one of those FC/VI to Nexus, can see a link and WWNs on the ports we connected the netapps to.

    In some netapp documents I found how to configure that and did it their way.
    I configured VSAN 2 with 2 zones and added the netapps Qlogic FC Adapter WWNs of ports 1 to zone 1 and WWNs of ports 2 to zone 2.
    Additionally I configured in-order-guarantee to VSAN 2 as netapp tells to do.

    When removing the direct attached ports from the netapps we can see that in their logs. When connecting to the Nexus the ports come up,
    we can see the WWNs on the switches but the Filer cannot build their connection. Connecting them back direct to themselves the connection can be build.

    The same behaviour if netapps connected to the same switch or to different ones.

    I'm not really deep into FibreChannel but we need to find a solution for that.

    Could it be a netapp licensing issue? Maybe the netapp doesn't allow switched connections, just stretched ones? (Unfortunately our netapp is out of support)
    Do I miss something at the Nexus'? Could find some examples, from netapp too, how to configure the switches and I did it in exactly that way.

    Below the Nexus' FC configuration and the "show fcns database detail" and "sh flogi database detail" outputs.

    Hope someone can help us out of that stranger.


    show flogi database details
    --------------------------------------------------------------------------------------------
    INTERFACE VSAN FCID PORT NAME NODE NAME FLAGS
    --------------------------------------------------------------------------------------------
    fc1/25 2 0x120000 21:00:00:1b:32:90:38:85 20:00:00:1b:32:90:38:85 ADOP
    fc1/26 2 0x120100 21:00:00:1b:32:90:20:66 20:00:00:1b:32:90:20:66 ADOP


    show fcns database detail
    ------------------------
    VSAN:2 FCID:0x120000
    ------------------------
    port-wwn (vendor) :21:00:00:1b:32:90:38:85 (Qlogic)
    node-wwn :20:00:00:1b:32:90:38:85
    class :3
    node-ip-addr :0.0.0.0
    ipa :ff ff ff ff ff ff ff ff
    fc4-types:fc4_features :scsi-fcp:init fc-vi
    symbolic-port-name :Netapp FCVI adapter 1a 200000019710
    symbolic-node-name :
    port-type :N
    port-ip-addr :0.0.0.0
    fabric-port-wwn :20:19:00:2a:6a:41:45:00
    hard-addr :0x000000
    permanent-port-wwn (vendor) :21:00:00:1b:32:90:38:85 (Qlogic)
    Connected Interface :fc1/25
    Switch Name (IP address) :NAME (IP)

    ------------------------
    VSAN:2 FCID:0x120100
    ------------------------
    port-wwn (vendor) :21:00:00:1b:32:90:20:66 (Qlogic)
    node-wwn :20:00:00:1b:32:90:20:66
    class :3
    node-ip-addr :0.0.0.0
    ipa :ff ff ff ff ff ff ff ff
    fc4-types:fc4_features :scsi-fcp:init fc-vi
    symbolic-port-name :Netapp FCVI adapter 1a 200000019514
    symbolic-node-name :
    port-type :N
    port-ip-addr :0.0.0.0
    fabric-port-wwn :20:1a:00:2a:6a:41:45:00
    hard-addr :0x000000
    permanent-port-wwn (vendor) :21:00:00:1b:32:90:20:66 (Qlogic)
    Connected Interface :fc1/26
    Switch Name (IP address) :NAME (IP)


    sh running (truncated)

    version 5.1(3)N2(1)

    feature fcoe
    feature telnet
    no feature http-server
    cfs eth distribute
    feature udld
    feature interface-vlan
    feature lacp
    feature vpc
    feature lldp
    feature vtp

    slot 1
    port 25-32 type fc

    vlan 1101
    fcoe vsan 1

    vlan 1102
    fcoe vsan 2

    vlan 1103
    fcoe vsan 3

    vlan 1104
    fcoe vsan 4

    vlan 1105
    fcoe vsan 5

    vlan 1106
    fcoe vsan 6

    vlan 1107
    fcoe vsan 7

    vlan 1108
    fcoe vsan 8

    vlan 1109
    fcoe vsan 9

    spanning-tree mode mst

    spanning-tree mst configuration
    instance 1 vlan 1100-1199

    vsan database
    vsan 1 name "ESX_FUJITSU"
    vsan 2 name "NETAPP"
    vsan 3
    vsan 4
    vsan 5
    vsan 6
    vsan 7
    vsan 8
    vsan 9

    in-order-guarantee vsan 2

    fcdomain fcid database
    vsan 2 wwn 21:00:00:1b:32:90:20:66 fcid 0xec0000 area dynamic

    vsan database
    vsan 2 interface fc1/25
    vsan 2 interface fc1/26
    vsan 4 interface fc1/27
    vsan 5 interface fc1/28
    vsan 6 interface fc1/29
    vsan 7 interface fc1/30
    vsan 8 interface fc1/31
    vsan 8 interface fc1/32

    interface fc1/25
    no shutdown

    interface fc1/26
    no shutdown


    interface fc1/25
    switchport mode F

    interface fc1/26
    switchport mode F

    zone default-zone permit vsan 1
    zone default-zone permit vsan 3-9

    !Full Zone Database Section for vsan 2
    zone name sm_zone_1 vsan 2
    member pwwn 21:00:00:1b:32:90:20:66
    member pwwn 21:00:00:1b:32:90:38:85

    zone name sm_zone_2 vsan 2
    member pwwn 21:01:00:1b:32:b0:20:66
    member pwwn 21:01:00:1b:32:b0:38:85

    zoneset name sm_zone_cfg vsan 2
    member sm_zone_1
    member sm_zone_2

    Cheers, Andre
     
    fote98cisco, Oct 4, 2013
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.