Need help with Storage USB Device

Discussion in 'Computer Support' started by Fred J, Jan 9, 2004.

  1. Fred J

    Fred J Guest

    I bought OTi UStorage USB Device (64MB) when I plug it in the USB port
    it visible on the system tray that it is plugged in, but when I click on the
    MyComputer Icon
    there it doesn't show as removable disc, under removable storage I have only
    3 1/2 Floppy - CD-RW Drive - CD-Rom but not the removable disc this happens
    in WindXP Pro, on the same computer I have Wind ME there is no problem it
    has assigned letter and is working fine, but when I am in Windows XP I can
    not see it,
    among the installed drives, in the Device manager under USB Mass Storage
    Device
    tells this device works properly but I don't have an icon to open it.
    Any help would be appreciated Fred
     
    Fred J, Jan 9, 2004
    #1
    1. Advertisements

  2. Fred J

    Billh Guest

    I can offer what happened to me. I have a Canon A80 digital camera. I hate
    installing software I do not need so I had hoped to just plug it in and see
    it as a removeable drive. Oddly it worked as I wanted on my Dell Desktop
    with XP Home that I had done a clean install on. But my new Dell Laptop
    with XP Pro did not find a driver for it. I found a driver for it on
    Canon's website. They claimed I did not need it with XP as it should be all
    ready installed but offered a download for it anyways. It worked fine after
    the install. So my feeling is some how the driver was not install by Dell
    as it should have.

    It was a WIA Driver that I was missing.

    So look at the device web site and look for a driver.

    "Fred J" <> wrote in message
    news:abELb.137805$...
    > I bought OTi UStorage USB Device (64MB) when I plug it in the USB port
    > it visible on the system tray that it is plugged in, but when I click on

    the
    > MyComputer Icon
    > there it doesn't show as removable disc, under removable storage I have

    only
    > 3 1/2 Floppy - CD-RW Drive - CD-Rom but not the removable disc this

    happens
    > in WindXP Pro, on the same computer I have Wind ME there is no problem it
    > has assigned letter and is working fine, but when I am in Windows XP I can
    > not see it,
    > among the installed drives, in the Device manager under USB Mass Storage
    > Device
    > tells this device works properly but I don't have an icon to open it.
    > Any help would be appreciated Fred
    >
    >
    >
     
    Billh, Jan 10, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.