native vlan mismatch on 2 2924 switches w/ only 1 vlan defined (same on both switches)

Discussion in 'Cisco' started by avraham shir-el, Jul 1, 2004.

  1. i'm getting the following message logged every minute:

    Jul 1 14:56:30: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch
    discovered on FastEthernet0/2 (0), with switchs1-cc-cab4.jct.ac.il
    FastEthernet0/23 (1).

    ok, there's lots in this group written about vlan mismatches.
    i haven't seen anything with all ports on both switches in the same
    vlan!

    both switches are 2924-xl's w/ all 24 ports on each unit in vlan1.
    the unit which logs the messages is running Version 11.2(8.2)SA6.
    the other unit is running Version 12.0(5)WC5.

    everythings seems to be working fine though.
    each switch has several production servers on it, so we would have
    noticed if there were connectivity or performance effects.

    any additional insight would be appreciated.
    tnx
    ams
     
    avraham shir-el, Jul 1, 2004
    #1
    1. Advertisements

  2. avraham shir-el

    Jeff C Guest

    I'll assume that the trunk has been negotiated and that the original access
    ports were at one point in different vlans. To set the native vlan on one
    of the switches to match the other try this (works on 2950)

    config t
    int f0/2
    switch trunk native vlan 1
    end

    You may be able to use the command "show interface f0/2 trunk" to view
    trunking characteristics on the port in question.

    Good luck,
    -Jeff C
     
    Jeff C, Jul 2, 2004
    #2
    1. Advertisements

  3. avraham shir-el

    Guest


    First, you should upgrade the IOS on both switches as they are both
    subject to some semi-recently announced vulnerabilities. This may
    also resolve some cdp version issues.

    If you still have a problem, compare the configurations between the
    switches to see what differences you have. Worst case, post the
    configs (minus any passwords, encrypted or not).
     
    , Jul 2, 2004
    #3
  4. Just enter
    no cdp advertise-v2
    in all boxes.
    Or correct the native vlans .
    It seems switchs1-cc-cab4.jct.ac.il uses some other native vlan than 1.
    Regs
    Hakan
     
    Håkan Månsson, Jul 2, 2004
    #4
  5. tnx 4 the hint jeff, but
    sho int fa0/2 swi (not trunk)
    indicated that both switches had vlan 1 as the default native vlan.
    i set it explicitly anyway, but the "vlan mismatch" messages still kept
    coming.

    the "no cdp advertise" as suggested by Håkan Månsson ()
    stopped the mismatch messages.
    it's still a mystery why they were coming altogether with both native vlans 1,
    and negotiation disabled as seen below.

    switchs1-cc-cab2>sho int fa0/2 swi
    Name: Fa0/2
    Switchport: Enabled
    Administrative mode: static access
    Operational Mode: static access
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE

    switchs1-cc-cab2>

    switchs1-cc-cab4>sho int fa0/23 swi
    Name: Fa0/23
    Switchport: Enabled
    Administrative mode: static access
    Operational Mode: static access
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE

    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    switchs1-cc-cab4>

    tnx
    ams
     
    avraham shir-el, Jul 20, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.