My Wireless Tab has disappeared!

Discussion in 'Wireless Networking' started by Guest, Jul 22, 2005.

  1. Guest

    Guest Guest

    Setting up a new wireless networking card; I get to the point where I right
    click the connection in order to configure the SSID WEP key etc and that tab
    is missing. (The one you have to check to allow windows to configure the
    wireles connection).How can I get it back? I refreshed my windows update
    including (finally) installing serive pack 2 but that did not cure the
    problem.
    Thanks
     
    Guest, Jul 22, 2005
    #1
    1. Advertisements

  2. Guest

    JoeT Guest

    You probably have to decide you want to use WZC instead of any included
    utility to config/run the new card, more often that not WZC is incompatible
    with them.

    To enable WZC

    Control panel
    administrative tools
    services
    wireless zero configuration
    startup type : automatic
    service status: start

    rebstart windows, you may have to reboot to get it to autostart and stick
     
    JoeT, Jul 22, 2005
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Thanks!

    I've just looked at the admin services tab and there is no windows zero
    configuration service - is there an acronym?
     
    Guest, Jul 22, 2005
    #3
  4. Guest

    Guest Guest

    correction I meant wireless zero configuration
     
    Guest, Jul 22, 2005
    #4
  5. Guest

    Clark Guest

    Do you have the connection Enabled?

    Clark
     
    Clark, Jul 22, 2005
    #5
  6. Guest

    Guest Guest

    yes I do - it simply reports no network - I have a second machine next to it
    (and have also swapped cards to make sure there isn't a hardware problem).
    The second machine also running xppro 2nd edition finds and logs onto the
    network without problem. I think the problem is with the setup of the
    machine which is why i finally installed sp2 last night but that didn't solve
    it. The first time I installed the card (DLINK G650+) it worked 100% but
    after closing down and rebooting I started this loop...
     
    Guest, Jul 22, 2005
    #6
  7. Guest

    JoeT Guest

    It's wireless (not windows, see below) zero configuration and if you don't
    see it listed after opening services under administrative tools I can't help
    ya...
     
    JoeT, Jul 22, 2005
    #7
  8. Guest

    Guest Guest

    That's the problem joe, I can't see it (and yes I spotted my typo - I realise
    it is wireless). I am trying to discover how to get that service reloaded,
    something must have happened to the files. ANytway thanks.
    jon
     
    Guest, Jul 22, 2005
    #8
  9. Guest

    Clark Guest

    Try using the configuration utility that came with your adapter. You may
    need to update it, but I am running without the WZC even turned on and
    everything is working great.

    If not, you should have a wzcsvc.dll in your system in Windows\system32
    folder. If you don't, do a search and copy it there (my file is 351k
    3/30/04).

    If you have that, you might have a registry entry WZCSVC under
    HKLM\System\CurrentControlSet\Services\

    If you have that, open the Run command and type services.msc. Go to the
    bottom and find Wireless Zero Configuration and right click to check
    properties. Make sure it is Automatic and start it while there.

    Some of this was probably already covered, but I am lazy ;) If you don't
    have any of this, let us know an you might start with the last step since it
    is easier (even though you appear to have done so already).

    Clark
     
    Clark, Jul 22, 2005
    #9
  10. Guest

    Clark Guest

    The easiest thing might just be to go to Start-Run and type "Regsvr32
    wzcsvc.dll" (no quotes)

    This should re-register the service in the registry. I don't know if it
    will replace the actual file if it is missing.

    Clark
     
    Clark, Jul 22, 2005
    #10
  11. Guest

    Guest Guest

    Hi clark, that is the problem even with the utility that came with the card
    nothing works. (In fact it says switch windows wireless networking off). It
    simply looks as if the thing has deleted some control somewhere. The card
    works perfectly on another machine. The dll exists and is near enough the
    size you mention 352KB 04/08/2004

    Furthermore the utility worked the first time it was installed and then
    stopped working. That was when I uninstalled it, rebooted and tried using
    windows instead without the utility and that was when I noticed the service
    tab had vanished.

    The registry entry exists there are three sub branches Enum Parameters
    Security

    Enum:


    Key Name:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc\Enum
    Class Name: <NO CLASS>
    Last Write Time: 22/07/2005 - 13:08
    Value 0
    Name: 0
    Type: REG_SZ
    Data: Root\LEGACY_WSCSVC\0000

    Value 1
    Name: Count
    Type: REG_DWORD
    Data: 0x1

    Value 2
    Name: NextInstance
    Type: REG_DWORD
    Data: 0x1

    Parameters:

    Key Name:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc\Parameters
    Class Name: <NO CLASS>
    Last Write Time: 22/07/2005 - 00:30
    Value 0
    Name: ServiceDll
    Type: REG_EXPAND_SZ
    Data: %SYSTEMROOT%\system32\wscsvc.dll

    Security:

    Key Name:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wscsvc\Security
    Class Name: <NO CLASS>
    Last Write Time: 22/07/2005 - 00:30
    Value 0
    Name: Security
    Type: REG_BINARY
    Data:
    00000000 01 00 14 80 90 00 00 00 - 9c 00 00 00 14 00 00 00 ................
    00000010 30 00 00 00 02 00 1c 00 - 01 00 00 00 02 80 14 00 0...............
    00000020 ff 01 0f 00 01 01 00 00 - 00 00 00 01 00 00 00 00 ÿ...............
    00000030 02 00 60 00 04 00 00 00 - 00 00 14 00 fd 01 02 00 ..`.........ý...
    00000040 01 01 00 00 00 00 00 05 - 12 00 00 00 00 00 18 00 ................
    00000050 ff 01 0f 00 01 02 00 00 - 00 00 00 05 20 00 00 00 ÿ........... ...
    00000060 20 02 00 00 00 00 14 00 - 8d 01 02 00 01 01 00 00 ...............
    00000070 00 00 00 05 0b 00 00 00 - 00 00 18 00 fd 01 02 00 ............ý...
    00000080 01 02 00 00 00 00 00 05 - 20 00 00 00 23 02 00 00 ........ ...#...
    00000090 01 01 00 00 00 00 00 05 - 12 00 00 00 01 01 00 00 ................
    000000a0 00 00 00 05 12 00 00 00 - ........


    I don't suppose that these are much help - it just looks normal... The only
    thing I can think of is that perhaps permissions have been changed on some of
    those folders.

    Thanks for your feedback - if you have any other ideas please let me know.
     
    Guest, Jul 22, 2005
    #11
  12. Guest

    Guest Guest

    Clark, thanks for this further idea - I didn't spot it. What happens when I
    do this is that I receive the following dark message: wzcsvc.dll was loaded
    but the DllRegisterServer entry point was not found. The file cannot be
    registered.

    That seems rather sinister... :(
     
    Guest, Jul 22, 2005
    #12
  13. Guest

    Clark Guest

    I think what I would do is to start over and try to get a standard system.
    Delete the device from the Device Manager and remove the card. Remove the
    config utility for the card. Reboot and go back and check the WZC to see if
    you can get it running. If it doesn't run normally, try the regsvr32
    wzcsvc.dll command to re-register everything and reboot. Hopefully the WZC
    is working at this point.

    Now try to install the card and just the drivers, not the configuration
    utility. If you know where the drivers are or have downloaded newer ones,
    make sure they are used for the install. Reboot.

    Now hopefully you can use the WZC to scan for networks and configure the
    card. If you don't have SSID broadcast turned on in the router, you may not
    be able to see your network, so make sure it is on at this point. Also make
    sure no wireless security is enabled at this point on the router or your
    wireless adapter. Also make sure MAC filtering is turned off or you have
    the card's MAC address added to the list of allowed.

    If you do see the SSID, set up a profile with what you need and save it.
    You can edit it later when you restore the wireless security. If you still
    can't see a network, then I am out of ideas.

    You may be on "wireless connection 15" or so by now, and some of those can
    be deleted, but that is another discussion. If you have questions about any
    of this, ask before you do it.

    Clark
     
    Clark, Jul 22, 2005
    #13
  14. Guest

    Guest Guest

    Thanks - I'll get on with that and report back.
     
    Guest, Jul 22, 2005
    #14
  15. Guest

    Jon Guest

    Hi Clark,
    Well, nothin' doin'
    Deleted Device, removed card, rebooted, deleted utility, rebooted.
    Still no sign of anything.
    Ran regsvr32 but still got message about DllRegisterserver re entry point...
    Ran regsvr32 with the /u to remove wzc but still got same message
    DllUnregisterserver etc
    Tore my hair out... :)
    Thinking only thing to do is rebuild the wretched machine.
    There is no data on it - loads of connection icons and a temporary folder
    for local working.
    (We use Citrix for work and I use PCAnywhere to reach my home computer...
    Maybe that is the best solution.
    Jon
     
    Jon, Jul 23, 2005
    #15
  16. Guest

    Clark Guest

    Well, I am out of ideas. I was thinking if the WZC would not run that
    perhaps something had been removed from your system that was needed.

    Also, if you use VPN, make sure you don't have a Eacfilt entry on your
    TCP/IP properties for the wireless, and if you do, uncheck it. Try
    repairing the connection if you haven't done that, but good luck. sorry I
    couldn't help.

    Clark
     
    Clark, Jul 23, 2005
    #16
  17. Guest

    Jon Guest

    Clark,
    You have been very kind thanks...
    I am pretty convinced that the system (which I installed 3 years ago and has
    been quite solid) has simply decided to go AWOL
    Jon
     
    Jon, Jul 23, 2005
    #17
  18. Guest

    Guest Guest

    Jon,

    May have the solution for you. My laptop came with Atheros Wireless
    Utility. Initially I disabled Atheros and used WZC (Wireless Tab was
    present) but found it intolerably glitchy so I switched to Atheros. After
    reading that MSFT had fixed the bugs I decided to switch back to WZC and
    found my "Wireless Tab" missing.

    Just to be clear, what was missing on my system was the Wireless Networks
    tab on the Wireless Network Connections Properties dialog box. I was also
    unable to view Available Networks. I suspected that Atheros made a change
    to WZCSVC registry . I'm by no means an expert on the registry, but I was
    desperate.

    My solution was to change
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WZCSVC\Parameters\Interfaces\
    LayoutVersion data = 7

    There were actually two entries for LayoutVersion (one nested inside the
    other). One was set to 3 the other to 7. So basically I just guessed. Was
    hoping this posting might inspire someone who actually knows what's going on
    to better document the solution.

    Best of luck to you,

    Mike
     
    Guest, Aug 8, 2005
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.