my printer won't print; windows says it's offline

Discussion in 'NZ Computing' started by Guest, Apr 14, 2013.

  1. Guest

    Guest Guest

    I have a canon mx420 multi-function printer connected through a tplink
    wireless router. When I first connected it/ installed it I was able
    to print ok but now, Windows says it is offline and I'm not able to
    print to it. If I run the Windows troubleshooter it says the printer
    is turned off. I can dial up the IP address of the printer in a web
    browser and see its settings etc but Windows just always says the
    printer is offline.

    Any idea how to find what the problem is?
     
    Guest, Apr 14, 2013
    #1
    1. Advertisements

  2. Guest

    Dave Doe Guest

    Possibly a shot in the dark but...
    Last three printers in a row that I fixed all suffered from simply not
    being up-to-date with Windows Update. Manually updated, and bingo,
    their printers started working again.
     
    Dave Doe, Apr 14, 2013
    #2
    1. Advertisements

  3. Guest

    Richard Guest

    Has its IP address changed since you set it up?

    Windows is a bit dumb in how it handles that, and its not helped that
    most printers will allow you to either set them up as an IP printer
    port, or else access a shared printer on a sort of functional print
    server built into it.
     
    Richard, Apr 14, 2013
    #3
  4. Guest

    Guest Guest

    Yes it has changed. Yesterday I assigned a static IP address to the
    printer using the printer's web browser thing - I used the IP
    address that it had been given already by my router. Then in Windows
    (Win 7) I added a new printer using that IP address - but it still
    didn't work.

    So now tonight, I turned the printer on first, then the router, then
    the PC. But still no print and then I find that the original canon
    printer things are gone from my list of printers but the TCP/IP one is
    still there but not working. So I deleted it and tried adding yet
    another printer (can't remember if I did "add local" or "add network")
    and specified the IP address - and eventually the printer started
    working and now I can print things - except that it takes a while for
    the printer to react and Windows ends up telling me that the printer
    is "not responding" - but the stuff still gets printed.

    I would have thought that printing via WIFI was common and I'm feeling
    exceedingly frustrated. I might go and visit Canon and see what they
    say.
     
    Guest, Apr 15, 2013
    #4
  5. Guest

    Guest Guest

    Guest, Apr 15, 2013
    #5
  6. Guest

    Dave Doe Guest

    You never replied to me re WU's check, however it's clear from this
    reply it's still not work, so the second thing I'd have suggested is to
    map the printer port and locally install the driver. It's a commonly
    used "workaround" :)

    IRC...
    * net use LPT2\\<ip address of the printer>\<printer name> (if
    Vista/Win7 run from an elevated command prompt)
    * install the driver locally using LPT2

    I've used this sucessfully on several WiFi printers.
     
    Dave Doe, Apr 15, 2013
    #6
  7. Guest

    Guest Guest

    PC ethernet cable ---> CISCO VOIP phone adapter thing --> ethernet
    cable----> TPLink router ---> wifi ---> printer (in another room)

    IPConfig says

    Windows IP Configuration
    Ethernet adapter Local Area Connection:

    IPv4 Address. . . . . . . . . . . : 192.168.15.100
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.15.1


    192.168.15.1 gets me to the CISCO phone adapter
    192.168.1.1 gets me to the router
    192.168.1.102 gets me to the Canon printer
     
    Guest, Apr 15, 2013
    #7
  8. Guest

    Guest Guest

    I didn't know what you meant by Windows Update. My PC (Win 7) is set
    to get Windows updates automatically and I've checked the printer
    drivers and they are the latest.
    I can actually print now even though Windows says "printer not
    responding" - and the delay before the printer starts doing
    something is probably over 30 seconds - which is a really long time
    for a 54 MBs plus connection. Since it's more or less working I don't
    feel like trying anything else at the moment, in case it stops
    working.
     
    Guest, Apr 15, 2013
    #8
  9. Guest

    Dave Doe Guest

    It's probably worth manually checking then - WU's. Start, All Programs,
    and at the bottom of the programs list, before the yellow folder icons,
    under "w" for Windows Update. (If any update exists for it, it probably
    won't be under the Important updates section, but perhaps under optional
    - have a looksee at all of the sections.)

    And I've never recommended to install driver updates for hardware that
    is already working - if you do, you need to be prepared to roll back to
    prior to that install point (System Restore). In short, if you're not
    sure about the consequences of an update rendering the hardware
    inoperative and how to subsequently deal with it, leave it unchecked.

    But if there's an update for that printer, go for it. So I'd sure
    recommend you manually run a WU check and at least see what it finds.
    No harm done.
     
    Dave Doe, Apr 15, 2013
    #9
  10. Guest

    Guest Guest

    ok, I connected the PC directly to the router and tried printing but
    it wouldn't print at all - said printer offline, so I re-did the LAN
    setup at the printer and also turned off the static IP address on the
    printer. Then I tried printing and it worked immediately with no
    delay or "printer not responding" messages. I dunno what happened to
    the printer port config in the PC where I specified the static IP
    address - it seems to be gone. Anyway, it seems to be all fine now.
    Thanks a lot.
     
    Guest, Apr 16, 2013
    #10
  11. Guest

    Guest Guest

    Windows Update told me there were six optional updates, including one
    for the Canon printer. I installed them all and I also changed around
    my network setup as suggested by EMB and now it's working fine. I've
    never thought to check for optional updates - so thanks for that.
     
    Guest, Apr 16, 2013
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.