Multiple pvc's on Cisco 878

Discussion in 'Cisco' started by j.kost, May 6, 2008.

  1. j.kost

    j.kost Guest

    Hello,

    I'm having a problem with the configuration of a Cisco 878.
    What i'm trying to do is configure 2 PVC's.

    One is a PPPoA connection, and the other a RFC 1483 connection, in
    full bridge.
    The thing that i can't get to work is using the 2 connections
    similtaniously.

    I'm using the following config:

    !
    version 12.4
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname <hostname>
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret bonbon
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone GMT 1
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    username <username> password <password>
    !
    !
    controller DSL 0
    mode atm
    line-term cpe
    line-mode 2-wire line-zero
    dsl-mode shdsl symmetric annex B
    line-rate auto
    !
    !
    !
    !
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc internet 0/36
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    pvc 0 0/37
    encapsulation aal5snap
    !
    bridge-group 1
    !
    interface FastEthernet0
    switchport access vlan 250
    !
    interface FastEthernet1
    switchport access vlan 250
    !
    interface FastEthernet2
    switchport access vlan 250
    !
    interface FastEthernet3
    !
    interface Vlan1
    no ip address
    bridge-group 1
    hold-queue 100 out
    !
    interface Vlan250
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    no autostate
    !
    interface Dialer0
    mtu 1492
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no peer default ip address
    ppp authentication pap callin
    ppp pap sent-username <username> password <password>
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 101 interface Dialer0 overload
    !
    access-list 101 permit ip 192.168.2.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    ntp clock-period 17177560
    ntp server 212.45.32.36
    end

    ----------------------------------------------------

    There are 2 VLAN's. VLAN 1 i'm using for the RFC 1483 connection, and
    VLAN 250 for the PPPoA connection.
    With this config, the PPPoA connection works. When i go into global
    configuration mode, and enter the command 'no ip routing', the RFC
    1483 connection works.
    The gateway of last resort disappears, and the routing table is shut
    down.
    After this, when i enter 'ip routing' in Global config mode, and 'ip
    route 0.0.0.0 0.0.0.0 Dialer0', the PPPoA connection works.

    Does anyone have a solution that fixes my problem?

    Thanks in advance.

    Greetings,

    Jan Kost
     
    j.kost, May 6, 2008
    #1
    1. Advertisements

  2. j.kost

    Bod43 Guest


    If I recall correctly - and it has been a while - the
    router will NOT bridge IP packets when
    routing is enabled???

    Unless you configure CRB/IRB?

    Here is a successful config with rfc1483
    that has an IP address on the router.
    This mayy not be what you want but maybe
    will point in some useful direction.

    ip cef

    !
    bridge irb ! ###
    !
    interface FastEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$
    ip address 10.1.2.1 255.255.255.0

    !
    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    bridge-group 1
    pvc 0/35
    encapsulation aal5snap
    !
    !
    interface BVI1
    bandwidth 8000
    ip address 6.23.17.15 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    load-interval 30
    crypto map pipe
    !
    ip route 0.0.0.0 0.0.0.0 6.23.17.1
    !
    bridge 1 protocol ieee ! ###
    bridge 1 route ip ! ###
    !
     
    Bod43, May 6, 2008
    #2
    1. Advertisements

  3. j.kost

    j.kost Guest

    Thank you. I have a working config with RFC 1483, so that's not the
    problem.
    It's true that the cisco will not bridge IP packets with routing
    enabled. When i disable it, it works fine. The problem is the
    combination of both.

    Thanks.
     
    j.kost, May 7, 2008
    #3
  4. j.kost

    Bod43 Guest

    The config fragment that I sent IS bridging over the
    ATM and routing to the inside.

    It is doing IRB.

    From memory - very flaky - I suspect that you may need CRB.
    I think that this is routing IP on some interfaces and
    bridging on others.

    Read about CRB and IRB.

    I forget it all now.


    Did you notice the "! ###" s in my previous post?
     
    Bod43, May 7, 2008
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.