msmsgs.exe ? XP Home hogging cpu and wont stay gone

Discussion in 'Computer Support' started by Tim Kett, Dec 16, 2004.

  1. Tim Kett

    Tim Kett Guest

    I have XP Home, and in task manager it shows msmsgs.exe ( owner ) to peg 99%
    at least, my cpu only when I am connected to my dial-in ISP.

    I could delete it in task manager processes and after 3 times, it would stop
    coming back in 1-2 minuits, but now, I have been deleating it 20-30 times
    and the damn thing keeps coming back in a second or 2, and pegging my cpu
    every 7 seconds or so, after it settles down after a few deletes and quits
    99% hogging it continuousely.

    My computer ran fine when it stayed deleated. No/very small ( only 3-5% )
    cpu spikes when just connected to ISP, and me not doing anything.

    I would prefer not to re-install yet, because my Norton antivirus
    subscription which is due in april will be lost ( I lost about 4 months of
    it the last time I reinstalled about 9 months ago ).

    All functions that I use worked normal with no cpu hogging when it would
    stay gone, but it looks like it is getting worse the last few days.

    How to get rid of msmsgs.exe perminately ?
     
    Tim Kett, Dec 16, 2004
    #1
    1. Advertisements

  2. Tim Kett

    Tim Kett Guest

    I should have googled it first. Anyway, according to posts of other people
    who had problems with msmsgs.exe, it is Windows Messenger. It shows up when
    outlook express is open.

    So I clicked on it for the 1st time since I bought this comp 2 years ago,
    and ticked all the boxes to disable it, and got a damn smartass message that
    it is still running, " so I could still get messages when logged in ". I
    have never even fired it up, except to try to get rid/disable it today, much
    less logged in to the damned thing.

    I re-booted, and still have it hogging the cpu, and it wont stay away still.

    No apparent way to uninstall it ( not listed ), no way to shut it down in
    administrative services ( again not listed ), and all the info to get rid
    of/disable it manually that I have found is for a different op system than
    XP Home from what it seems.

    TIA, tim
     
    Tim Kett, Dec 16, 2004
    #2
    1. Advertisements

  3. Tim Kett

    Toolman Tim Guest

    |I should have googled it first. Anyway, according to posts of other people
    | who had problems with msmsgs.exe, it is Windows Messenger. It shows up
    when
    | outlook express is open.
    |
    | So I clicked on it for the 1st time since I bought this comp 2 years ago,
    | and ticked all the boxes to disable it, and got a damn smartass message
    that
    | it is still running, " so I could still get messages when logged in ". I
    | have never even fired it up, except to try to get rid/disable it today,
    much
    | less logged in to the damned thing.
    |
    | I re-booted, and still have it hogging the cpu, and it wont stay away
    still.
    |
    | No apparent way to uninstall it ( not listed ), no way to shut it down in
    | administrative services ( again not listed ), and all the info to get rid
    | of/disable it manually that I have found is for a different op system than
    | XP Home from what it seems.
    |
    | TIA, tim
    |
    |
    Ahh...but I believe it *CAN* be stopped! Open Notepad (winkey-r, type
    notepad, press enter) and copy the text between the double lines to notepad.
    (Cut/paste works best).

    ==========
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger]

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client]
    "PreventRun"=dword:00000001
    "PreventAutoRun"=dword:00000001

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Outlook\InstantMessaging]
    "ForceDisableIM"=dword:00000001
    ==========

    (If any of the above lines are broken between the [brackets] then make sure
    they are fixed in your notepad window so they are one complete line.)

    Then save the file to your desktop with the name "MessengerKill.reg".
    Double-click the file to make those changes to your registry. You may need
    to reboot for it to take effect.
     
    Toolman Tim, Dec 16, 2004
    #3
  4. Tim Kett

    Richard Guest


    No problem. Find the folder on your c:\drive named "messenger".
    Rename it to "no-messeger" or "stop-messenger".
    Since OE can't find the file, it ignores it and moves on.
     
    Richard, Dec 16, 2004
    #4
  5. Tim Kett

    Tim Kett Guest

    Thank you Tim and Richard, but before I checked back here, I tried the
    instructions here

    http://myitforum.techtarget.com/articles/15/view.asp?id=7033

    And problem is completely solved !!! :)

    Windows messenger is GONE, and I have my cpu power back !!! It looks like it
    was downloading crap before I removed it.

    Thanks again :)
     
    Tim Kett, Dec 16, 2004
    #5
  6. Tim Kett

    Toolman Tim Guest

    | Thank you Tim and Richard, but before I checked back here, I tried the
    | instructions here
    |
    | http://myitforum.techtarget.com/articles/15/view.asp?id=7033
    |
    | And problem is completely solved !!! :)
    |
    | Windows messenger is GONE, and I have my cpu power back !!! It looks like
    it
    | was downloading crap before I removed it.
    |
    | Thanks again :)
    |
    Cool! Neat tip...
     
    Toolman Tim, Dec 16, 2004
    #6
  7. Tim Kett

    Tim Kett Guest

    Cool! Neat tip...

    Yes, my best friend emailed it to me :)

    I printed it out, and filed it in my XP paper file, for when I reinstall in
    april.

    I wont have windows messenger on my machine ever again :)

    It is great to know, there are other ways to get rid of it as well :)
     
    Tim Kett, Dec 16, 2004
    #7
  8. I first disabled it in Outlook Express, then went to Control Panel>
    Add/Remove Programs>on the left-hand side of Add/Remove Programs
    "Add/Remove Windows Components" and uncheck it, along with MSN Explorer
    and that piece of schitt, Windows Media Player.

    "Tim Kett" <> chiseled in stone, the
    following words
     
    @}-}-------Rosee, Dec 17, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.