mprapi.dll --> samlib.dll --> ntdll.dll issue.

Discussion in 'Computer Support' started by Some1, Apr 2, 2004.

  1. Some1

    Some1 Guest

    AGAIN!!!

    Hi folks,

    I'm sorry to come here again with the same issue that I thought was
    over.

    The computer: Compaq Presario 1200 mod 12XL201(laptop)
    OS: Windows 98SE Spanish version

    Background:
    Clean system restore from Compaq original 2 CD set.
    Installation of Linksys USB100TX usb to eternet adapter (updated
    driver).
    Installation of EnterNet PPPoE from Look Communications.
    Installation of windows and IE updates, patches and fixes.
    Software installation: Spybot Search and Destroy, Spyware Blaster,
    AdAware, AVG antivirus, Qwik-Fix, Adobe Acrobat Reader, PowerPoint
    Viewer. No Diskeeper light this time, though.

    Every seemed to be OK until I uninstall Look Communications software
    from the uninstall link in Look folder.

    Symptoms:

    Error MPRAPI.DLL not found.
    I've installed Look Communications software again to see if the error is
    fixed, to no avail. Then I've expanded System_Sav partition
    D:\I386\mprapi.dl_ into C:\Windows\System\mprapi.dll
    As Look software was not the solution, I've unistalled again.

    Error SAMLIB.DLL not found. I've expanded System_sav partition
    D:\I386\samlib.dl_ into C:\Windows\System\samlib.dll
    Error "El archivo SAMLIB.DLL está
    vinculado a un NTDLL.DLL:RtlFreeUnicodeString de exportación que no
    existe" that translates to "The file SAMLIB.DLL is connected
    with the missing one Export-NTDLL.DLL-RtlFreeUnicodeString"

    I've got no clue to this problem. Could someone give me his/her kind
    advice?

    Thank you in advance.

    Some1.
     
    Some1, Apr 2, 2004
    #1
    1. Advertisements

  2. Some1

    °Mike° Guest

    I have already told you what that error means. It
    is telling you that you have the wrong version of
    samlib.dll . I suggest you contact the vendors.
     
    °Mike°, Apr 2, 2004
    #2
    1. Advertisements

  3. Some1

    Some1 Guest

    Thank you for your suggestion. I've noticed that the version of the
    dll's are not matching, but I can't solve it. The problem begins when
    the unistallation of EnterNet PPPoE finishes.
    Trying to match versions of dll's was tried several times, with several
    versions. Always appears an Error Message.
    Which vendor do you suggest to call? EnterNet provider?

    Some1.
     
    Some1, Apr 2, 2004
    #3
  4. Some1

    °Mike° Guest

    The vendors of the hardware/software that is trying
    to install the wrong version -- I don't have access to
    your system, that's your department.
     
    °Mike°, Apr 2, 2004
    #4
  5. Some1

    Some1 Guest

    Ok. Ashamed to say so, but I gave up.

    My solution: Clean Restore from the 2 CD set from Compaq. Installation
    of Linksys adapter driver and EnterNet PPPoE to download updates and
    needed software quicker.
    Did not uninstall Linksys adapter driver nor EnterNet PPPoE.
    Installation of Dial-up connection and account, and set this as default
    (as this will be the only means of connecting to internet from now on).
    Everything seems to work ok now.

    Some1.
     
    Some1, Apr 5, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.