Missing or Corrupt...\systems32\hal.dll

Discussion in 'Computer Support' started by Rubix, Jan 16, 2006.

  1. Rubix

    Rubix Guest

    I had a computer hick-up recently where my computer would suddenly
    reboot itself. It has happened often but until now it would restart
    into Windows XP. Now when it starts it doesn't boot, all that appears
    is an underscore. The bios still recognizes the drive and I ran a
    diagnostic test on the Maxtor SATA and it passed. I am unable to
    repair Windows as I select R it goes to the repair console and askes
    me to type exit. I created a floppy containing this info:

    xcopy c:\boot.ini a: /h
    xcopy c:\ntdetect.com a: /h
    xcopy c:\ntldr a: /h

    When it booted in stated that the \systems32\hal.dll was missing or
    corrupt.

    At the dos prompt I was not able to gain access to view directories in
    my c:\

    I can't repair windows and F8 doesn't work so what are my options
    besides the obvious of formatting and/ or trying to recover in NTFS
    format, which I don't think is possible. Regardless I wouldn't want to
    go that route.

    Thanks,
    Rube
     
    Rubix, Jan 16, 2006
    #1
    1. Advertisements

  2. Rubix

    Tony Guest

    When you get to the command prompt (C:) try typing bootcfg. This should fix
    any errors in the boot.ini. Then try the repair install again.
    If that still doesn't work, where D: is the letter of your CD drive, try
    typing:

    copy D:\i386\ntldr C:\
    copy D:\i386\ntdetect.com C:\
    attrib -h -r -s C:\boot.ini del C:\boot.ini
    BootCfg /Rebuild

    This will rebuild the boot.ini file.
     
    Tony, Jan 16, 2006
    #2
    1. Advertisements

  3. Rubix

    Rubix Guest

    I should state that I am able to get to the repair/recovery mode but
    the option is not given when I select "to set up windows now, press
    enter". The following screen does not show:
    c:\windows "Microsoft Windows XP Professional" rather "Partition 1"
    appears.

    At the recovery console I did a chkdsk:
    "The volume appears to contain one or more unrecoverable problems."

    In c:\dir:

    "An error occurred during directory enumeration."

    Rube
     
    Rubix, Jan 16, 2006
    #3
  4. Rubix

    Rubix Guest

    It won't allow to copy. It appears c:\ is corrupt.
     
    Rubix, Jan 16, 2006
    #4
  5. Rubix

    Tony B Guest

    When you put the XP disk in to do the recovery, did you press F6 to
    install the SATA drivers? IIRC the it won't read the SATA drives unless
    the SATA drivers are reinstalled.

    You could also try doing a reinstall up to the stage past the licence
    agreement up to the bit where it reboots and asks you to press any key to
    boot from the CD ROM. Don't press any key and see if it will boot from
    the hard drive. It should then detect the corrupt version of XP and give
    you the option of either doing a new install or a recovery. If it does,
    chose the recovery option.

    Afraid it does look like you are going to do a fresh install of XP. You
    could try downloading a copy of Knoppix and booting from that to see if
    you can recover any data you want.
     
    Tony B, Jan 16, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.