Microsoft Press Training Kit Exam Prep 70-529

Discussion in 'MCTS' started by fairyliquid, Dec 7, 2008.

  1. fairyliquid

    fairyliquid Guest

    I am unable to run the exam prep installed on my Vista Home Premium.
    Once the software is installed and I try to run the Microsoft Press Training
    Kit Exam Prep v7.9.0.2 application I keep getting the following error message:

    Run-time error '-2147319779 (8002801d)':
    Automation error
    Library not registered

    I have uninstalled and re-installed it but have had no successs in running
    any of the sample test questions. I have Office 2000 installed.

    Can anyone help?
    fairyliquid, Dec 7, 2008
    1. Advertisements

  2. I had to deal with the same problem. Apparently the Practice Test software
    included with the Training Kits are not certified on Vista. You could try one
    of the following workarounds as suggested by the Microsoft/MeasureUp support
    (see the email trail below). The only way I could make it to work was to
    setup a VirtualPC with Windows XP SP2 loaded on my Vista machine. This would
    require you to have a valid Windows XP license.

    Here's a tip, I've cleared this exam and didn't find the practice test on
    the Training Kit CD to be useful (even after jumping hoops to set it up). You
    might want to try purchasing the practice test directly from MeasureUp (and
    btw that works on Vista).

    Email trail w/ tech support:

    Date: Fri, 23 May 2008 08:42:00 -0400
    Subject: RE: Microsoft Learning Support case #19924

    Hi Vikrant;

    We are so sorry. We don’t know why the UAC is involved but since the fix is
    not working for you, we suggest that you try the options below, one of them
    will work for you.

    Open Computer or Windows Explorer and go to the C:\Program Files\Microsoft
    Press Training Kit or Readiness Review folder and in there is
    MsLocalWare.exe. Right click the executable and pick properties, on the
    Compatibility tab select the checkbox to Run this Program as Administrator.

    Otherwise, our programmers suggested try installing or reinstalling the .NET
    Framework Version 2.0 Redistributable Package (x86) available from

    If that doesn’t do it we know that the Microsoft Virtual PC will work and
    you can install our software there. I’ve setup
    a couple of these virtual PC’s now and it’s a very nice solution. Especially
    if you have some older software that won’t run on Vista.

    We regret the inconvenience this has caused you. Please let us know if you
    have any questions or concerns.

    Have a great weekend!
    John Hecht
    MeasureUp Support
    678 356 505
    Subject: RE: Microsoft Learning Support case #19924
    Date: Thu, 22 May 2008 17:37:16 -0700


    I need to follow up on this support case. I followed your instructions and
    uninstalled the Test Prep software. Then turned UAC back on. Rebooted as
    required. Installed the Test Prep back again and it works fine. The UAC is
    still turned on. However, after a couple of days of working fine it is giving
    me the same error again upon launching the Test Prep software. See attached
    screen shots.

    This time again I uninstalled the software. Turned UAC off (since it was on
    already). Rebooted. Turned UAC back on. Rebooted again as required. Installed
    the software again. And it works fine again (Note: In my case the Test Prep
    software never works with UAC turned off). I've done this process of
    uninstalling and installing the software more than a couple of times already.
    I don't think this is a reliable workaround. And it is very annoying and a
    time consuming process. Could you please suggest me a permanent solution to
    this problem or at least what really causes it.

    Any help would be greatly appreciated.

    Vikrant Kalha
    Date: Tue, 29 Apr 2008 15:49:30 -0400
    Subject: RE: Microsoft Learning Support case #19924


    Sorry for the trouble. Please uninstall the program from Control Panel first
    or by running the CD again and picking remove. Then in Control Panel select
    the User Accounts and select to turn off the User Account Control for the
    moment. Or if it is turned off, turn it on. Then close up Control Panel and
    reinstall the software. See if the program runs before changing the UAC back
    to its prior state.

    Thank you,
    Customer Support Specialist
    V) 678-356-5050
    F) 770-777-0732
    11660 Alpharetta Highway, Suite 490
    Roswell, GA 30076
    Vikrant Kalhan, Dec 18, 2008
    1. Advertisements

  3. Hi,
    I had the same problem,
    but to solve it I register Vsocx6.ocx
    Just run from command prompt
    regsvr32 C:\Windows\System32\Vsocx6.ocx

    I believe it will help to you.

    Alexander Shapovalov, Jan 17, 2009
  4. fairyliquid

    Adrian Guest

    Thanks Alexander - I had the same problem and Registering Vsocx6.ocx fixed it
    for me.

    It's located in C:\Windows\SysWOW64 on Vista-64.
    Adrian, Feb 6, 2009
  5. fairyliquid

    Chartrand Guest

    Yeah, registering vsocx6.ocx fixed for me too. I'm running vista 32.

    Chartrand, Feb 20, 2009
  6. fairyliquid


    Jul 26, 2009
    Likes Received:
    Спасибо, помогло! Thank you!
    keykeeper, Jul 26, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.