Memory slot gone AWOL

Discussion in 'NZ Computing' started by Lodi, Mar 16, 2009.

  1. Lodi

    Lodi Guest

    Hi all...I have two memory slots on my mobo (XP-K7VM333) and the second one
    has gone missing. It previously happened a few weeks ago but it came back
    when I cleared the CMOS (bridging the jumpers as per the manual).

    This time bridging the jumpers didn't work, pulling the CMOS battery didn't
    work, even re-flashing the BIOS didn't work.

    At the BIOS boot-up screen the BIOS mistakenly labels slots 0 and 1 (the
    only slots I have) as slots 2 and 3. No sign of slots 0 and 1

    Also both slots have a stick of ram in them (both sticks are fine as I've
    tested them elsewhere) but the output of "sudo lshw -C memory" shows my
    second slot (the missing slot) to be occupied and my first slot (the
    working slot) to be empty. Very screwed up.

    Here's the relevant output of "sudo lshw -C memory"....

    description: System Memory
    physical id: 18
    slot: System board or motherboard
    size: 512MiB
    capacity: 512MiB
    description: DIMM 333 MHz (3.0 ns) [empty]
    physical id: 0
    slot: A0
    width: 64 bits
    clock: 333MHz (3.0ns)
    description: DIMM 333 MHz (3.0 ns)
    physical id: 1
    slot: A1
    size: 512MiB
    width: 64 bits
    clock: 333MHz (3.0ns)

    The only recent change to this mobo was my fitting a replacement (second
    hand) PSU as the original one was needed elsewhere.

    Any thoughts, suggestions, tips or tricks welcome.

    Lodi, Mar 16, 2009
    1. Advertisements

  2. Lodi

    Lodi Guest

    Sorry rugby people.....I hit the "Screw up and make a fool of yourself"
    button instead of the "post to newsgroup" button.

    I blame the elves.

    Lodi, Mar 16, 2009
    1. Advertisements

  3. Lodi

    Lodi Guest

    And sorry computer people....I hit the "screw up totally and cross-post to
    every subscribed group" button.

    You've gotta love the flexibility of KDE :)

    Lodi, Mar 16, 2009
  4. Lodi

    Lodi Guest

    Howdy Bobs...The battery is a standard CR2032. I've just pulled it and
    tested it. It's giving 3.12v (nominal 3.0v) so I'm guessing it's okay.

    As for the super cool operating want cryptic?

    This afternoon it took me the best part of an hour to get my computer to
    recognise and read a floppy disk.

    Automatic floppy disk support (post-installation) was taken out at the
    previous version of Ubuntu. Nobody told me. So off to google.

    Eventually I worked out that because this was the first time Ubuntu had
    used the floppy disk drive to read a floppy disk I simply needed to
    modprobe my floppy and root edit my /etc/modules, mkdir a /floppy in my /
    media, grep for a fd0 in my lshw to root edit my /etc/fstab, then a sudo
    mount -a.....just to read a floppy disk.

    It almost made me nostalgic for XP

    Lodi, Mar 16, 2009
  5. Lodi

    Nigel Evans Guest

    Have you considered sheep farming as an alternative ?
    Nigel Evans, Mar 16, 2009
  6. Had an Australian house guest, by any chance?

    Chris Parslow, Mar 16, 2009
  7. Lodi

    Lodi Guest

    Compressed air and moderate degrees of violence seem to have done the

    Guess it's an indication that the mobo is on its way out. Five-ish years
    of 24/7-ish use from a $150 board. Can't complain.

    Lodi, Mar 17, 2009
  8. Lodi

    Dave Doe Guest


    Pretty old mobo now mate. Check the cap (capacitors), do they look
    "bloated" on top? - got any "material" building up on the tops of them?

    If so, definately time for a new mobo.
    Dave Doe, Mar 17, 2009
  9. So basically it can see the slot, just not what's in it.
    Maybe it was just dust in the slot affecting contact with the pins?
    Lawrence D'Oliveiro, Mar 17, 2009
  10. Lodi

    Gib Bogle Guest

    Some attention with a rubber might be called for.
    Gib Bogle, Mar 17, 2009
  11. Of course you should complain when a motherboard dies after just 5
    years. Old TVs often keep going for up to 20 years, and there is no
    reason for computers to be worse than that. The use of bad capacitors
    has just made us expect less from computers, but it is clearly a
    manufacturing fault to use bad capacitors that do not last, and any
    motherboard that you buy now should be expected to last more than 10
    years, not just 5.
    Stephen Worthington, Mar 17, 2009
  12. Lodi

    Enkidu Guest

    Why is automounter not working for you? Why edit the /etc/fstab and
    /etc/modules? That makes it permanent. Why create a subdirectory in
    /media. If automounter is not working for you all you need to do is
    modprode floppy, and mount /dev/fd0 somewhere. But while you are there
    you can create disk image files of all your floppies and then forget
    about them. I haven't had a floppy drive for more than three years.


    Enkidu, Mar 17, 2009
  13. Lodi

    timbochov Guest

    Get a Mac.
    timbochov, Mar 17, 2009
  14. Lodi

    ~misfit~ Guest

    Yet, from the sounds of it, this was a 'contaminant in the RAM slot' issue
    rather than a longevity thing. It's a known hazard when you have a CPU
    cooler right beside it moving lots of air and dust. With older computers I
    find a good squirt of CO cleaner is often needed in the RAM slots (and
    sometimes the module contacts need cleaning with an eraser when re-seating).
    ~misfit~, Mar 17, 2009
  15. Lodi

    Bao Bab Boom Guest

    dont forget to check your prostate.....dogs are very good for this
    Bao Bab Boom, Mar 17, 2009
  16. Lodi

    Lodi Guest

    A safe premise from which to start is that I don't know what I'm doing.
    Hence the googling.

    I've never come across anything called automounter but if it's supposed to
    do what it sounds like it's supposed to do then it failed.

    *As I understand it* the whole process breaks down into two parts.
    1) Get Ubuntu to recognize the floppy drive and then
    2) Make the floppy drive a permanent feature at boot-up

    Loading the floppy module is modprobe's job. Once I knew Ubuntu could
    recognize the floppy drive I could then edit /etc/modules to make it

    Making the /media/floppy directory gave me the "somewhere" you alluded to in
    your post. Editing /etc/fstab gives me a permanent "somewhere" which shows
    up in my Storage Media link. This is where I keep links to all of my
    partitions, usb drives and dvd drives. And now my floppy disk.

    You said......"all you need to do is modprode floppy, and mount /dev/fd0"

    I certainly tried that early on in the piece but got the following......

    mount: /dev/fd0 is not a valid block device

    As I said earlier, hence the googling. We're not all nix gurus you know.

    Lodi, Mar 17, 2009
  17. Lodi

    Lodi Guest

    What on earth does that mean???

    Seriously....I'm wondering what a prostate is. Is it prostrate misspelt.

    And if it is what on earth is the link between a prostrate sniffing canine
    and a malfunctioning ram slot.

    Lodi, Mar 17, 2009
  18. Lodi

    Lodi Guest

    Lodi, Mar 17, 2009
  19. Lodi

    Enkidu Guest

    No, he spelt it right.

    The doctor tests for prostate cancer by inserting a finger up your bum.
    I think he's making jokes about 'RAM' and 'slots',. Dogs have a habit of
    sticking their noses where they shouldn't.


    Enkidu, Mar 17, 2009
  20. Lodi

    Enkidu Guest

    I'm surprised that you want to make it permanent, that's all.
    Well, sounds like the module wasn't loaded, possibly, but I haven't had
    a floppy drive for so long my memory may be getting hazy.
    But *you* solved it. That makes *you* the guru!


    Enkidu, Mar 17, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.