Maxtor One-Touch external drive - suddenly Windows doesn't see it anymore...help?

Discussion in 'Computer Support' started by Walter Mautner, Apr 11, 2007.

  1. tis only me wrote:

    ......
    Ok, so it's lost the drive letter. Can you see it in disk management, and
    what does it tell there, and then when you right-click the partition entry?
    Can you see it when you start from a livecd like knoppix or winpe?
     
    Walter Mautner, Apr 11, 2007
    #1
    1. Advertisements

  2. Walter Mautner

    tis only me Guest

    You guys in here have never let me down over the past 10 years, but
    this problem may have too many possibilities.

    Last night...while un-raring some files on my Maxtor 300gig external
    drive, I accidentally pulled the power cord out of my Canon printer
    that was also on..connected with USB. (Maxtor is connected using USB
    as well.)

    Got the usual warning from Windows with the "unplug and eject" dialog,
    clicked "ok" and then found out that my Maxtor had disappeared from
    sight in Windows. (It was originally assigned as Drive Letter "G")

    Have uninstalled the Maxtor, re-installed, re-booted about 5 times,
    but Windows still doesn't see it anymore.
    I never ever touched the drive...but the printer somehow affected it.

    Anyone here know where to start looking?
    (PS: The Maxtor is still listed in the Device Manager)

    thanks in avance!

    -me-
     
    tis only me, Apr 11, 2007
    #2
    1. Advertisements

  3. Walter Mautner

    tis only me Guest

    Guess I should have mentioned, that I am running Windows 2000 as an
    OS.

    Forgot that.
     
    tis only me, Apr 11, 2007
    #3
  4. Walter Mautner

    tis only me Guest

    Ouch..my disk manager doesn't seem to be up to snuff either.
    (although i'm anything but a newbie...i'm not all that familiar with
    disk management)
    My first attempt to check out DM, under "storage" the folder beneath
    it isn't labeled. strange. when trying to open it got the following
    error:
    "Runtime error!
    C:.winnt\system32\mmc.exe

    R6025
    -pure virtual function call"

    and it crashed.

    2nd attempt, didn't "error", but something isn't right.
    if i right-click on any of the drives, i can't see what the options
    are. the dialogs are all blank.
    (I assume the top option is "open" because it opened my internal
    drives, but when i tried it on the Maxtor, nothing happened.
    I'm also assuming the bottom option is "help" but I have no idea what
    the middle options are.)

    The Maxtor drive indicates the amount of data on the drive, but
    nothing else.

    (I did check the Maxtor website, and saw their graphics on what I
    should see in Disk Management, but mine don't look like that.
    The word "healthy" doesn't appear anywhere on any of my drives.)

    Now i'm getting nervous....

    (Maxtor makes a big deal about how you just plug this thing in, and it
    appears on your desktop. That's what happened when I first installed
    it last year. I'm befuddled why I can't just do that now.)
     
    tis only me, Apr 11, 2007
    #4
  5. Walter Mautner

    Jerry Attic Guest

    Try running checkdisk at a reboot to see if anything has become
    corrupted.

    Jerry
     
    Jerry Attic, Apr 11, 2007
    #5
  6. Walter Mautner

    Jerry Attic Guest

    tis only me <> said in


    Had a thought that might help you. Go to majorgeek.com and download the
    newest version of the "Ultimate Boot CD.' I has a bunch of different diag
    and repair programs on it. I've used it and found it to be pretty
    comprehensive.

    Jerry
     
    Jerry Attic, Apr 11, 2007
    #6
  7. Walter Mautner

    tis only me Guest

    If Windows isn't seeing the drive...will I still be able to run
    checkdisk??
     
    tis only me, Apr 11, 2007
    #7
  8. Well, I guess your OS is stuffed up somehow. Run sfc /scannow with your
    windows cd inserted (the already existing registered drives hopefully still
    work) and hope it will repair your system.
    Check your harddrive ASAP after you managed to backup important data.
     
    Walter Mautner, Apr 12, 2007
    #8
  9. Walter Mautner

    James Guest

    A couple of thoughts:

    Have you tried to remove/uninstall the device from Device Manager and
    then plug it back in and let Windows re-recognize it, or did you
    uninstall it from Add/Remove Programs? Have you tried another USB
    port or cable--those do go bad from time to time. And the obvious
    one: Does the Maxtor drive have power?

    Hope this helps.

    James
     
    James, Apr 14, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.