Mapping the LPT1 Port to a network printer

Discussion in 'Wireless Networking' started by Guest, Nov 22, 2005.

  1. Guest

    Guest Guest

    I have successfully mapped the LPT1 port to a network printer using the Net
    Use command (persistent:yes) and it works great for me. My users, however,
    don't have local administrative rights and it doesn't work for them. Is
    there a way to map map that printer so that it's mapped for all users,
    regardless of their local permissions, or is there a way to do this without
    making them an administrator?

    Thank you,

    Andy Siegel
    Dover, DE
     
    Guest, Nov 22, 2005
    #1
    1. Advertisements

  2. Guest

    Ryan Younger Guest

    The way this should be done is to have all user's machine's as part of a
    domain, having user's log onto their machine's using their active directory
    user account and have a central print server which has all network printer's
    added to it. You can then add a printer/s via group policy based on group
    membership..

    --
    All the best,

    Ryan Younger.
    http://spaces.msn.com/members/wirelessnetworking/ - Ryan's Wireless
    Networking Weblog

     
    Ryan Younger, Nov 22, 2005
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    I'm so sorry I forgot this one little important fact. I'm trying to print
    from a DOS based program that has to use LPT1. I wish it were this easy.

    Andy
     
    Guest, Nov 23, 2005
    #3
  4. You have replies in other groups - in the future, please don't multipost -
    if you need to post to multiple groups, it's best to crosspost instead, by
    posting a single message to a handful of relevant groups (separate the NG
    names with commas) so that everyone can follow the thread. Thanks :)

    See http://www.blakjak.demon.co.uk/mul_crss.htm

    That said - as I said in one of the aforementioned replies, try using a
    startup script rather than user login script.
     
    Lanwench [MVP - Exchange], Nov 23, 2005
    #4
  5. Guest

    Ryan Younger Guest

    This can occur due to the fact that a user without administrative priviliges
    can't map LPT1 to a printer using an environment variable setting for the
    command window that launches the program (using net use) if the LPT port is
    already assigned to the local parallel port. The fix is to use the
    Devcon.exe tool which is included with the Windows XP DDK to disable the LPT
    port mapping to the local parallel port when the computer starts. You must
    include this command in a script which runs when the computer starts as
    lanwench has pointed out:

    Non-Administrators Cannot Remap an LPT Port to a Network Printer

    http://support.microsoft.com/kb/313644/


    --
    All the best,

    Ryan Younger.
    http://spaces.msn.com/members/wirelessnetworking/ - Ryan's Wireless
    Networking Weblog





    "Lanwench [MVP - Exchange]"
     
    Ryan Younger, Nov 24, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.