Managing Computers Remotely with the MMC

Discussion in 'MCSE' started by Guest, Sep 25, 2005.

  1. Guest

    Guest Guest

    Hello,

    I've just started studying for MCSE (70-290) using the Microsoft Self-Paced
    Training Kit and have installed W2003 server under Virtual PC running under
    Windows XP Pro.

    Page 2-10 asks me to

    1) Open the Computer Management Console
    2) Right click Computer Management in the tree pane and and choose Connect
    to Another Computer
    3) Type the name or IP address of the computer and click OK to connect

    At this point no other computers have been joined to the Domain but I can
    see resources on the XP Pro via Network Places (I'm using Virtual Switch in
    VPC). The first sentence of the chapter suggests I should be able to do this
    "in a peer-to-peer network"

    It also warns I must have administrative credentials on the remote computer
    and that I can use Run As to launch a console with such credentials.
    I've used Remotemachinename\remoteusername where this is the id of a user
    with Admin privileges on XP.

    I get:

    "Unable to Logon:
    Logon Failure: Unknown User or bad password"

    What do I have to do to log on to the remote machine?

    Thanks.
     
    Guest, Sep 25, 2005
    #1
    1. Advertisements

  2. Guest

    Vincent Lape Guest

    generally the copmuters in my netwok who are not domain members are accessed
    by using address \\<computername> when i get the login prompt use
    administrator / admin password
     
    Vincent Lape, Sep 25, 2005
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Many thanks for your reply Vincent.

    I am able to access the XP computer using \\<computername> via eg Start Run.
    It immediately shows me my shares without asking for an id or password.
    (Strange?)

    The specific problem I have is using the "Connect to Remote Computer" option
    in an MMC eg compmgmt.msc. It accepts the name \\Atlas but when I then try to
    open Event Viewer I get "Unable to connect to the computer "Atlas" the error
    was: Access Denied"

    When I try starting the MMC using Run As (as suggested in the Training Kit
    text), I can't get it to accept a valid XP id/password. I've tried
    "\\Atlas\Administrator and checked that the password is correct (it's the
    same on XP and W2003) but no joy. Just entering \\Atlas without an id or
    password gets the same result.

    Presumably W2003 is checking these in Active Directory. Should I add them
    even though Atlas isn't joined to the Domain?

    Any further suggestions/comments gratefully received.

    Thanks Again.

    Graham.
     
    Guest, Sep 25, 2005
    #3
  4. Guest

    catwalker63 Guest

    "=?Utf-8?B?dGF0dGVyamFjaw==?=" <>
    prattled ceaslessly in
    Make sure the username and password are the same on both computers.
    Also, turn off simple file sharing on the XP box.

    --
    Catwalker
    aka Pu$$y Feet
    BS, MCSA, MCSE
    MCNGP #43
    www.mcngp.com
    faq.mcngp.com
    "Definitely not wearing any underwear."
     
    catwalker63, Sep 25, 2005
    #4
  5. Guest

    Briscobar Guest

    Try "Atlas\password", not "\\Atlas\password". Without the quotes, obviously.
     
    Briscobar, Sep 26, 2005
    #5
  6. Guest

    Guest Guest

    Thanks for your input catwalker63.

    I was using the Administrator id which has the same password on both
    computers. Simple file sharing was on. I turned it off and restarted both
    systems but still got the same problem.
     
    Guest, Sep 26, 2005
    #6
  7. Guest

    Guest Guest

    Thanks Briscobar

    I've tried both those variations and a few others. No joy.
     
    Guest, Sep 26, 2005
    #7
  8. Guest

    Guest Guest

    Thanks everyone. I still can't get this to work using RunAs but have found
    that I can access a remote computer in an MMC using the IP address so I'm
    going to bypass this till I know a bit more.

    in as concise a manner as he was able but at the same
    time attempting to give sufficient information:
     
    Guest, Sep 26, 2005
    #8
  9. Guest

    Ben Smith Guest

    Can you connect via RDP?
     
    Ben Smith, Sep 26, 2005
    #9
  10. Guest

    Ben Smith Guest

    You have a name resolution problem - the #1 troubleshooting issue with
    Windows. Welcome to your life. :)
     
    Ben Smith, Sep 26, 2005
    #10
  11. Guest

    Peter Guest

    is Net-Logon service running?
    is Secondary Logon service running?
    is RPC service running?
    is Secondary Logon service running?

    Greetzz Peter
     
    Peter, Sep 26, 2005
    #11
  12. Guest

    Guest Guest

    Thanks Ben,

    Yes I think that may have been part of the problem. The rest was ignorance
    and an RTFM failure.
     
    Guest, Sep 27, 2005
    #12
  13. Guest

    Guest Guest

    There was also a problem of connecting via RDP. It just presented a black
    screen. This has also "fixed itself".

    RDP from a guest m/c under Virtual PC to the host is interesting. It pops up
    a message asking if it is OK to log off the host. Answering OK logs off the
    host and presumably makes the connection which cannot be seen unless I'm
    logged on to the host. Logging back onto the host breaks the RDP connection
    by design but when I look at the guest VPC again it's showing the host's
    desktop and a message that the connection was closed. I think I should create
    another guest VPC of XP Pro to carry out simulations. All a bit alice in
    Wonderland.
     
    Guest, Sep 27, 2005
    #13
  14. Guest

    Guest Guest

    Thanks Peter,

    The problem is now resolved. These services are running now but I didn't
    check them while it persisted.
     
    Guest, Sep 27, 2005
    #14
  15. Guest

    Guest Guest

    Thanks Everyone,

    The problem is now resolved although I might still have a misunderstanding
    of RunAs.

    Causes:

    1) My stupidity: I had assumed I wouldn't be able to access the XP machine
    through MMC without Run As XPmachine\userid. In fact I could do it by
    entering IP address and eventually just computername which is what the book
    asked me to do.

    2) My ignorance: I thought RunAs would scan the network for the computername
    and verify the id/password on the target computer. It looks as though it has
    to be defined on the source computer (am I still wrong here?)

    3) A glitch: due to originally installing W2003 under Virtual PC with shared
    networking instead of virtual switch, I had numerous problems with DHCP, DNS,
    Active Directory which might still have been hampering DNS

    In summary as several you said, as long as the same id exsts on both
    machines with sufficient privileges this should work without Run As. If the
    passwords are the same it doesn't even ask for password.

    Thanks again.
     
    Guest, Sep 27, 2005
    #15
  16. Guest

    Neil Guest

    admitting you have a problem is the first step. pull up a chair and have
    a coffee....

    "Hi, my name is Neil and I have a problem with failing to RTFM. I think
    it all began as a young boy. you see, I was born a man..."
     
    Neil, Sep 27, 2005
    #16
  17. Guest

    FrisbeeĀ® Guest

    That would be some trick... and rather painful for your mother.
     
    FrisbeeĀ®, Sep 27, 2005
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.