machine_check_exception ?

Discussion in 'A+ Certification' started by Frank, Apr 23, 2004.

  1. Frank

    Frank Guest

    WinXP Home

    My daughter is experiencing unexplainable blue screen crashes and the
    machine automatically reboots.
    The error message is not on for long enough to read, but she did catch a
    glimpse of part of the message, "machine_check_exception" .
    There is no pattern to what software she's using when it happens - it seems
    random. I have turned off the Automatically Restart in control panel>system.

    Can anyone offer a diagnosis & solution?
    Frank, Apr 23, 2004
    1. Advertisements

  2. Frank

    Tony Guest

    Here is a crazy idea that worked for me when someone was getting an error message that lasted a
    split second.

    I pointed my camcorder at the screen and taped it. When I played the tape back, I paused it on the
    frame that showed the message. I wrote it down, checked MS knowledge base and fixed the problem.

    Tony, Apr 23, 2004
    1. Advertisements

  3. Frank

    Frank Guest

    great idea - but dont have a camcorder

    Frank, Apr 23, 2004
  4. Frank

    Frank Guest


    I have already unchecked the automatically reboot box in control

    I'm having problems with memtest. I d/l the floppy version and the 1.11 ver
    had a missing file and couldn't install to floppy. The older one ver. 1.00
    was ok. However, following the instruction to reboot with it in the drive
    just brought up the invalid system disk error message. Maybe it cant work
    with XP ?

    I did however find TuffTest Lite and Doc Memeory - I will try one of them.

    I'm ignorant about dumps and minidumps and dumpchk. I assume it's part of XP
    ? Where do you run it from? And looking at the MS link it aint easy to
    interpret ?
    Frank, Apr 23, 2004
  5. Frank

    Frank Guest

    Memory tests ok.

    found this to help me run dumpchk

    will get back with info
    Frank, Apr 23, 2004
  6. Frank

    Frank Guest

    OK, got Memtest going - after a few hours it's still going and
    I dont know how to interpret the screen results, or whether it means it
    could be a faulty ram stick?
    I would like to write them up here and see if they make sense to you. The
    display is in 2 lines and is shown horizontally (rows & columns).

    Top Line:
    Ecc Errs=0

    Second Line:
    Failing Address=00014fb65bc - 335.3mb

    (hope I transferred those correctly!) - Does this mean anything to anyone?
    Looking at the Memtest page they say all you can do anyway is swop the ram
    sticks with known-good modules and see if the problem goes away. Is this the
    problem ?
    Regarding reading the minidump file - where can I get dumpchk.exe ? I tried
    from RUN and searching the hard drive - nothing. I tried Google - nothing.
    Is it available?

    That machine just crashed on me and when it rebooted (automatically despite
    that feature being turned off in System) the message was "you have recovered
    from a serious error:
    BC Code:9c BCP1:00000000 BCP2: 8005366FO BCP3:CC0000FF BCP4:20040189
    OSVER:5_1_2600 SP:1_0 Product 768_1

    Does this mean anything to anyone?
    Frank, Apr 24, 2004
  7. Frank

    Frank Guest

    It is strange that Memtest showed bad memory and neither DocMemory or
    TuffTest Lite showed anything?
    I will now run Memtest again with one stick at a time to isolate the
    culprit. Which part of the second line exactly is it that you used to
    diagnose a bad stick so I can look at it again with the test on the
    individual sticks?
    Frank, Apr 24, 2004
  8. Frank

    Frank Guest

    We didn't get an xp cd with this system, only a 'recovery' cd which has the
    OS - i will try but i suspect it may be more difficult to extract dumppchk
    from this
    Frank, Apr 24, 2004
  9. Frank

    Frank Guest

    You are quite a sleuth:) Fascinating how you are tracking down the culprit.
    There are 2 sticks (slots) on this mobo. It orignally came with 1x 128mb ram
    module and we added a 256mb stick So I guess it's the 256 stick then
    (assuming it reads the 128 first ! ) ?

    Why would good ram suddenly go bad - the system was purchased in Sept2003.
    Basic specs according to Aida32 are:
    Celeron 4A, 2433mhz
    Gigabyte GA-85650GXM mobo
    SIS 650GX chipset
    XPHome SP!
    Frank, Apr 24, 2004
  10. It isn't crazy if it works... :)

    Tom MacIntyre, Apr 24, 2004
  11. Unless you suspect digestive problems... :)

    Tom MacIntyre, Apr 24, 2004
  12. Frank

    Frank Guest

    I ran Memtest86 overnight on individual ram modules, and 1 stick (128) is
    good and the other (256) is bad. Just a thought though, could it be the slot
    and not the ram stick? I could try to verify and run the bad stick in the
    other slot (where the good stick tested good)? If it were to be the slot, is
    that necessarily symptomatic of a bigger issue - like the motherboard and/or
    psu ?
    Frank, Apr 24, 2004
  13. Frank

    Frank Guest

    The same stick was bad in both slots. I've just bought another stick and it
    tests good. So I'm hoping this is the end of the story. Thanks for helping
    me find my way - much appreciated !!!
    (the failed stick was AzenRam DDR 2100 133mhz unbuffered 2.5V CAS 2.5)
    Frank, Apr 24, 2004
  14. Frank

    Frank Guest

    Hey Will, guess I can toss DocMemory and TuffTest Lite now :) MemTest86 is
    all I need.
    Frank, Apr 25, 2004
  15. Frank

    Frank Guest

    You're not gonna want to hear this - well it happened again just now. The
    only thing she's done since I replaced the ram stick that May have anything
    to do with it (but I would think not), is downloaded windows updates after
    she was prompted to do so by the icon in the system tray. Yikes!
    Frank, Apr 25, 2004
  16. Frank

    Frank Guest

    Hi Will - sorry for the delay. It took a while to find an xp cd and install
    the support tools>dumpchck
    I have run it and pasted the contents herein - hopefully it provides
    troubleshooting clues. Also I ran MBM5 and the temperatures look good. And
    MemTest86 retested ok too. Finally the system was restored to a point before
    the windows updates and then re-updated but without the KB835732. I will
    also post this under the heading 'MiniDump analysis'

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Lara>cd\windows

    C:\WINDOWS>dumpchk minidump\mini042704-02.dmp
    Loading dump file minidump\mini042704-02.dmp
    ----- 32 bit Kernel Mini Dump Analysis

    MajorVersion 0000000f
    MinorVersion 00000a28
    DirectoryTableBase 00039000
    PfnDataBase 81053000
    PsLoadedModuleList 8054be30
    PsActiveProcessHead 8054de78
    MachineImageType 0000014c
    NumberProcessors 00000001
    BugCheckCode 0000009c
    BugCheckParameter1 00000000
    BugCheckParameter2 8053f0f0
    BugCheckParameter3 cc0000ff
    BugCheckParameter4 20040189
    PaeEnabled 00000000
    KdDebuggerDataBlock 8053dde0
    MiniDumpFields 00000dff

    ServicePackBuild 00000100
    SizeOfDump 00010000
    ValidOffset 0000fffc
    ContextOffset 00000320
    ExceptionOffset 000007d0
    MmOffset 00001068
    UnloadedDriversOffset 000010a0
    PrcbOffset 00001878
    ProcessOffset 000024c8
    ThreadOffset 00002720
    CallStackOffset 00002978
    SizeOfCallStack 00003000
    DriverListOffset 00005c08
    DriverCount 000000a3
    StringPoolOffset 00008c70
    StringPoolSize 00001680
    BrokenDriverOffset 00000000
    TriageOptions 00000041
    TopOfStack f2ebd000
    DebuggerDataOffset 00005978
    DebuggerDataSize 00000290
    DataBlocksOffset 0000a2f0
    DataBlocksCount 00000003

    Windows XP Kernel Version 2600 (Service Pack 1) UP Free x86 compatible
    Kernel base = 0x804d4000 PsLoadedModuleList = 0x8054be30
    Debug session time: Tue Apr 27 12:57:06 2004
    System Uptime: 0 days 0:05:41
    start end module name
    804d4000 806c6980 nt Checksum: 0020230B Timestamp: Thu Aug 29
    03:24 2002 (3D6DE35C)

    Unloaded modules:
    f309f000 f30af000 NAVENG.Sys Timestamp: unavailable (00000000)
    f2dff000 f2e90000 NavEx15.Sys Timestamp: unavailable (00000000)
    f2ea0000 f2eb0000 NAVENG.Sys Timestamp: unavailable (00000000)
    f2dff000 f2e90000 NavEx15.Sys Timestamp: unavailable (00000000)
    f78c8000 f78d8000 NAVENG.Sys Timestamp: unavailable (00000000)
    f4238000 f42c9000 NavEx15.Sys Timestamp: unavailable (00000000)
    f2f30000 f2f57000 kmixer.sys Timestamp: unavailable (00000000)
    f38c1000 f38e8000 kmixer.sys Timestamp: unavailable (00000000)
    f7de7000 f7de8000 drmkaud.sys Timestamp: unavailable (00000000)
    f3abe000 f3acb000 DMusic.sys Timestamp: unavailable (00000000)
    f7cb2000 f7cb4000 splitter.sys Timestamp: unavailable (00000000)
    f3ace000 f3adc000 swmidi.sys Timestamp: unavailable (00000000)
    f3923000 f3946000 aec.sys Timestamp: unavailable (00000000)
    f7b80000 f7b85000 Cdaudio.SYS Timestamp: unavailable (00000000)
    f757c000 f757f000 Sfloppy.SYS Timestamp: unavailable (00000000)

    Finished dump check

    Frank, Apr 27, 2004
  17. Thank you.

    The sad fact is that those who are subjected to a lot of my wit
    (friends, family, co-workers) have a radically different opinion than
    you. :)

    Tom MacIntyre, Apr 29, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.