Loss of WPA availability after reinstall

Discussion in 'Wireless Networking' started by Rob D, Feb 27, 2005.

  1. Rob D

    Rob D Guest

    This has got me really puzzled. On one of my laptops (Sony Vaio R505
    series), with XP Pro, I have been accessing my wireless network for many
    months without problem and with WPA-PSK encryption - hidden SSID.
    For unrelated reasons I decided to wipe the HD and reinstall XP from the
    Sony recovery discs a couple of days back.
    This is where it gets weird. After a succesful reinstall and going through a
    lot of hassle to get it set up just as I want it, I find the inbuilt (Ambit)
    Lan-Express wireless card doesn't give me an option for selecting WPA!
    I had previously installed lots of software over the past few months since
    it's last "rebuild" - and I'm pretty sure that last time I installed XP
    service pack 1 immediately after installing XP, then installed various
    Windows updates, including SP2 over a period of some time.
    The only difference this time is that I installed SP2 (from a saved download
    file), immediately after reinstalling Windows (i.e. no SP1 first, no
    individual updates from Windows Update site, etc. just directly to SP2).
    I'm really puzzled as to why I can't have the option for WPA when this card
    definitely had the option previously.
    If I run the Wireless Network setup Wizard I'm told my card doesn't have WPA
    ability. I've tried downloading earlier drivers from Windows Update (via the
    Admin link, where you get to see *all* updates), but none of these gives the
    card the WPA capability it previously had.


    Rob D, Feb 27, 2005
    1. Advertisements

  2. My bet is that the driver you are using is old, and that the drivers on
    Windows Update are just as old. Go to the Sony website and you should be
    able to get the latest drivers for your NIC and thus enable WPA-PSK
    Peter Bui[MS], Feb 28, 2005
    1. Advertisements

  3. Rob D

    Rob D Guest

    Thanks for the response, I'm sure you're right. especially as after a *lot*
    of playing around installing non - original drivers, I did at least get the
    *option* to use WPA - unfortunately that particular driver didn't allow my
    card to function correctly!
    Anyone who owns Sony will tell you "Go to Sony website....." means at the
    very least a lot of hassle. It's quite annoying that on their US website I
    can actually get a driver for this same card which includes the "enhanced
    wireles security" (presumably WPA). But downloading it gives me an .exe file
    which when run, tells me "Sorry, your model is not the specific machine
    which this download is intended for...." - Thanks Sony - same card, same
    I'm still puzzled as to how I managed to get WPA compatible driver installed
    before - it must be due to my not going directly to SP2 - and Microsoft's
    "we know best, you can only install *certified* drivers" attitude! However,
    I can see no sign of such a driver loose on the 'net.
    BTW, before anyone suggests it, I did look at the temporary extracted fies
    from the Sony .exe file - but it doesn't get far enough through extraction
    before coming to a halt and kindly informing me I don't have the "correct"
    machine. This is a self extracting exe, but Winzip won't extract it as it
    tells me it's an "unknown format".

    Rob D, Mar 1, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.