Linksys WAG54G

Discussion in 'Network Routers' started by William Cooper, Oct 28, 2004.

  1. Hi I am trying to set up a VPN using the above ADSL router. It seems that
    when I have IPSec pass through switched on it is blocking part of the
    protocol. I can see that I am connecting as the attempt creates log entries
    in the Smooth Wall log. The VPN I am using is Smooth Tunnel, an add on for
    Smooth Wall. This is the commercial version. I know it is using ESP Protocol
    50. I have other clients that can connect using Cable Modems and I can
    connect with a dailup connection, so I know that my certificate etc are
    good. Any ideas would be helpful.

    William
     
    William Cooper, Oct 28, 2004
    #1
    1. Advertisements

  2. Hi

    I know nobody has replied to this, but I now have an answer. According to
    Linksys, the firewall option has to be disabled, and in fact this works. But
    I do not find it a particularly good solution.

    There ya go eh.

    William
     
    William Cooper, Nov 9, 2004
    #2
    1. Advertisements

  3. Ya, that is what linksys told me too...LMAO... BEFSX41 couldnt get a
    connection to hold or even connect...linksys said turn off the fire wall...
    I did but didnt really work, so I upgraded both routers to a firmware that
    stink, but I now have a stable connection with the firewall turned on.. go
    figure...Look on the net for a hacked firmware (flogaters sight is very
    useful) he does what linksys ought to... when the time server that was hard
    coded in the firmware went down, had to get a hacked firmware to get it to
    keep time...then linksys fixed that with a lot of other problems... I am
    begining to think their firmware is like M$ Windows... full of holes... LOL
    My suggestion is th do a lot of googling to find your answer in the amass of
    information on the net.

    KK
     
    Kaptain Krunch, Nov 10, 2004
    #3
  4. I believe the exact problem is the NAT function in the router since it mucks
    around with the TCP headers, the addresses and the port numbers, to do it's
    thing. The security features in VPN don't really allow this so the protcol
    gets screwed. That's why they told you to turn off the firewall since it
    likely also turns off the NAT function in addtion to SPI.

    I don't see anything on the Linksys Web site with the model number of
    WAG54G. Maybe a WAP54G? It looks like it is one of their wireless router
    products with the "W" in the model number. Not all of their routers have VPN
    pass thru which is what I think you need. The WRT54G is a wireless router
    with a built in fire wall and VPN pass thru ability for two VPN tunnels.
    That way you should be able to leave the firewall on and the router detects
    the VPN traffic, handling it special so it works. The non speed booster
    version I've seen selling locally for around $70 at the computer stores.

    For more information read the info at the link below under the heading
    "Network Address Translator (NAT) Traversal".

    http://www.microsoft.com/windows2000/server/evaluation/news/bulletins/l2tpclient.asp

    --
    Leland C. Scott
    KC8LDO

    Wireless Network
    Mobile computing
    on the go brought
    to you by Micro$oft
     
    Leland C. Scott, Nov 10, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.