Linksys USB Wireless Adapter WUSB54GC Installed GTGina.dll

Discussion in 'Computer Support' started by James, Feb 25, 2006.

  1. James

    James Guest

    Last week I installed a new USB wirelss adapter, WUSG54GC, made by

    When my WUSB54GC was installed there was a file added--GTGINA.DLL--and
    changes made to the registry for that file. It apparently changed the
    way my logon (XP Home) works. My logon used to go directly to the
    desktop as I am both the only user and admin. Now it goes to the
    login screen asking for the login name and password. When I
    uninstalled the software, it went back to normal. When I reinstalled
    the software the same thing happened.

    This is not a serous problem only an annoyance. As far as I can tell,
    everything else runs normally and the wireless adapter works well.

    The only answer from Linksys so far is that it is no problem. I
    couldn't find anything on it in Google.

    The registry locationfor GTGina.dll is

    My questions: (1) Does anyone know what is the function of
    (2) Is GTGina.dll necessary for using the USB adapter?
    (3) Can I delete the file and/or remove it from the registry?

    I don't want to delete the registry entry or the file until I am sure
    I know the effects.


    James, Feb 25, 2006
    1. Advertisements

  2. James

    Meat Plow Guest

    Just installed one today. After installing the drivers and XP detecting
    and configuring it to use with Windows Wireless config, I aborted the rest
    of the installation(Linksys Wireless config utility). XP does a fine job
    on its own with this adapter.
    Meat Plow, Feb 26, 2006
    1. Advertisements

  3. James

    James Guest

    What I found was that the software installation change the
    DefaultUserName logon from my name to Administrator. When I changed
    it back then I am able to start up and go directly to the desktop.

    I found that in the registry entry

    Weird. Linksys says they don't know anything about it.

    James, Feb 26, 2006
  4. James

    James Guest

    What I found was that the software installation change the
    DefaultUserName logon from my name to Administrator. When I changed
    it back then I am able to start up and go directly to the desktop.

    I found that in the registry entry

    Weird. Linksys says they don't know anything about it.

    James, Feb 27, 2006
  5. James

    imacutiepie Guest

    I have that same problem with the GtGina file. Did you ever get your
    questions answered? I believe my user name is still my name..are you
    referring to your Windows logon username or to do with your internet
    imacutiepie, Mar 4, 2006
  6. James

    a747drvr Guest

    a747drvr, Mar 9, 2006
  7. James

    a747drvr Guest

    I have the same problem with GTGina.dll affecting the Windows Logon. I
    will attempt to contact Linksys for a solution and will post the result
    if there is one. Ridiculous!
    a747drvr, Mar 9, 2006
  8. I just got a Linksys wireless adapter - same problem and everything
    with GTGina.dll. I was worried at first because as I checked some info
    on the file I saw that it was created by Gemtek and I don't have any
    Gemtek products - but I guess the adapter may use a Gemtek piece or

    Do we have any updated news on the problem with the login. Hopefully
    Linksys will provide a patch or update to fix the problem/annoyance.

    I will check back frequently - I hope to learn something new.
    doubleamartinez, Mar 11, 2006
  9. James

    rodmcd2 Guest

    I just purchased and installed the linksys usb wirless adapter and it
    works fine but I have a problem with the Gtgina.dll file. The file
    prevents me from switching between users without logging off on my
    pc. This was a great feature for me. I don't know what to do. I
    unistalled the usb adapter, however the gtgina.dll file is still on
    my pc and in my registry(by the way, the adapter still works fine).
    Not sure what to do about this one. I guess I'll try to call lynksis
    also and I'll post what I find out. This sucks!!!
    rodmcd2, Mar 17, 2006
  10. James

    DocDEH Guest

    I checked with Linksys online support today. The answer was to download
    driver version from the Linksys website, then to "uninstall
    everything," reboot, install the new driver, then plug in the device.
    But DO NOT do what I did. I renamed GTGina.dll thinking then the
    computer would bypass it. It doesn't. I refuses to start up Windows at
    all without that in place. I could not even get to Safe Mode and am now
    doing a complete system restore. I like Linksys products and paid more
    for this Linksys adapter than I would have for a D-Link because I have
    had great experience with Linksys before. But this GTGina business is a
    scary one.
    DocDEH, Mar 17, 2006
  11. James

    DocDEH Guest

    After the reinstall of the OS I took the risk of installing the
    driver and utilities. Bad news. GTGina.dll is right back there. It's
    from Gemtek in Taiwan; is it possible they are the makers of the
    Linksys hardware (there product line seems to be networking and
    DocDEH, Mar 17, 2006
  12. James

    DocDEH Guest

    How did you uninstall? I couldn't find a Linksys entry in Add/Remove
    software, and when I renamed the dll that's when I messed up the entire

    DocDEH, Mar 17, 2006
  13. James

    James Guest

    Sorry for the delay in responding but I've been away.

    The program/file folder isn't named "Linksys", it is listed in
    Add/Remove programs as "Compact Wireless-G USB Adapter". No I don't
    know why.

    As for Linksys, they don't have a clue. I sent them this information:

    I did a search (using WinHEX) on the install disk for the wireless
    adapter WUSB54GC and found two references to GTgina.dll. One is in the
    file setup.inx. and the other is in the file data1.hdr. I can't tell
    if the file itself is embedded in some other file and extracted during
    the install. Comments or ideas?

    They responded:

    Thank you once again for contacting Linksys Technical Support.

    I apologize but we really have no information regarding the GTGINA.DLL
    file. Try to install the WUSB54GC adapter in a different computer to
    observe if it will have the same effect on a different computer. In
    addition, you can also try to install the driver only to check if the
    WLAN monitor conflicts with the Windows XP system.

    If you have any further questions, feel free to visit our knowledge
    base at or send us an e-mail at
    so that we can assist you.

    Thank you and have a nice day!

    Now, my daughter bought a Linksys PCMCIA wireless adapter, installed
    it and had none of these problems. Her problem was a defective card
    that wouldn't allow the computer to boot if it was installed. The
    problem turned out to be that the card would not connect to the
    voltage pins in the socket (i.e., the green ready light would flash on
    and off and not hold steady). I too bought Linksys because of their

    My only suggestion is to return the adapter and if you want a Linksys,
    buy the PCMCIA card.

    Hope this helps.

    James, Mar 22, 2006
  14. James

    kishjr Guest

    have the same problem with login after install of linksys usb adapter
    (WUSB54GC). can login under wifes account as administrator and kids
    as user but cannot access mine at all as administrator. does not
    make sense to me. aggravating if nothing else, just want a normal
    login again, with the wireless hookup. if anyone has an answer would
    appreciate some help. do not know much about programs just enough to
    get into trouble. thanks for any info you can provide. linksys is
    not providing any support or help at all on there end. would have
    gone differt route with different company next time.
    kishjr, Mar 28, 2006
  15. James

    DocDEH Guest

    I'll check that, thanks. I have discovered that the gina.dll is a
    crucial file for the operating system and that somehow Linksys is
    substituting their own for the generic one that comes normally with
    windows. I see (on a system another system) both shgina.dll and
    msgina.dll in the System32 folder. Those are the normal ones.

    Someone from this board sent me a file he said came from the Linksys
    site. It describes the problem and says to uninstall the utility (as
    you did), leave the device plugged in, restart the computer. It will
    detect new hardware. Point the search for a driver to the Linksys
    Driver folder on C:\ and allow it to install the driver without
    installing the utility. You can then use the regular Windows wi-fi

    I'll try it. It's supposed to re-enable the logon options in Windows.

    DocDEH, Mar 29, 2006
  16. James

    mbush Guest

    Hi there,

    I've been experiencing the same problems as everyone else here. I
    think I found a solution today via Check out this link:

    Basically, you don't delete the file, but you do delete the registry

    This person tried it, and I just tried it as well. Things seem fine.
    mbush, Mar 31, 2006
  17. James

    Bababooey Guest

    Try this.

    The registry key for gtgina.dll is located at the following place

    (Just go to start, run - then type regedit. Be sure to backup your
    registry before you try this)


    You will see the registry key for GTGina.dll at that location

    Delete the registry value for GTGina.dll


    This should have things running smoothly again for you
    Bababooey, Apr 1, 2006
  18. James

    Linda Noll Guest

    I don't have that file in my registry
    Linda Noll, Apr 1, 2006
  19. James

    JLA Guest

    Linda Nollwrote:
    I don't have that file in my registry
    What operating system are you running?
    JLA, Apr 2, 2006
  20. James

    bob_chauvin Guest

    The described regedit fix worked for me too, no boot required. I did
    export the registry setting to a file for backup, though. Thanks.

    JLA a écrit :
    bob_chauvin, Apr 2, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.