LinkSys Router Reliability ?

Discussion in 'Computer Support' started by Robert11, Feb 29, 2004.

  1. Robert11

    Robert11 Guest

    Hello:

    Had no trouble with my LinkSys router for about 6 months.
    Now, having trouble getting it to work.

    Beginning to suspect that it might be something wrong with the router
    itself, rather than
    my (so far futile attempts) to re-configure it, and getting it going again.

    Very general question: how has the reliability of Linksys routers, in
    general, proven over the last few years ?

    Is it that they hardly every go bad, or is there a fairly meaningful
    percentage that have, or develop, "problems ?"

    Thanks,
    Bob
     
    Robert11, Feb 29, 2004
    #1
    1. Advertisements

  2. Robert11

    docmill Guest

    Everyone I know that uses them are happy and have good luck.
    Depending on your model, sometimes they need to be reset after trying to
    reconfigure them. Hold in the little red button on the back.
     
    docmill, Feb 29, 2004
    #2
    1. Advertisements

  3. Robert11

    Guest Guest

    I have had my LinkSys router for a couple of years now. No problems other
    than it seems to loose DHCP about once every 6 months or so - I just simply
    remove the power for about 30 seconds and the boot it back up again...
     
    Guest, Feb 29, 2004
    #3
  4. Robert11

    Dan Shea Guest

    They hardly ever go bad. Certainy not within 6 months.

    That being said, if yours used to work correctly and it no longer
    does, perhaps it's gotten busted. If you provide some details about
    the "problems" it's developed, you might get better answers.

    Cheers,
    dan
     
    Dan Shea, Feb 29, 2004
    #4
  5. Robert11

    Miggsee Guest

    What kind of modem? Adelphia told me Surfboard modems can fry them.
     
    Miggsee, Feb 29, 2004
    #5
  6. Robert11

    Meat-->Plow Guest

    I had one go bad a few days after purchase. Others I have had for years and
    never had any problems.
     
    Meat-->Plow, Feb 29, 2004
    #6
  7. Robert11

    Badaz Guest

    Linksys BSR41 here no problems in the couple years ive had it
    however ive heard Firmware upgrades above 1.42.7 can casue issues....
     
    Badaz, Feb 29, 2004
    #7
  8. Robert11

    Rick Merrill Guest

    I had a lightening strike that partially fried my LinkSys - BUT I
    was able to repair it! First, the fuse Inside the power supply
    module blew and I had to solder in a replacement (new physical size,
    but same amperage). Then I found that one half of the modem ethernet
    cable had gone - that is tough to isolate because the LED on the PC
    comes on - and Comcast replaced the modem. - RM
     
    Rick Merrill, Feb 29, 2004
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.