Limited User Account Access to Internet on Wireless Network

Discussion in 'Wireless Networking' started by Guest, Jan 12, 2005.

  1. Guest

    Guest Guest

    I'm having a problem when a limited user account logs in and tries to access
    the internet on a desktop I set up on a wireless network. It shows the
    wireless network as disabled. I have XP Pro OS. I did find out that in
    order for a limited user account to access the internet I have to log in as
    the administrator and switch over to the limited account user then I see the
    wireless network enabled which lets me access the web. Is that the way it's
    suppose to work or do I have to set up the limited user account in such a
    manner to let it have internet access which will then enable the wireless
    network.
     
    Guest, Jan 12, 2005
    #1
    1. Advertisements

  2. Guest

    Guest Guest

    I am having the same problem . XP Pro SP2 with a Belkin F5D7001 wireless
    card.
    Is this a problem with SP2? The Belkin help desk guy had never heard of the
    problem.
     
    Guest, Jan 13, 2005
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    I connacted Belkin again after trying the
    http://support.microsoft.com/default.aspx?scid=kb;en-us;313242&Product=winxp,
    which did not work for me.

    The Belkin rep suggested installing a registry key:

    HKeyLocalMachine\software\microsoft\windows\currentversion\runservices with
    bcmwltry = "bcmwltry.exe", but it has not helped me either.

    I wrote an email, so we shall see what comes back.

    As common as this problem is with as many vendor's products affected, it
    seems more like a Microsoft fault than a NCI fault.

    Happy hunting,

    Dave M
     
    Guest, Jan 13, 2005
    #3
  4. Once a wireless connection is configured by an Adminsitrator, it should
    connect automatically to the network for all users on the machine. There may
    be something in your configuration that is preventing this. Please tell me a
    little more about your specific setup.

    Are you using Windows software to configure your wireless settings or are
    you using a third-party application?
    What kind of authentication are you using to connect to the network?

    One thing you can check right now ...

    - Open the properties page for the wireless connection.
    - Select the 'Wireless Networks' tab.
    - Is the network you want to connect to in the 'Preferred networks' list?
    - If so, select your network in this list and then click on 'Properties'
    (you can find the authentication type, etc. on this page)
    - Select the 'Connection' tab.
    - Make sure the 'Connect when this network is in range' checkbox is checked.

    Let me know if this is of any help and if not, get back to me with your
    specific configuration.

    Thanks!
    --
    Alan Muller
    Software Design Engineer in Test

    Please do not send email directly to this alias. This alias is for newsgroup
    purposes only.

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Alan Muller [MSFT], Jan 13, 2005
    #4
  5. Guest

    Guest Guest

    Alan,

    I am not using Windows XP Pro to configure the wireless network. Belkin has
    its own install CD that I used to configure the adapter on the wireless
    desktop. I did speak to some of the Belkin Tech Support people and they told
    me the all users have to have admin authority to access the network. Does
    that make sense?
     
    Guest, Jan 13, 2005
    #5
  6. Guest

    Guest Guest

    I see a problem on the Wireless Network connection properties. The
    Connection under the preferred network properties is set to "Connect when
    this network is in range," however the authentication tab has an error:
    IEEE 802.1x autnentication cannot operate on peer-to-peer (ad hoc) networks
    or on networks for which data encryption is disabled.

    I use Shared and WEP with a network key that I selected (pass phrase). I
    have not set it up as an ad hoc network, nor am I using access points. (I am
    communicating now using the Admin account.)

    When I log out of the admin account and log into a limited account, the
    radio is on as the account opens then it shuts down. I cannot reenable it
    until I sign in an administrator.

    Regards,

    Dave M
     
    Guest, Jan 14, 2005
    #6
  7. well for one thing, if you are not using an access point, you are in Ad Hoc
    mode.
     
    Robert Jacobs, Jan 14, 2005
    #7
  8. Guest

    rick23 Guest

    Dave M,

    I believe your problem lies either with the Belkin wireless utility or
    the Belkin drivers.

    I had the exact same problem with a Dell Inspiron 5100 laptop, Win XP
    Pro, when I installed a Belkin F5D7011 802.11G PCMCIA card.

    As the administrator account, I could connect and the card worked fine,
    but on all of the 3 limited user accounts, the radio would not enable,
    hence the account could not connect.

    To make a long story short, I discovered the Belkin card has the same
    Broadcom chipset as a Dell Truemobile 1300 Mini-pc card. I also knew
    for a fact that the Dell wireless utility does NOT have the limited
    account problem.

    So here is what I did to fix the problem. I downloaded from Dell
    support the driver (and Wireless Utility) for a Truemobile 1300 Mini-PC
    card. I uninstalled the Belkin wireless utility and the card.

    Then I installed the Truemobile driver (and wireless utility included),
    then installed the Belkin card. The new hardware wizard found the
    driver for what it calls a Truemobile PCMCIA card.

    I started the wireless utility from the start menu and all limited
    accounts worked fine.

    Don't know if this will help you or not.
    I never called Belkin tech support.

    Good luck

    Doc in Hawaii






















     
    rick23, Jan 17, 2005
    #8
  9. Guest

    Guest Guest

    Thank you, Rick. I like your approach, unfortunately I am not running a Dell
    machine nor a PCMCIA card, though I will research alternative driver sources.


    Regards,

    Dave M

     
    Guest, Jan 18, 2005
    #9
  10. Guest

    tranquille Guest

    Hi
    I have a wifi pci card, a belkin F5D7001 like you, I followed this :

    Card: Belkin F5D7001 Highspeed Wireless 128Mbps Desktop Network Card
    Chipset: BCM4306
    pciid: 14e4:4320
    Driver: http://ftp.us.dell.com/network/R81433.EXE (use bcmwl5a.inf in
    directory AR)
    Other: The card is working however I am not sure about the advertised
    speeds. I will update later. Used ndiswrapper on a Fedora Core 2
    distro. Dell driver worked better than the Belkin CD.

    Using a dell driver, it works far better than the original one, even
    not logged as an admin.
    (the R81433 is around 10 mb)

    good luck
     
    tranquille, Feb 4, 2005
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.