LIMITED or NO CONNECTIVITY in SP2

Discussion in 'Wireless Networking' started by Guest, Sep 5, 2004.

  1. Guest

    Guest Guest

    My laptop uses an Intel M processor, so it has wi-fi built-in. however, when
    SP2 was installed, and can connect with an excellent signal, but then it says
    "Limited or No Connectivity", and i can't seem to connect to the internet.
    i've been doing all sorts of tweaking just to have it work again. pls someone
    help me. my laptop is my life!!!
     
    Guest, Sep 5, 2004
    #1
    1. Advertisements

  2. Guest

    hercster Guest


    -
    hercste
     
    hercster, Sep 5, 2004
    #2
    1. Advertisements

  3. Guest

    hercster Guest

    I have a similar problem with a Centrino equipped Dell D800 with buil
    in wireless that has worked flawlessly. Now after SP2, My machine doe
    not recognise the wireless network despite being 4 feet away from th
    Router. I removed SP2 but it did not restore my prior wireles
    capability. This is UGLY as wireless is important to my operation.

    Gor


    -
    hercste
     
    hercster, Sep 5, 2004
    #3
  4. Greetings Paolo,

    That message is new in Service Pack 2. It means that local area connection
    is configured to obtain a ip address automatically, but it cannot
    communicate with a DHCP Server to get an automatic ip address. It should get
    an automatic private ip address in the 169.254.x.x range. If your computer
    is configured for a wireless network, disable the wireless encryption on the
    network while troubleshooting. If you have a successful connection with
    encryption disabled, then check your encryption settings.

    You can turn off that messsage. To do so, follow these steps:

    1. Right-click My Network Places and click Properties.
    2. Right-click the Wireless Network Connection, and then click Properties.
    2. Uncheck "Notify me when this connection has limited or no connectivity"
    3. Click Ok.

    _____________
    Eric Cross
    Microsoft MVP (Windows Networking)
    http://mvp.support.microsoft.com
     
    Eric Cross [MVP], Sep 6, 2004
    #4
  5. Guest

    Guest Guest

    Eric,
    By the way, I have tried this with two different Wireless cards and two
    different wireless routers (disabling WEP). This approach does not appear to
    work. Unfurtunately, I have wasted countless hours (as have other I see
    posted in this group) trying to find a solution.

    Since I have been doing wireless for two years, that was one of the first
    things I checked. IMHO, it is definintely something in the MS stack for the
    wireless since I have ruled out hardware, and encryption for previously
    working solutions.
     
    Guest, Sep 6, 2004
    #5
  6. Guest

    Guest Guest

    I have the same issue with some laptops and not others. Two different
    networks. The machines that will not connect now had some troubles getting
    connected before sp2. The fix then was to disable and reinable, with sp2
    that won't work. What will work is to UNINSTALL the device, reinstall the
    device in device manager. Then it will reconnect ON THAT LOGIN ONLY. upon
    rebooting the issue still prevails. Good signal, is communicating with the
    access points (two locations), but will not obtain a DHCP lease. This
    happens without WEP enabled. This is an issue! Any ideas? Some computers
    link fine , some don't. Help!
     
    Guest, Sep 7, 2004
    #6
  7. Guest

    Guest Guest

    This is possibly the WORST advice I have ever seen!!

    I have the same problem on my Dell Inspiron 500m and have trawled the
    internet to find a solution. The connection works FINE when I have cable
    plugged into the modem, but I get the 'limited or no connectivity' message
    when in wireless...and despite the advice I actually have NO connectivity.
    Turning off the message isn't going to fix it!! That's like sticking my head
    in the sand to ignore the problem!!

    NO-ONE has offered a solution that works, except this:

    Wait 24 hours. And then for some reason, it starts working again.

    This is the second time it has happened to me and it is VERY VERY
    frustrating. Somebody please sort it out and give me some advice!!
     
    Guest, Nov 7, 2004
    #7
  8. Guest

    Tanya Guest

    Tanya, Nov 7, 2004
    #8
  9. Guest

    Guest Guest

    Guys,

    I was having this problem too, have seen a million different "fixes" on the
    web, none of them worked. Finally stumbled upon one a couple of nights ago
    that does the trick!! The problem lies in SP2's inability to communicate with
    a DHCP server, they obviously know about it and have posted a fix that
    doesn't work. HOPEFULLY THEY READ THIS AND POST A PROPER FIX!!

    Untill then, what you need to do is manually assign your laptop an IP
    address. Go to your Network adapter's properties, select TCP/IP and click
    properties. Instead of 'obtain an IP address automatically', enter one
    yourself, something like 192.168.1.x with a subnet mask of 255.255.255.0. The
    default gateway and DNS server should point to your router's IP address. If
    you aren't using a router, not exactly sure whether this will work or not...
    This is the only thing that's worked for me, hopefully this sorts you guys
    out too!
     
    Guest, Nov 8, 2004
    #9
  10. Guest

    graphit Guest

    I found out the following. For me problem also occurs with anothe
    portable equiped with a 3Com PcCard and with Win XP an NO SP2 !!!! So
    it's most likely not a SP2 related matter. Also, my other portable
    already had SP2 installed for 2 weeks before the problems started.

    Now I tested changing the SSID on my wireless router and guess what..
    both machines are able to connect and reconnect, receiving a proper I
    address from the DHCP server. And this several consequtive times.

    It keeps getting better, I changed back the SSID to the old value and.
    my laptops can reconnect to the network again.

    There seems to be some light at the end of the tunnel but I still don'
    see a reason what causes this strange behaviour.

    I'll keep posting my findings here


    -
    graphi
     
    graphit, Nov 15, 2004
    #10
  11. i get a similar problem.

    Does sp2 connect sometimes using a decent IP, but then sometimes it trys
    using a completely different IP not in your routers DHCP?!?!
     
    Stuart Turrell, Nov 19, 2004
    #11
  12. Guest

    Guest Guest

    Guess what....I am also having similar issues.

    I am using a Buffalo G54 card which is in my Compaq Evo620c. Prior to
    upgrading to SP2 it worked a treat and managed to pick up DHCP addresses from
    the various routers I connect to.

    I completely trashed the HD to install WinXP with SP2 (slipstreamed by MS on
    a technet CD) . I was amazed how the signal strength increased but if I need
    to use a network now, I must set it to a static address as it will not see a
    DHCP server.

    All the searches I have found suggest that I should continue to use a static
    address but I thought that DHCP would be properly supported in SP2! I am
    using this as a work around but clearly there is an issue.

    BTW I have tried applying the Hotfix KB884020 and the regfix that a lot of
    people recommend.....no difference.

    If anyone has any more ideas can you send me an email to

    Thanks

    Aidan
     
    Guest, Apr 9, 2005
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.