"Limited or no connectivity" error

Discussion in 'Wireless Networking' started by Guest, Feb 20, 2005.

  1. Guest

    Guest Guest

    I have tried to connect to my wireless network using Windows XP and a D-Link
    DWL-520+ network card. Every time I try to connect I get an error stating
    "Limited or no connectivity" "This problem occurred because the network did
    not assign a network address to the computer†So it looks like the computer
    took one which I know was not assigned by my router. It can't connect to the
    internet or any other network resources through the wireless connection. The
    computer is set up to obtain an IP address automatically and the router is
    set up to act as a DHCP server on the network. Also this computer can
    connect fine using a wired network. Another computer using the same network
    card and Windows 2000 works fine. The router is a D-link 614+. Does anyone
    know what to do to fix this? I am not really sure whether this is a problem
    on the computer or the router. I also reset the router to the factory
    default and tried to configure the network again but this computer still will
    not connect.
     
    Guest, Feb 20, 2005
    #1
    1. Advertisements

  2. Guest

    DLink Guru Guest

    If you take the network card out and place it in another system and
    everything works fine, then guess what?????? Its your system setup wrong
    somewhere.

    Ok lets see.
    1) Have you verified that in device manager says the device is working
    properly?
    2) Have you downloaded the latest greatest drivers from D-Link. Here is the
    Link:
    http://support.dlink.com/products/view.asp?productid=DWL-520+
    3) What version of XP are you running? Pro or Home? SP1 or SP2?
    4) Are you running a firewall? SP2 or a third party? If yes, have you
    disabled it? Some third party filewalls, especiall Norton, need to be
    uninstalled then reinstalled after you make the network connection. Why?
    Have no idea, but have had fits with them many times.
    5) Just to clarify, when you said you connected using a win2k machine using
    the same card, you are saing the same exact card, not just another card same
    model right?

    Ill get back to you when you get back to me.

    Robert....
     
    DLink Guru, Feb 20, 2005
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    1. Yes the device manager indicates the network card is working properly.
    2. Yes I am using the latest drivers installed from the package provided by
    dlink, I also tried the automatic driver installation provided through
    Windows Update.
    3. I am running XP Pro with SP2.
    4. The only firewall on it right now is the default setup that comes with SP2.
    5. The other computer has another card of the same model, it was not the
    same physical card.
    Actually this computer used to run Windows ME and the network card worked
    fine. It just doesn't work with WinXP. So it's almost certainly not a
    problem with the card itself, but rather a problem with software somewhere.
    This is why I suspect the operating system. I also tried disabling the
    option to use Windows to manage the card and instead I used the D-link card
    manager, however, Windows XP continues to do other setup that other versions
    of Windows do not appear to and I think that is part of the problem. The
    computer appears to connect to the card just fine from the D-link software
    (shows exactly what the other card on the Win2K computer shows) it just has
    the extra connection steps with XP that appear to break the setup. I also
    recently upgraded the firmware on the D-link router, however I don't think
    this is the problem because other computers work. I don't understand why the
    wireless card is unable to get an IP address while the ethernet card is able
    to. It appears everything is working properly other than the actual
    obtaining of an IP address.
    Michael
     
    Guest, Feb 20, 2005
    #3
  4. Guest

    DLink Guru Guest

    At question 2, you need to make sure your driver version is the most updated
    from the D-Link site. Windows Update will not always give you the most
    updated drivers on all products. The driver that comes with the product does
    not have to be the most updated either, even if you bought it yesterday.

    At Question 4, Have you disabled the Firewall and tried?

    At Question 5, that puts other options out there that were not clarified
    before.

    Have you enabled WEB or WAP on your router? If yes then disable them and see
    if it works without encryption enabled.

    Have you Enabled any MAC filtering or set a range of IPs to be used? If you
    have MAC filtering on then the DHCP server would be ignoring the new NIC. If
    you have set a range of IPs to use like 192.168.0.2 to 196.168.0.5 and are
    trying to connect a fifth machine the router will also ignore that.

    Ill think about this a bit more, let me know if any of that helped...

    Robert...
     
    DLink Guru, Feb 20, 2005
    #4
  5. Guest

    Guest Guest

    Yes, I installed the most recent driver from the D-Link site (version 3.07)
    I tried it with and without the firewall it doesn't affect it.
    The router does have WEP enabled , disabling it doesn't make a difference.
    It appears to me that the card is connecting just fine, the computer just
    will not connect into the network and take an IP address. There is no MAC
    address filtering and the router is set to assign IP addresses 192.168.0.100
    through 192.168.0.199 so there should be no lack of IP addresses. The
    network has only 3 computers. As I look at the log on my router it shows
    that the wireless card is connecting. I also tried setting a static IP
    within Windows, but I get an error about not being able to clear the ARP
    Cache. I don't know what ARP Cache is so if someone could tell me that would
    be great. I also had that error once with the DHCP setup, however it did not
    repeat itself. It ususally just gives the error about not being able to
    renew the IP address.
     
    Guest, Feb 20, 2005
    #5
  6. Guest

    Guest Guest

    Ok, So it actually will connect when I set a static IP address in Windows, I
    don't really know why it didn't at first, but it connected while I left the
    computer for a few minutes.
    Thanks for all the suggestions,
    Michael
     
    Guest, Feb 20, 2005
    #6
  7. Guest

    Fortiche Guest

    Have you tried shutting down the computer.
    disconnect the router
    reset the modem
    when all diodes are lit
    connect the router
    wnen all dioes are lit
    start the computer.
     
    Fortiche, Feb 20, 2005
    #7
  8. Guest

    DJ Guest

    I've had similar issues but in reverse. In other words, I have a
    Windows XP Pro machine running SP2 and my wireless card works fine
    there. When I put the wireless card in my work laptop which is Windows
    2000 it connects to the network but does not pick up a valid IP. I'm
    at work typing this message so I don't know the exact models of DLink
    hardware I have other than it is 802.11g @ 54Mbps. Like Michael, I
    have downloaded the latest drivers from DLink's web site and even
    uninstalled and reinstalled to be sure. I do have WEP instituted and I
    have trying without it as well. I've even supplied my WEP key. I've
    also tried to assign an IP address when it recognizes the MAC address.

    The one question I have is, would DNS Suffixes cause any issues? I've
    tried removing them and it doesn't seem to help.

    Thanks!
    DJ
     
    DJ, Feb 28, 2005
    #8
  9. Guest

    mikew

    Joined:
    Jul 4, 2006
    Messages:
    1
    Likes Received:
    0
    fixed by using the dlink configure utility

    I had this same problem, and after much struggling, I discovered that when I used the dlink configuration tool - it worked....

    that is, when I went to
    the windows "Wireless Network Connection Properties"
    on the middle tab "Wireless Networks" there is a check box
    for "Use Windows to configure my wireless network settings".
    Un-checking this makes it work, checking this breaks my network
    but the status shown is still "connected" (ping yahoo.com does
    and does not work based on this check box).

    This was after I gave up on DHCP settings and assigned a static
    ip address from the router to my wireless MAC and after setting
    this connection (on the PC) to be a matching static ip address.
     
    mikew, Jul 4, 2006
    #9
  10. Guest

    camilinksys

    Joined:
    Jul 1, 2006
    Messages:
    6
    Likes Received:
    0
    It is very common that you get the error message "limited connectivity" or "you are connected to the access point but the internet cannot be found" when your router has the security enabled, but you have either mistyped it, not typed it at all or even typed it but not confirmed it.

    I. First of all, check out the available signals in range
    ( For Windows XP SP2 Wireless Zero Configuration
    --> Control Panel
    --> Network Connections
    --> right-click on Wireless Network Connection
    --> View Available Signals)

    Once you've found your network on the list, if it were secured you'd see a little key chain to the left of the network's name (aka SSID).

    a. If you see no key chain, double click on the name and this should connect you. If it doesn't connect you, go forward to step 2.

    b. If there is one, double click on the network and your network monitor should ask for a password or key. you have to enter it and confirm it (meaning, you should type it in twice). This should get you connected. If you see the chain or know that you have a key, but the monitor won't ask for it, click on the option Changer the Order of Preferred Networks, find your network; select it and click on properties. You will find yourself on the Association tab: make sure the option "The key is provided for me automatically" is not ticked. Type in your Network key in the blanks above it. Next, go to the Authentication tab and make sure that none of the options is ticked, either.


    II. If the Zero Config says you are connected, and you still get this error message, go to the menu Start --> Run --> type CMD --> then, on the black screen, type ipconfig and hit enter
    Check that your IP address is other than 169.254.x.x . If this is the case, skip this step.
    If you have a 169.254.x.x range address, go back to the Network Connections window and right-click on Wireless Network Connection. This time you will go to Properties. Select Internet Protocol TCP/IP, hit properties again and tick the "use the following IP address" and write down an address in the range of your router or AP. If you don't know what the range is, you should check this with its Tech Support. At the same time, it will be necessary for you to configure statis DNS servers, which you should check with your Internet Service Provider.
    After this, you should be able to surf the net.


    II. If you've checked all of this and there seems to be no problem, the only thing left to do is access your router's or AP's configuration interface and make sure you haven't enabled any MAC address filtering.
     
    camilinksys, Jul 4, 2006
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.