Just Need Most Basic Router Config For Internet Connectivity - Please Help!!

Discussion in 'Cisco' started by rafael_romano299, Oct 13, 2005.

  1. I'm sure the answer to this question must be simple but try as I might,
    I can't get it to work! My situation is as follows:

    I have an NTL Broadband Cable Modem which is ordinarily connected to a
    Belkin Wireless G Router (although I don't use the wireless capability
    - just cables). Everything works fine. I want to swap this Belkin
    Wireless G Router for a Cisco 831 router running IOS 12.2 for reasons
    relating to my job.

    With the full (and I think somewhat complicted!) config that was
    already on the router, I had no Internet connectivity at all. In order
    to troubleshoot, I stripped down the config to what I thought was the
    very most basic config required with the intention of putting it back
    line by line afterwards. Specifically, my basic config is as follows:

    'ip address dhcp' on the external interface.

    'ip address 10.3.6.1 255.255.255.0' on the internal interface.

    'ip dhcp pool DHCPPool
    network 10.3.6.0 255.255.255.0
    default-router 10.3.6.1
    dns-server 10.2.1.2'

    'ip route 0.0.0.0 0.0.0.0 ethernet1'

    The router picks up an '81.102.x.x' IP address on the external
    interface just as it should however, still no connectivity whatsoever
    to the outside world.

    Please help! I must be missing something but I don't know what it is!
    Many thanks in advance!
     
    rafael_romano299, Oct 13, 2005
    #1
    1. Advertisements

  2. you will need to add NAT to you config.

    access-list 1 permit 10.3.6.0 0.0.0.255
    ip nat inside source list 1 int eth1 overload
    interface ethernet 0
    ip nat inside
    interface ethernet 1
    ip nat outside
    no ip route 0.0.0.0 0.0.0.0 ethernet1
    ip route 0.0.0.0 0.0.0.0 dhCP

    this should work.
    make shure that your dns is reachable.
    dont´t forget to implement some security features.

    regards
    andre
     
    Andre Janssen, Oct 13, 2005
    #2
    1. Advertisements

  3. Thank you so much for your response Andre - you certainly pointed me in
    the right direction!

    I had to further 'tweak' the default route to get it working though -
    it is now 'default route 10.3.6.1 255.255.255.255 ethernet1 permanent'.

    I now have my full config back in place including all security.

    Thank you again!
     
    rafael_romano299, Oct 14, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.