JavaScript does not work in Firefox

Discussion in 'Firefox' started by minnesotti, Jul 18, 2006.

  1. minnesotti

    minnesotti Guest

    I used to write little programs in JavaScript many years ago, so I know
    the difference. I checked the web browser via the website which I
    mentioned above, and it says that I have Firefox. It seems al'right at
    this end.

    Hmm... after a week of twisting, I just twisted something in ZA Pro,
    and the picture-hosting website loaded into my Firefox browser. The
    JavaScript Console does not complain anymore that there are errors.
    However... still, there are some problems. If I go to the pictures made
    by the photographers, the pictures cannot download into the browser.
    Perhaps, I should give it up.
     
    minnesotti, Jul 18, 2006
    #21
    1. Advertisements

  2. minnesotti

    gwtc Guest

    java and javascript have nothing in common with each other except for
    the word java.

    --
    So, You Think You Know Everything?

    Did you know that the up and coming Mercedes-Benz Bionic Car will be
    based on the sleekness and stylish of a fish in water -- the
    streamline contours of a box fish that is?
     
    gwtc, Jul 18, 2006
    #22
    1. Advertisements

  3. minnesotti

    gwtc Guest

    java and javascript have nothing in common with each other except for
    the word java.

    --
    So, You Think You Know Everything?

    Did you know that the up and coming Mercedes-Benz Bionic Car will be
    based on the sleekness and stylish of a fish in water -- the
    streamline contours of a box fish that is?
     
    gwtc, Jul 18, 2006
    #23
  4. minnesotti

    gwtc Guest

    a couple of things to check. Tools, Options, Content, and make sure
    that "Load images" is checked and "for the originating website only"
    is unchecked. Then in the address bar, type in about:config and look
    for this entry:

    dom.disable_image_src_set

    once found, double click on it and change it to false. Do any of
    these help now?

    --
    So, You Think You Know Everything?

    Did you know that the up and coming Mercedes-Benz Bionic Car will be
    based on the sleekness and stylish of a fish in water -- the
    streamline contours of a box fish that is?
     
    gwtc, Jul 18, 2006
    #24
  5. minnesotti

    gwtc Guest

    a couple of things to check. Tools, Options, Content, and make sure
    that "Load images" is checked and "for the originating website only"
    is unchecked. Then in the address bar, type in about:config and look
    for this entry:

    dom.disable_image_src_set

    once found, double click on it and change it to false. Do any of
    these help now?

    --
    So, You Think You Know Everything?

    Did you know that the up and coming Mercedes-Benz Bionic Car will be
    based on the sleekness and stylish of a fish in water -- the
    streamline contours of a box fish that is?
     
    gwtc, Jul 18, 2006
    #25
  6. While the city slept, minnesotti () feverishly typed...

    [...]
    Having just perused this thread, that might be a good idea. You may be
    better finding a picture hosting site that doesn't rely on shoddy javascript
    coding to present the basic content to the client. I'm sure there are plenty
    out there. :)

    Cheers,
    Nige
     
    nice.guy.nige, Jul 19, 2006
    #26
  7. minnesotti

    sticks Guest

    Thank you very much!! I have had the same problem. I experienced the
    same thing on ebay. Always had to use IE there. This solved the
    problem. Much appreciated!!

    sticks
     
    sticks, Jul 19, 2006
    #27
  8. minnesotti

    gwtc Guest

    finally something I said that works ;-) :-D :cool:

    --
    So, You Think You Know Everything?

    Did you know that the up and coming Mercedes-Benz Bionic Car will be
    based on the sleekness and stylish of a fish in water -- the
    streamline contours of a box fish that is?
     
    gwtc, Jul 19, 2006
    #28
  9. minnesotti

    Z Guest

    Can you explain what that setting does?
     
    Z, Jul 19, 2006
    #29
  10. minnesotti

    gwtc Guest

    I'm not too sure, but it has something to do with image changes and
    javascript. Or, maybe thats javscripts changing images.

    This was one of those big problems with those who use google maps.
    The default is true -- as in don't change images. It took us a while
    to figure out whats going on, and I stubled on to changing it false.
    Then everyone was able to view google map images. And the only reason
    I came across it was because I was using Mozilla Suite
     
    gwtc, Jul 19, 2006
    #30
  11. As mentioned here
    http://www.thepavilions.ca/google_help.html
    http://www.equestrianestate.ca/google_help.html
    http://www.chrisbeach.co.uk/core/scripts/entryViewer.php?ID=11700
    http://maps.google.ca/support/bin/answer.py?answer=18529&topic=1498

    You would only come across the situation if the preference was set to
    true of course, and by default the setting has been set to false since
    24 Jun 2003 (Mozilla version 1.4)

    The setting in SeaMonkey is controlled by
    [SeaMonkey-->Preferences]*-->Advanced-->Scripts & Plugins
    Allow scripts to
    X Change images

    so, obviously the purpose of the setting is to control whether or not a
    javascript can change an image - and as this problem shows, its better
    for some sites if you allow that.

    Interestingly enough, this is one of the 'controls' not deemed essential
    enough to have its own UI in Firefox - in Firefox, the only means to
    change it is via about:config, there is no UI setting.
     
    Mozilla Champion (Dan), Jul 20, 2006
    #31
  12. minnesotti

    test9876

    Joined:
    Jul 9, 2007
    Messages:
    1
    Likes Received:
    0
    minnesotti wrote:
    > Hi there,
    >
    > I subscribed to a photographic pictures-hosting website which is heavy
    > on JavaScript. My preferred latest browser Mozilla Firefox does not
    > work with it -- no pictures are displayed and no buttons react to
    > clicking. The website's helpdesk says it should work with Firefox, and
    > could not offer any more advices. The JavaScript Console shows that
    > there are numerous errors occuring. It looks like the web browser does
    > not recognise JavaScript code. When viewing the website with Internet
    > Explorer, JavaScript code works al'right and the website works. I am
    > using ZoneAlarm Pro as a firewall... I heard it might clip the
    > JavaScript code. When I turned ZAPro off, the website still was not
    > viewable. I viewed the website through anonymizer which re-wrote
    > JavaScript code... and surprise-surprise... I could view the
    > picture-hosting website. I would hypothesize that the anonymizer
    > re-writes the JavaScript code to the old code understandable by Firefox
    > (however, the website helpdesk claims that their website works with
    > latest Firefox, and I could not find any other computer with Firefox to
    > check if the problem is only with my computer). Or, there might still
    > be something running on my computer which clips the JavaScript code
    > like ZAPro which probably still runs even after turning it off. Help me
    > please, with the suggestion of possible causes. Thanks.

    Minnesotti can I ask which anonymizer you used exactly because the ones I have tried seem to remove the javascript from the browser!
     
    test9876, Jul 9, 2007
    #32
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.