ISP madness - solved by Ciso VPN, what the??

Discussion in 'Cisco' started by chandy, May 3, 2007.

  1. chandy

    chandy Guest

    Hi,

    I am posting this here in the hope that the fundamental understanding
    of networking in this group would provide a resolution to my
    issue..and I can use a Cisco VPN to sorta fix it, which might point to
    the issue.

    The issue is this: I have a Sweex MO250 wireless ADSL router modem. I
    can get it to connect to my service provider but I can only browse
    sites on the google.com domain. Every other site on the web serves me
    about 20 lines of HTML and nothing else. Google is fast and works
    normally, as does google video, groups, etc, DNS works fine.

    Now, if I install a Cisco VPN client, I can connect through the MO250
    to a VPN server and access other sites successfully, but only if I use
    the VPN client. The VPN cannot be used long-term so I need to fix the
    core issue.

    Could this be an issue or misconfiguration with the MO250? If so, can
    you tell me what the issue could be? Or do the symptoms define it as
    a definite problem with the ISP?

    Thanks,

    Chandy
     
    chandy, May 3, 2007
    #1
    1. Advertisements

  2. Sounds very much like an MTU issue, and packet fragmentation. The VPN is
    probably working around it because it uses smaller packets, but when you are
    going to varied sites, you will follow their MTU.

    Most newer wireless router fix up the MTU along the way. This is an issue
    with PPPOE, DSL, blah blah blah. How much do you want to know? Google
    "PPPOE MTU"

    Sounds like the Sweex is junk, and failed to learn the lesson of dozens of
    routers before it. It may need new firmware, but the sweex website is
    BEYOND lame.

    Failing that, use DRTCP to set the MTU of your wireless to 1352 or 1400 or
    1492.

    http://www.dslreports.com/drtcp

    Or using the Cisco SET MTU tool.

    I did find an english manual from the OEM at
    http://www.sweex.com/documents/MO250/2/MO250_man_eng_oem.pdf Page 144 (PDF
    page 150) of the OEM manual.

    Looks like there is a setting you can check to "enforce PPPOE MTU" or you
    can lower the MTU on the router itself. Or on the card of your PC. Doesn't
    matter, really.

    Also try updating the wireless driver for your PC. Do all wireless devices
    have the same problem/
     
    Phillip Remaker, May 4, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.