ISDN Switching between BRI and PRI interfaces

Discussion in 'Cisco' started by chassignet, Jan 3, 2006.

  1. chassignet

    chassignet Guest

    Hello,

    I have a 2811 router which has one VWIC-1MFT-E1 connected to the PSTN,
    and one VIC2-2BRI-NT/TE connected DIRECTLY to one router and one modem
    (not Cisco ones). The 2811 is a H323 gateway that works properly for
    voice with CallManager and Cisco IP Phones (whose reach external
    numbers through the PRI interface).

    The router and the modem (whose handle data) need to access to the PSTN
    through the PRI interface (for remote maintenance purpose). I mean the
    2811 needs to proceed the switching between its BRI interfaces and its
    PRI interface properly!!!

    We've managed to make ISDN switching to work in our lab with one 3640
    router with two VIC2-2BRI-NT/TE (one connected to the PSTN and one
    directly connected to a router). So, I don't know why it's not working
    with a 2811 between a BRI and a PRI???

    Our network topology network is as follow :

    CCM---IP---2811-PRI--PSTN
    |
    BRI
    |
    Modem&Router

    Does someone know how to make this configuration working ?

    Thanking you in advance,
    Regards,

    Benjamin

    PS: I have the following configuration :

    Current configuration : 4591 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname H323GTW
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 4096 debugging
    enable secret 5 *****************************
    !
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-select 1 E1 0/0/0
    no aaa new-model
    ip subnet-zero
    !
    !
    ip cef
    !
    !
    no ip domain lookup
    no ftp-server write-enable
    isdn switch-type primary-net5
    !
    voice-card 0
    no dspfarm
    dsp services dspfarm
    no local-bypass
    !
    !
    voice call carrier capacity active
    !
    voice service pots
    !
    voice service voip
    modem passthrough nse codec g711alaw
    !
    !
    voice class codec 1
    codec preference 1 g711ulaw
    !
    !
    !
    voice class h323 1
    h225 timeout tcp establish 5
    !
    !
    !
    !
    !
    !
    voice translation-rule 10
    rule 1 /^1/ /001/
    rule 2 /^2/ /002/
    rule 3 /^3/ /003/
    rule 4 /^4/ /004/
    rule 5 /^5/ /005/
    rule 6 /^6/ /006/
    rule 7 /^0/ /00/
    rule 8 /^8/ /008/
    !
    voice translation-rule 20
    rule 1 /^00/ /0/
    rule 2 /^01/ /1/
    rule 3 /^03/ /3/
    !
    !
    voice translation-profile modif_entrant_appelant
    translate calling 10
    !
    voice translation-profile modif_sortant_appele
    translate called 20
    !
    !
    !
    !
    !
    !
    controller E1 0/0/0
    framing NO-CRC4
    pri-group timeslots 1-28
    !
    !
    !
    interface FastEthernet0/0
    description vers CCM
    ip address 192.168.10.6 255.255.255.0
    duplex auto
    speed auto
    h323-gateway voip interface
    h323-gateway voip bind srcaddr 192.168.10.6
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0:15
    no ip address
    no logging event link-status
    isdn switch-type primary-net5
    isdn incoming-voice voice
    isdn negotiate-bchan resend-setup
    isdn sending-complete
    no cdp enable
    !
    interface BRI0/1/0
    no ip address
    isdn switch-type basic-net3
    isdn overlap-receiving
    isdn protocol-emulate network
    isdn layer1-emulate network
    isdn incoming-voice voice
    isdn sending-complete
    isdn skipsend-idverify
    line-power
    !
    interface BRI0/1/1
    no ip address
    isdn switch-type basic-net3
    isdn overlap-receiving
    isdn protocol-emulate network
    isdn layer1-emulate network
    isdn incoming-voice voice
    isdn skipsend-idverify
    line-power
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.10.254
    !
    !
    ip http server
    ip http authentication local
    ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 0/0/0:15
    translation-profile incoming modif_entrant_appelant
    cptone FR
    !
    voice-port 0/1/0
    compand-type a-law
    cptone FR
    !
    voice-port 0/1/1
    compand-type a-law
    cptone FR
    !
    !
    !
    dial-peer cor custom
    !
    !
    !
    dial-peer voice 10 pots
    translation-profile outgoing modif_sortant_appele
    destination-pattern .T
    progress_ind setup enable 3
    progress_ind alert enable 8
    progress_ind progress enable 8
    progress_ind connect enable 8
    incoming called-number .
    no digit-strip
    direct-inward-dial
    port 0/0/0:15
    forward-digits all
    !
    dial-peer voice 11 pots
    destination-pattern 7158
    progress_ind setup enable 3
    progress_ind alert enable 8
    progress_ind progress enable 8
    progress_ind connect enable 8
    incoming called-number 7158
    direct-inward-dial
    port 0/1/0
    forward-digits all
    !
    dial-peer voice 12 pots
    destination-pattern 7157
    progress_ind setup enable 3
    progress_ind alert enable 8
    progress_ind progress enable 8
    progress_ind connect enable 8
    incoming called-number 7157
    no digit-strip
    direct-inward-dial
    port 0/1/1
    forward-digits all
    prefix 7157
    !
    dial-peer voice 100 voip
    description Vers Publisher
    preference 1
    destination-pattern 71..
    voice-class codec 1
    voice-class h323 1
    session target ipv4:192.168.10.2
    incoming called-number 71..
    dtmf-relay h245-signal h245-alphanumeric
    no vad
    !
    dial-peer voice 110 voip
    description Vers Subscriber
    preference 2
    destination-pattern 71..
    voice-class codec 1
    voice-class h323 1
    session target ipv4:192.168.10.3
    incoming called-number 71..
    dtmf-relay h245-signal h245-alphanumeric
    no vad
    !
    dial-peer voice 200 voip
    description Vers Publisher
    preference 1
    destination-pattern 30..
    voice-class codec 1
    voice-class h323 1
    session target ipv4:192.168.10.2
    dtmf-relay h245-signal h245-alphanumeric
    no vad
    !
    dial-peer voice 210 voip
    description Vers Subscriber
    preference 2
    destination-pattern 30..
    voice-class codec 1
    voice-class h323 1
    session target ipv4:192.168.10.3
    dtmf-relay h245-signal h245-alphanumeric
    no vad
    !
    gateway
    timer receive-rtp 1200
    !
    !
    !
    line con 0
    password 7 *****************************
    login
    line aux 0
    password 7 *****************************
    login
    line vty 0 4
    password 7 *****************************
    login
    !
    scheduler allocate 20000 1000
    !
    end
     
    chassignet, Jan 3, 2006
    #1
    1. Advertisements

  2. chassignet

    chassignet Guest

    PS: When I try to make a call from the router connected to the BRI of
    the 2811, Here is what I get :

    H323GTW#DEB ISDN Q931
    debug isdn q931 is ON.
    H323GTW#TERM MON
    H323GTW#
    *Dec 16 17:45:32.492: ISDN BR0/1/0 Q931: RX <- SETUP pd = 8 callref =
    0x0B
    Bearer Capability i = 0x8890
    Standard = CCITT
    Transer Capability = Unrestricted Digital
    Transfer Mode = Circuit
    Transfer Rate = 64 kbit/s
    Channel ID i = 0x83
    Called Party Number i = 0x80, '0323990725'
    Plan:Unknown, Type:Unknown
    *Dec 16 17:45:36.492: ISDN BR0/1/0 Q931: RX <- SETUP pd = 8 callref =
    0x0B
    Bearer Capability i = 0x8890
    Standard = CCITT
    Transer Capability = Unrestricted Digital
    Transfer Mode = Circuit
    Transfer Rate = 64 kbit/s
    Channel ID i = 0x83
    Called Party Number i = 0x80, '0323990725'
    Plan:Unknown, Type:Unknown
    *Dec 16 17:45:40.484: ISDN BR0/1/0 Q931: RX <- RELEASE_COMP pd = 8
    callref = 0x
    0B
    Cause i = 0x80E6 - Recovery on timer expiry
     
    chassignet, Jan 3, 2006
    #2
    1. Advertisements

  3. Erik Tamminga, Jan 3, 2006
    #3
  4. chassignet

    chassignet Guest

    Hello,

    Thanks for your reply!
    I've changed some little things on my access router...
    Now, here is what I get on my 2811 router :

    H323#deb isdn q931
    *Jan 5 07:08:01.735: ISDN BR0/1/0 Q931: RX <- SETUP pd = 8 callref =
    0x79
    Bearer Capability i = 0x8890
    Standard = CCITT
    Transer Capability = Unrestricted Digital
    Transfer Mode = Circuit
    Transfer Rate = 64 kbit/s
    Channel ID i = 0x83
    Called Party Number i = 0x80, '0032390725'
    Plan:Unknown, Type:Unknown
    *Jan 5 07:08:01.739: ISDN BR0/1/0 Q931: TX -> SETUP_ACK pd = 8
    callref = 0xF9
    Channel ID i = 0x89
    *Jan 5 07:08:16.747: ISDN Se0/0/0:15 Q931: Applying typeplan for
    sw-type 0x12 i
    s 0x0 0x0, Calling num 7158
    *Jan 5 07:08:16.747: ISDN Se0/0/0:15 Q931: Applying typeplan for
    sw-type 0x12 i
    s 0x0 0x0, Called num 0323990725
    *Jan 5 07:08:16.747: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref
    = 0x0165

    Sending Complete
    Bearer Capability i = 0x8890
    Standard = CCITT
    Transer Capability = Unrestricted Digital
    Transfer Mode = Circuit
    Transfer Rate = 64 kbit/s
    Channel ID i = 0xA1839B
    Preferred, Channel 27
    Progress Ind i = 0x8183 - Origination address is non-ISDN
    Calling Party Number i = 0x80, '7158'
    Plan:Unknown, Type:Unknown
    Called Party Number i = 0x80, '032390725'
    Plan:Unknown, Type:Unknown
    *Jan 5 07:08:16.747: ISDN BR0/1/0 Q931: TX -> CALL_PROC pd = 8
    callref = 0xF9
    *Jan 5 07:08:16.823: ISDN Se0/0/0:15 Q931: RX <- CALL_PROC pd = 8
    callref = 0x
    8165
    Channel ID i = 0xA9839B
    Exclusive, Channel 27
    *Jan 5 07:08:16.823: ISDN Se0/0/0:15 Q931: RX <- CONNECT pd = 8
    callref = 0x81
    65
    *Jan 5 07:08:16.827: ISDN Se0/0/0:15 Q931: TX -> CONNECT_ACK pd = 8
    callref =
    0x0165
    *Jan 5 07:08:16.839: ISDN BR0/1/0 Q931: TX -> CONNECT pd = 8 callref
    = 0xF9
    *Jan 5 07:08:16.863: ISDN BR0/1/0 Q931: RX <- CONNECT_ACK pd = 8
    callref = 0x7
    9
    *Jan 5 07:08:22.835: %ISDN-6-CONNECT: Interface BRI0/1/0:1 is now
    connected to
    unknown unknown
    sh isdn active
    *Jan 5 07:08:26.247: %ISDN-6-CONNECT: Interface BRI0/1/0:1 is now
    connected to
    unknown unknownSH ISDN ACTIVE
    --------------------------------------------------------------------------------
    ISDN ACTIVE CALLS
    --------------------------------------------------------------------------------
    Call Calling Called Remote Seconds Seconds Seconds
    Charges
    Type Number Number Name Used Left Idle
    Units/Currency
    --------------------------------------------------------------------------------
    Out 7158 0323990725 9 Unavail -
    0
    In ---N/A--- ---N/A--- 9 Unavail -
    --------------------------------------------------------------------------------
    *Jan 5 07:08:39.139: ISDN BR0/1/0 Q931: RX <- DISCONNECT pd = 8
    callref = 0x79

    Cause i = 0x8090 - Normal call clearing
    *Jan 5 07:08:39.139: %ISDN-6-DISCONNECT: Interface BRI0/1/0:1
    disconnected fro
    m N/A N/A, call lasted 22 seconds
    *Jan 5 07:08:39.139: %ISDN-6-DISCONNECT: Interface BRI0/1/0:1
    disconnected fro
    m unknown , call lasted 22 seconds
    *Jan 5 07:08:39.143: ISDN BR0/1/0 Q931: TX -> RELEASE pd = 8 callref
    = 0xF9
    Cause i = 0x8290 - Normal call clearing
    *Jan 5 07:08:39.155: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8
    callref = 0
    x0165
    Cause i = 0x8090 - Normal call clearing
    *Jan 5 07:08:39.179: ISDN BR0/1/0 Q931: RX <- RELEASE_COMP pd = 8
    callref = 0x
    79
    *Jan 5 07:08:39.291: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8
    callref = 0x81
    65
    *Jan 5 07:08:39.295: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8
    callref =
    0x0165

    It seems the configuration is almost OK but the communication between
    my access router (connected to the BRI interface of the 2811 router)
    and my remote router can't be established.

    Is it a problem of PRI configuration? Is it a question of configuring a
    dedicated chanel on the PRI ?
    Could you please give me your feedback about that ?

    Thanking you in advance
    Regards

    Benjamin
     
    chassignet, Jan 5, 2006
    #4
  5. chassignet

    John Agosta Guest

    It looks like a seperate call is being placed in each direction. The
    connection should come up with a single
    call. I've seen this before on more than one occasion - bug perhaps -
    it had to do with the CHAP configuration and IOS version.

    Specifically, if one-way authentication was configured, the routers placed
    two calls, and the challenge
    happened on one channel, but never got the response on that same channel.
    If two way authentication was configured, a single call was placed, and the
    challenge/response took place on
    the same channel.

    I'd suggest posting the configs for both routers, maybe even the output of
    "debug ppp authentication" as well.......

    Perhaps the easiest way to rule this out would be to eliminate
    ppp/authentication from the conigurations and try again......

    -ja
     
    John Agosta, Jan 5, 2006
    #5
  6. chassignet

    chassignet Guest

    Hi,

    "It looks like a seperate call is being placed in each direction."
    I know, but it is normal insofar as there is an incoming call on the
    2811 BRI interface (from the access router to the 2811) and an outgoing
    call on the 2811 PRI interface (from the 2811 to the remote router via
    PSTN).

    As you wished here is additional information :

    1. Here is the configuration of the access router :

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname *******
    !
    enable password 7 ************
    !
    username HIRS password 7 ************
    !
    !
    !
    !
    ip subnet-zero
    !
    no ip domain-lookup
    isdn switch-type basic-net3
    isdn voice-call-failure 0
    !
    !
    !
    interface Ethernet0
    ip address 192.168.30.20 255.255.255.0
    no ip directed-broadcast
    !
    interface BRI0
    ip address 192.168.0.2 255.255.255.0
    no ip directed-broadcast
    encapsulation ppp
    no ip split-horizon
    dialer map ip 192.168.0.1 name HIRS 0032390725
    dialer-group 1
    isdn switch-type basic-net3
    no cdp enable
    ppp authentication chap
    !
    no ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.30.254
    ip route 10.15.3.0 255.255.255.0 192.168.0.1
    !
    dialer-list 1 protocol ip permit
    snmp-server engineID local 00000009020000E01E3E597C
    snmp-server community public RO
    !
    line con 0
    exec-timeout 0 0
    login
    transport input none
    stopbits 1
    line vty 0 4
    password 7 0703014E1E
    login
    !
    end

    2. here is the debug ppp authentication :

    AXIANS#deb ppp neg
    PPP protocol negotiation debugging is on
    AXIANS#
    AXIANS#term mon
    AXIANS#ping 10.15.3.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.15.3.2, timeout is 2 seconds:
    ......
    Success rate is 0 percent (0/5)
    AXIANS#
    2w6d: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
    2w6d: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 0032390725
    2w6d: BR0:1 PPP: Treating connection as a callout
    2w6d: BR0:1 PPP: Phase is ESTABLISHING, Active Open
    2w6d: BR0:1 LCP: O CONFREQ [Closed] id 119 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 120 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 121 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 0032390725
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 122 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 123 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 124 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 125 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 126 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 127 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 128 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: O CONFREQ [REQsent] id 129 len 15
    2w6d: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    2w6d: BR0:1 LCP: MagicNumber 0x69D207E6 (0x050669D207E6)
    2w6d: BR0:1 LCP: TIMEout: State REQsent
    2w6d: BR0:1 LCP: State is Listen
    2w6d: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected from
    0032390725 , call
    lasted 22 seconds
    2w6d: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
    2w6d: BR0:1 LCP: State is Closed
    2w6d: BR0:1 PPP: Phase is DOWN
    AXIANS#UN ALL

    Regards

    Benjamin
     
    chassignet, Jan 5, 2006
    #6
  7. Hi,

    No there is just one call being setup. What the output displays is a call
    coming in on BRI0/1/0 and leaving via S0/0/0 this is normal behaviour in a
    setup where the router "switches" the call to another ISDN interface.

    Indeed have a look at authentication. See what debug ppp authentication and
    debug ppp negotiation have to say.

    Erik
     
    Erik Tamminga, Jan 7, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.