ISDN PRI to BRI can't ping

Discussion in 'Cisco' started by wxu3000, Jul 13, 2005.

  1. wxu3000

    wxu3000 Guest

    Hi,
    I've a got a Cisco 2610 with ISDN 10 PRI service, and a Cisco 1603
    with ISDN BRI service. I dial out from 2610 to 1603. It is very weired
    that when the 1603 is in another state, (which means I need to put area
    code when I dial), I can ping from WAN interface of 2610 to WAN
    interface of 1603. Howerver, if the 1603 is in the same state of 2610,
    I cannot ping from WAN interface of 2610 to 1603. In both cases, I can
    see the call is established when I do a "show isdn active". The only
    difference I could see is: When 1603 is in another state, I can see
    from 1603 that the call is connected to 0312345678, which is the ISDN
    10 number. However, when 1603 is in the same state of 2610. it says the
    call is connected to unknown. Is this the problem?

    Please help. Thank you very much.

    Config for 2600:

    Building configuration...

    Current configuration : 1787 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname ISDN_MEL_POP
    !
    enable secret 5 xx.
    !
    ip subnet-zero
    !
    !
    !
    isdn switch-type primary-net5
    isdn voice-call-failure 0
    !
    controller E1 1/0
    pri-group timeslots 1-10,16
    !
    !
    !
    interface Ethernet0/0
    ip address 10.1.7.211 255.255.255.248
    half-duplex
    !
    interface BRI0/0
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface BRI0/1
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface Serial1/0:15
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type primary-net5
    isdn bchan-number-order ascending
    !
    interface Dialer0
    description ***CMI Kengsington 03 96872355 or 03 96872955***
    ip address 10.1.16.101 255.255.255.252
    encapsulation ppp
    dialer pool 1
    dialer string 43218765
    dialer-group 1
    !
    interface Dialer1
    description ***CMI Campbellfield 03 93577622 or 03 93578722***
    ip address 10.1.16.109 255.255.255.252
    encapsulation ppp
    shutdown
    dialer pool 1
    dialer string 0234567812
    dialer-group 1
    !
    ip classless

    no ip http server
    no ip pim bidir-enable
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    line vty 0 4
    password 7 1234
    login
    !
    no scheduler allocate
    end

    Config for 1603:
    CMI-KENSINGTON#sh running-config
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname abc
    !
    enable secret 5 XX
    !
    ip subnet-zero
    isdn switch-type basic-net3
    !
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.209.7 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    no keepalive
    !
    interface BRI0
    ip address 10.1.16.102 255.255.255.252
    no ip directed-broadcast
    encapsulation ppp
    dialer-group 1
    isdn switch-type basic-net3
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.1.16.101
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    exec-timeout 0 0
    transport input none
    line vty 0 4
    password 7 123
    login
    !
    end
     
    wxu3000, Jul 13, 2005
    #1
    1. Advertisements

  2. wxu3000

    wxu3000 Guest

    Result from "debug ISDN q931".
    1. Unsuccessful call:
    1d08h: ISDN BR0: RX <- SETUP pd = 8 callref = 0x5D
    1d08h: Sending Complete
    1d08h: Bearer Capability i = 0x8890
    1d08h: Channel ID i = 0x89
    1d08h: Calling Party Number i = 0x00A3
    1d08h: Called Party Number i = 0xC1, '43218765'
    1d08h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
    1d08h: ISDN BR0: TX -> CONNECT pd = 8 callref = 0xDD
    1d08h: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x5D

    2. Successful call:
    1d08h: ISDN BR0: RX <- SETUP pd = 8 callref = 0x5C
    1d08h: Sending Complete
    1d08h: Bearer Capability i = 0x8890
    1d08h: Channel ID i = 0x89
    1d08h: Calling Party Number i = 0x2183, '34568731'
    1d08h: Called Party Number i = 0xC1, ''43218765'
    1d08h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
    1d08h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 34568731
    1d08h: ISDN BR0: TX -> CONNECT pd = 8 callref = 0xDC
    1d08h: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x5C

    I believe there is something wrong " Calling Party Number i = 0x00A3".
    Any ideas to bypass this?

    Thank you.
     
    wxu3000, Jul 13, 2005
    #2
    1. Advertisements

  3. wxu3000

    wxu3000 Guest

    I believe there is something wrong with the telecomm company, who did
    not advertise the PRI ISDN number properly. And they denied the
    problem.

    However, it is fixed by using "ppp authentication chap".
     
    wxu3000, Aug 5, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.