ISDN Dial Backup @ Wits End...

Discussion in 'Cisco' started by Charles U Farley, Jan 30, 2004.

  1. I'm at my wits end about getting this ISDN to call when the serial interface
    fails. I've taken the config directly from Cisco's website and cannot get
    it to work. Any help/suggestions would be greatly appreciated! My config
    is below, sorry for a long post.

    Chuck.


    #############
    ## Calling router
    #############

    username Main password 7 changeme
    !
    ip multicast-routing
    ip dvmrp route-limit 20000
    isdn switch-type basic-5ess
    !
    interface Ethernet0/0
    ip address 10.4.0.1 255.255.0.0
    ip helper-address 10.1.0.11
    !
    interface BRI0/0
    ip address 10.249.250.2 255.255.255.252
    no ip directed-broadcast
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    load-interval 30
    no keepalive
    dialer map ip 10.249.250.1 name Main broadcast 3xxxxxxxxx
    dialer load-threshold 5 either
    dialer-group 1
    isdn switch-type basic-5ess
    no cdp enable
    ppp authentication chap
    ppp multilink
    !
    interface Serial0/0
    bandwidth 2048
    ip address 10.249.250.110 255.255.255.252
    !
    router eigrp 888
    network 10.4.0.0 0.0.255.255
    network 10.249.250.0 0.0.0.255
    eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.249.250.109
    ip route 0.0.0.0 0.0.0.0 10.249.250.1 200
    no ip http server
    !
    access-list 100 deny eigrp any any
    access-list 100 permit ip any any
    dialer-list 1 protocol ip list 100

    ------------------------
    10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
    D 10.8.0.0/16 [90/2707456] via 10.249.250.109, Serial0/0
    D 10.249.251.0/30 [90/297756416] via 10.249.250.109, Serial0/0
    D 10.3.0.0/16 [90/2707456] via 10.249.250.109, Serial0/0
    C 10.249.250.0/30 is directly connected, BRI0/0
    D 10.1.0.0/16 [90/1787392] via 10.249.250.109, Serial0/0
    D 10.7.0.0/16 [90/2707456] via 10.249.250.109, Serial0/0
    C 10.4.0.0/16 is directly connected, Ethernet0/0
    D 10.249.250.104/30 [90/2681856] via 10.249.250.109, Serial0/0
    C 10.249.250.108/30 is directly connected, Serial0/0
    D 10.249.250.100/30 [90/2681856] via 10.249.250.109, Serial0/0
    D 10.249.250.124/30 [90/2681856] via 10.249.250.109, Serial0/0
    D 10.249.250.116/30 [90/2681856] via 10.249.250.109, Serial0/0
    D 192.168.207.0/24 [90/2684416] via 10.249.250.109, Serial0/0
    S* 0.0.0.0/0 [1/0] via 10.249.250.109





    ##################
    # Called router
    ##################
    username Secondary password 7 changeme
    !
    interface Serial1/3
    ip address 10.249.250.109 255.255.255.252
    no ip directed-broadcast
    fair-queue 64 256 0
    !
    interface BRI2/0
    ip address 10.249.250.1 255.255.255.252
    no ip directed-broadcast
    encapsulation ppp
    dialer-group 1
    isdn switch-type basic-5ess
    ppp authentication chap
    ppp multilink
    !
    router eigrp 888
    network 10.1.0.0 0.0.255.255
    network 10.249.250.0 0.0.0.255
    network 10.249.251.0 0.0.0.255
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.1.0.5
    ip route 10.4.0.0 255.255.0.0 10.249.250.2 200
    !
    access-list 100 deny eigrp any any
    access-list 100 permit ip any any
    dialer-list 1 protocol ip list 100
    !
    !

    S 192.168.250.0/24 [1/0] via 10.1.0.5
    10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
    D 10.8.0.0/16 [90/2195456] via 10.249.250.118, Serial1/2
    C 10.249.251.0/30 is directly connected, Tunnel0
    D 10.3.0.0/16 [90/2195456] via 10.249.250.106, Serial1/0
    C 10.249.250.0/30 is directly connected, BRI2/0
    C 10.1.0.0/16 is directly connected, Ethernet0/0
    D 10.7.0.0/16 [90/2195456] via 10.249.250.126, Serial0/0
    D 10.4.0.0/16 [90/1787392] via 10.249.250.110, Serial1/3
    C 10.249.250.104/30 is directly connected, Serial1/0
    C 10.249.250.108/30 is directly connected, Serial1/3
    C 10.249.250.100/30 is directly connected, Serial1/1
    C 10.249.250.124/30 is directly connected, Serial0/0
    C 10.249.250.116/30 is directly connected, Serial1/2
    192.168.207.0/24 is variably subnetted, 2 subnets, 2 masks
    S 192.168.207.1/32 [1/0] via 10.1.0.5
    D 192.168.207.0/24 [90/2172416] via 10.249.250.102, Serial1/1
    S* 0.0.0.0/0 [1/0] via 10.1.0.5
     
    Charles U Farley, Jan 30, 2004
    #1
    1. Advertisements

  2. Charles U Farley

    Hansang Bae Guest

    You need to post the debug for q921, q931 and ppp
    negotiation/authentication. Make sure you turn on msec option for debug
    timestamping. Aaron provide an example a few days ago.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Jan 31, 2004
    #2
    1. Advertisements

  3. Charles U Farley

    Terry Knight Guest

    Chuck,

    try this:

    Router(config)# int serial 0/0 ---------->obviously this is your primary
    interface
    Router(config-if) backup interface bri0/0 ------------------> specifies the
    backup interface
    Router(config-if) backup delay 20 20 ------------------> activates the
    backup 20 seconds after failure and deactivates 20 seconds after the primary
    link comes back up.

    Teggs
     
    Terry Knight, Feb 1, 2004
    #3
  4. Terry,

    Do I leave the rest of the configuration the same? Is anything else
    removed?

    Thanks,
    Chuck.
     
    Charles U Farley, Feb 2, 2004
    #4

  5. The problem is, I can't get to the other side (calling side) unless I go out
    on location (far away and my window of testing is 2:30am-3:00am). The only
    side I can debug from is the received call which nothing comes up as if the
    caller isn't calling. I force the primary link down on the called side and
    wait for the caller to connect...but nothing comes up. I will see about
    getting something out there to capture the console.

    Thanks,
    Chuck
     
    Charles U Farley, Feb 2, 2004
    #5
  6. Charles U Farley

    Ivan Ostres Guest

    Do you have syslog server on remote location? That would do the trick..
     
    Ivan Ostres, Feb 2, 2004
    #6


  7. Unfortunately, no...this office is very limited in what they have.
     
    Charles U Farley, Feb 2, 2004
    #7
  8. ~
    ~ > > The problem is, I can't get to the other side (calling side) unless I go
    ~ out
    ~ > > on location (far away and my window of testing is 2:30am-3:00am). The
    ~ only
    ~ > > side I can debug from is the received call which nothing comes up as if
    ~ the
    ~ > > caller isn't calling. I force the primary link down on the called side
    ~ and
    ~ > > wait for the caller to connect...but nothing comes up. I will see about
    ~ > > getting something out there to capture the console.
    ~ > >
    ~ > >
    ~ > >
    ~ >
    ~ > Do you have syslog server on remote location? That would do the trick..
    ~
    ~
    ~
    ~ Unfortunately, no...this office is very limited in what they have.

    You can just use logging buffered to capture the debugging on the
    far side router. I.e.

    conf term
    service timestamp debug date msec
    logging buffered 30000 debug
    end

    debug this
    debug that

    Then bring down the primary link, then give the remote side
    enough time to call, then bring up the primary link after the
    remote side doesn't call, then telnet to the remote side,
    then do "show log".

    for "this" and "that", I suppose I'd use "debug dialer",
    "debug isdn q931", "debug ppp nego".

    Aaron
     
    Aaron Leonard, Feb 2, 2004
    #8
  9. Charles U Farley

    Terry Knight Guest

    Chuck,

    The rest of the config looks fine.

    Regards

    Teggs
     
    Terry Knight, Feb 3, 2004
    #9
  10. Charles U Farley

    Ned Trilby Guest

    I looked at your original config and it looks good. I was under the
    impression that Cisco didn't want us to use "Backup interfaces" - best
    to use routing metric as Chuck has defined. Chuck - how are you
    bringing down your serial interface ? I hope you are not doing a
    "shutdown" from enable mode? This won't allow the dialer to fire up as
    the "other side" serial is then still up. Best is to pull the serial
    cable from either router and watch your debugs...
    Good luck,
    Ned
     
    Ned Trilby, Feb 3, 2004
    #10
  11. Chuck,

    Ok, I was expecting it to detect it being down when I did a shutdown on the
    interface thus kicking off the BRI Dialer. So the config could be working
    afterall, it's just that I have to physically pull the cable out to verify?
    I may be able to test it this week as the customer just upgraded their
    circuit from a 56k to full T. Before I pull the 56k WIC, I will see what
    happens when I pull the cable.

    Thank you all for the great advice! The help here is priceless...
    Chuck.
     
    Charles U Farley, Feb 3, 2004
    #11
  12. ~


    I will remember this one for future reference....

    Thanks
     
    Charles U Farley, Feb 3, 2004
    #12
  13. PMFJI... but if you're backup method does not detect and recover from
    interface shutdown, what other failure modes is it going to fail to
    recover from???? If your link is not using end-to-end keepalives, then
    there are a whole raft of failures just waiting to happen which "backup
    interface" will not protect you from. Unless there is a unique feature
    of "backup interface" that you just have to have (such as bandwidth on
    demand) it is _far_ better to use dial on demand or dialer watch for ISDN
    backup.

    Disclaimer: As always, YMMV.

    Hint: You have verified that the ISDN line actually does work??? If you
    have a working line and the routers are correctly configured, a "no
    backup interface" on the primary interface should cause the ISDN line to
    immediately dial (and stay up).

    Another Hint: Inserting the lines:
    service timestamps debug datetime msec localtime
    service timestamps log datetime msec localtime
    will make it much easier to interpret what is going on in the buffered
    log.

    Good luck and have fun!
     
    Vincent C Jones, Feb 3, 2004
    #13
  14. Charles U Farley

    John Agosta Guest


    You should beware using the physical port as the backup interface.
    When doing so, the router will hold layer 1 down. It is possible that
    when the backup interface attempts to re-establish L1 connectivity,
    the line does not come up.

    Better to use a "dialer interface" / "dialer profile" as the backup
    interface.
    This way, layer 1 protocol will be active 24x7 on the BRI. When the primary
    interface fails, your router will simply place a call over an already "UP"
    physical port.


    You can see examples of doing this at Cisco's web site,
    and I am sure Vince Jones has someinteresting notes on this subject
    on his site. Check the archives for the URL....


    -ja


    -ja
     
    John Agosta, Feb 4, 2004
    #14
  15. Charles U Farley

    Hansang Bae Guest

    ADmin downing the primary interface will not work. Cisco IOS is smart
    enough to realize that if you admin down the interface, you probably
    don't want the back to kick in. So either change the encapsulation type
    (to go up/down), or pull the cable, or kill the far side.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Feb 4, 2004
    #15
  16. I think there is some confusion (at least there is for me) over
    which interface is being downed. My interpretation is that Chuck is
    at location A. The configuration uses backup interface at location
    B to have B call A. Chuck is trying to test by downing the interface
    on A to force B to call. While the IOS on B may be "smart" enough
    to block backup interface if the primary interface is downed on B,
    downing the interface on B is suicidal if you're doing it from A,
    so I assumed Chuck is downing the interface on A and waiting for B to
    call, a test which _should_ work but does interfere with production
    traffic, particular if the test is successful in finding a problem
    with the backup implementation or link.

    Disclaimer: My experience with backup interface tends to be limited
    these days to using it just enough to point out to the client why they
    should be using dialer watch or DDR instead of backup interface. While
    the configuration is quick and easy, the difficulty of routine testing
    of the backup circuits makes it the hardest to use in the real world.
     
    Vincent C Jones, Feb 4, 2004
    #16
  17. ADmin downing the primary interface will not work. Cisco IOS is smart
    You are correct, I am at location A (the called) and downing the interface
    at A to get location B (the caller) to dial into A.

    Do I know the ISDN works? Well, I can dial it and see my callerID in the
    debug on location B (we had major SBC goofups on which numbers were which).

    I will test this Friday and will consider doing the dialer backup.

    Thanks for everything,
    Chuck.
     
    Charles U Farley, Feb 4, 2004
    #17
  18. A necessary, but not a sufficient test. It does not prove that location
    B can place an outgoing call (this is a particularly common setup error
    if the call is long distance, as that must be separately configured
    by the telco).
    Remember that once you do get it to work, you also need to routinely
    test the backup line to have a significant probability of it actually
    still working when you finally do need it! (See chapters 1 & 4 of my
    book for the gory details :) but the bottom line is that if you don't
    test it, the telco won't fix it when it breaks, because they only
    repair what they're told to...
    You're welcome. Good luck and have fun!
     
    Vincent C Jones, Feb 4, 2004
    #18

  19. When trying to have the dialer (location B) call Location A, it immediately
    fails with the following:
    I have debug isdn q931, ppp negotiation, ppp authentication. These ISDN
    lines do have LD service setup and it is a LD call.


    Massillon#isdn call interface bri 0/0 1330xxx6938
    Massillon#
    5d04h: BRI0/0 DDR: Attempting to dial 1330xxx6938
    5d04h: ISDN BR0/0: TX -> SETUP pd = 8 callref = 0x0D
    5d04h: Bearer Capability i = 0x8890
    5d04h: Channel ID i = 0x83
    5d04h: Called Party Number i = 0x80, '1330xxx6938'
    5d04h: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0x8D
    5d04h: Cause i = 0x82B2 - Requested facility not subscribed
    5d04h: BRI0/0: wait for isdn carrier timeout, call id=0x800D



    When I do the same thing from Location A ( the called) to Location B ( the
    caller ) it gives me the below debug.


    Main#
    Main#isdn call interface bri 2/0 1330xxxxx04
    24w5d: ISDN BR2/0: Event: Hangup call to call id 0x8003 ces = 1
    24w5d: ISDN BR2/0: process_disconnect(): call id 0x8003, call type is DATA,
    b_idb 0x60C20C44, ces 1
    24w5d: CC: dsl 16 No CCB Src->HOST cid 0x8003, ev 0x5 ces 1
    24w5d: ISDN BR2/0: received HOST_QUERY_RESPONSE call_id 0x8003
    Main#
    24w5d: ISDN BR2/0: Outgoing call id = 0x8004, dsl 16
    24w5d: ISDN BR2/0: Event: Call to 1330xxxxx04 at 64 Kb/s
    24w5d: ISDN BR2/0: process_bri_call(): call id 0x8004, called_number
    1330xxxxx04, speed 64, call type DATA
    24w5d: CC_CHAN_GetIdleChanbri: dsl 16
    24w5d: Found idle channel B1
    24w5d: ISDN BR2/0: TX -> INFOc sapi = 0 tei = 65 ns = 1 nr = 3 i =
    0x0801020504028890180183700C803133333038333039383034
    24w5d: SETUP pd = 8 callref = 0x02
    24w5d: Bearer Capability i = 0x8890
    24w5d: Channel ID i = 0x83
    24w5d: Called Party Number i = 0x80, '1330xxxxx04'
    24w5d: ISDN BR2/0: RX <- RRr sapi = 0 tei = 65 nr = 2
    24w5d: ISDN BR2/0: RX <- INFOc sapi = 0 tei = 65 ns = 3 nr = 2 i =
    0x0801825A080282B2
    24w5d: RELEASE_COMP pd = 8 callref = 0x82
    24w5d: Cause i = 0x82B2 - Requested facility not subscribed
    24w5d: ISDN BR2/0: TX -> RRr sapi = 0 tei = 65 nr = 4
    24w5d: ISDN BR2/0: received HOST_DISCONNECT_ACK call_id 0x8003
    24w5d: ISDN BR2/0: Error: Unfound B-channel on Disconnect_Ack - callid
    0x8004
    24w5d: ISDN BR2/0: HOST_DISC_ACK Voice cid 0x8004 error
    24w5d: ISDN BR2/1: TX -> RRp sapi = 0 tei = 81 nr = 2
    24w5d: ISDN BR2/1: RX <- RRf sapi = 0 tei = 81 nr = 0
    24w5d: ISDN BR2/0: Event: Hangup call to call id 0x8004 ces = 1
    24w5d: ISDN BR2/0: process_disconnect(): call id 0x8004, call type is DATA,
    b_idb 0x60C20C44, ces 1
    24w5d: CC: dsl 16 No CCB Src->HOST cid 0x8004, ev 0x5 ces 1
    24w5d: ISDN BR2/0: received HOST_QUERY_RESPONSE call_id 0x8004
    24w5d: ISDN BR2/0: TX -> RRp sapi = 0 tei = 65 nr = 4
    24w5d: ISDN BR2/0: RX <- RRf sapi = 0 tei = 65 nr = 2
     
    Charles U Farley, Feb 16, 2004
    #19
  20. ~
    ~
    ~ When trying to have the dialer (location B) call Location A, it immediately
    ~ fails with the following:
    ~ I have debug isdn q931, ppp negotiation, ppp authentication. These ISDN
    ~ lines do have LD service setup and it is a LD call.
    ~
    ~
    ~ Massillon#isdn call interface bri 0/0 1330xxx6938
    ~ Massillon#
    ~ 5d04h: BRI0/0 DDR: Attempting to dial 1330xxx6938
    ~ 5d04h: ISDN BR0/0: TX -> SETUP pd = 8 callref = 0x0D
    ~ 5d04h: Bearer Capability i = 0x8890
    ~ 5d04h: Channel ID i = 0x83
    ~ 5d04h: Called Party Number i = 0x80, '1330xxx6938'
    ~ 5d04h: ISDN BR0/0: RX <- RELEASE_COMP pd = 8 callref = 0x8D
    ~ 5d04h: Cause i = 0x82B2 - Requested facility not subscribed
    ~ 5d04h: BRI0/0: wait for isdn carrier timeout, call id=0x800D

    Talk to the guys who run your local switch. (I.e. your LEC.)
    Ask them what they've got set up wrong. They either don't
    like your number format or they don't want to let you place
    64k data calls. If it's the latter situation, you could try
    placing a DOV call and see what happens.
    (http://www.cisco.com/warp/public/793/access_dial/8.html)
     
    Aaron Leonard, Feb 17, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.