ISDN DDR routing

Discussion in 'Cisco' started by Toby, Jun 6, 2004.

  1. Toby

    Toby Guest

    Any ideas what I am doing wrong here?

    I am trying to set up a dial on demand ISDN link with one way calling only.
    I can get the link to come up and traffic to pass in one direction but no
    traffic is returning over the link. According to Cisco the dialed router
    should set up a dynamic mapping back over the ISDN link which it does.
    (confirmed with SH IP ROUTE with a /32 address). When using DEBUG IP TRAFFIC
    it becomes clear that the traffic is being sent to the BRI interface on
    return, but there is an encapsulation failure so it does not pass it
    back.over the link.

    I am using a 3620 and a 2522 and have tried it in both directions from clean
    load of routers. the 3620 is running IOS 12.0(8) and the 2522 12.0(17)

    The config is as follows as it currently stands.

    2522
    ip subnet-zero
    isdn switch-type basic-net3
    !
    interface Loopback0
    ip address 10.3.3.3 255.255.255.255
    no ip directed-broadcast
    !
    interface BRI0
    ip address 172.16.1.1 255.255.255.252
    no ip directed-broadcast
    encapsulation ppp
    isdn switch-type basic-net3
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.16.1.2 permanent

    3620
    ip subnet-zero
    isdn switch-type basic-net3
    !
    interface Loopback0
    ip address 10.4.4.4 255.255.255.255
    no ip directed-broadcast
    !
    interface BRI1/0
    ip address 172.16.1.2 255.255.255.252
    no ip directed-broadcast
    encapsulation ppp
    dialer map ip 172.16.1.1 21
    dialer-group 1
    isdn switch-type basic-net3
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.16.1.1 permanent
    !
    dialer-list 1 protocol ip permit

    Please note I have tried pointing the default route to the local, remote IP
    addresses of the BRI interface and also to the BRI interface itself. The
    only difference I have found is that I have to point it to the remote
    address to bring the link up.

    What have I missed?

    Thanks

    Toby

    P.S. I am using a ISDN PBX to test this hence the two digit dialing
    sequence. Not a simulator.
     
    Toby, Jun 6, 2004
    #1
    1. Advertisements

  2. Toby

    Hansang Bae Guest

    [snip]

    You're missing dialer-maps and dialer-list on the 2500 side.



    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Jun 7, 2004
    #2
    1. Advertisements

  3. Toby

    Toby Guest

     
    Toby, Jun 7, 2004
    #3
  4. Toby

    Hansang Bae Guest

     
    Hansang Bae, Jun 7, 2004
    #4
  5. Toby

    Toby Guest

    I have already had this working with two way dialing, I am trying to get
    this working so that only one way calling is in use.

    I agree it looks like the Cisco documentation is wrong as when I configure
    the default route to the BRI interface on the calling side instead of the
    remote BRI IP address I get encapsulation failed on the sending side too so
    this looks like a mapping problem as you suggest. Partly I wanted
    confirmation that the Cisco recomended config is incorrect and also the
    correct or should I say recomended method that works one way.

    Should I create a map and also deny all interesting traffic on the called
    side so that it will respond but not initiate a call itself. Also I know
    that I should use specific IP ROUTE commands on the called side in a real
    network enviroment and not a default route, but as this is a home test lab a
    default route is a no brainer for this purpose. Is there a better/prefered
    way of achieving this though?

    Thanks

    Toby

     
    Toby, Jun 7, 2004
    #5
  6. Toby

    Hansang Bae Guest

    The easiest way to do it is just to leave the number out of the dialer-
    map statement. If there is no number, it cannot dial out. Also, you
    may want the keyword "broadcast" if you need some routing updates to go
    across the link. Finally, legacy dialers are, well, legacy. But since
    I don't work with dialer profiles too much, I can't give you a good
    working config.

    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Jun 8, 2004
    #6
  7. Toby

    Toby Guest

    Thanks for that.

    I am trying to go through all the config types, Legacy 2 way, one way,
    Ringback, dialer watch (whatever that is) etc at present, as a learning
    curve.

    Any known problems/solutions welcome.

    Toby
     
    Toby, Jun 8, 2004
    #7
  8. Toby

    Hansang Bae Guest

    As a general practice, I almost always disable fast switching on BRI
    interfaces. "no ip route-cache" Way too many bugs in the older code.


    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
     
    Hansang Bae, Jun 9, 2004
    #8
  9. Toby

    Toby Guest

    That's useful to know.
    I may try with and without ip route cache on various scenarios to see if I
    run into any problems.

    Cheers

    Toby
     
    Toby, Jun 9, 2004
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.