ISDN (BRI) Dial-in w/cisco 2611, routing

Discussion in 'Cisco' started by Rainer, Jul 17, 2003.

  1. Rainer

    Rainer Guest

    Hi all,

    I am having problems accessing a network via ISDN dial-in


    Cisco 2611
    +------------------------+ Gateway: 10.1.1.1
    PC -------( ISDN )-------| BRI0/0 Eth0/0 |------( LAN )------
    +------------------------+ 10.1.1.x
    192.168.1.1 10.1.1.2
    pool:
    192.168.1.3
    - 192.168.1.4


    I can dial in, get a ip (e.g.192.168.1.3), i can ping to
    192.168.1.3 (my computer)
    192.168.1.1 (cisco router)
    10.1.1.2 (Ethernet Card)

    but that´s it! I can´t reach e.g. 10.1.1.1 and other PCs in the LAN.
    What am I doing wrong? please help!

    Rainer


    ----[sh run]--------------------------------

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Cisco2600
    !
    enable secret <>
    enable password <>
    !
    username xxx password <>
    ip subnet-zero
    !
    !
    no ip domain-lookup
    !
    isdn switch-type basic-net3
    !
    interface FastEthernet0/0
    description connected to EthernetLAN
    ip address 10.1.1.2 255.0.0.0
    speed auto
    full-duplex
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface BRI1/0
    description connected to Dial-inPCs(ISDN)
    no ip address
    encapsulation ppp
    dialer rotary-group 1
    dialer-group 1
    isdn switch-type basic-net3
    no cdp enable
    !
    interface BRI1/1
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface BRI1/2
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface BRI1/3
    no ip address
    shutdown
    isdn switch-type basic-net3
    !
    interface Dialer1
    description connected to Dial-inPCs(ISDN)
    ip address 192.168.1.1 255.255.255.0
    encapsulation ppp
    no ip split-horizon
    dialer in-band
    dialer-group 1
    peer default ip address pool Cisco2600-Group-1
    no cdp enable
    ppp authentication chap pap callin
    ppp multilink
    !
    router rip
    version 2
    network 10.0.0.0
    network 192.168.1.0
    no auto-summary
    !
    ip local pool Cisco2600-Group-1 192.168.1.3 192.168.1.4
    ip classless
    no ip http server
    ip pim bidir-enable
    !
    !
    dialer-list 1 protocol ip permit
    snmp-server community public RO
    !
    line con 0
    exec-timeout 0 0
    password <>
    login
    line aux 0
    line vty 0 4
    password <>
    login
    !
    end
    !
     
    Rainer, Jul 17, 2003
    #1
    1. Advertisements

  2. Because you want 10.1.1.2 255.255.255.0 instead ?
     
    jonathan fernandes, Jul 17, 2003
    #2
    1. Advertisements

  3. Rainer

    Rainer Guest

    What am I doing wrong? please help!
    well, I had to add
    route add 192.168.1.0 mask 255.255.255.0 10.1.1.2
    for each pc on startup.

    are ther better ways doing so?
    Rainer
     
    Rainer, Jul 18, 2003
    #3
  4. Rainer

    Rainer Guest

    Yes, there's a better way.
    Hi Hans,

    I do know the task of a default gatway, but as I have to integrate the
    router into an already existing LAN, where I don´t have access to the
    clients standard gateway settings (there I could have integrated my
    router...) But in this case, I will have to include some batch for all the
    clients...

    But whe the client doesn´t have a default gateway, will it find my remote
    dial-in computers IP address? (just wondering)

    Rainer
     
    Rainer, Jul 21, 2003
    #4
  5. Rainer

    Rainer Guest

    Hi Laurent,

    I changed this already; but the problem was, that the pc inside the LAN
    didn´t know where to respond, as the default gateway didnt´t know my new
    router. So in order to fix this without touching the standard gateway (I
    don´t even know if there will be one...), I have to add a static route for
    all clients.

    regards,
    Rainer
     
    Rainer, Jul 21, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.