Internet access from inside : PIX 501 VPN Server

Discussion in 'Cisco' started by Karel Vandenhove, Apr 7, 2005.

  1. Hi,

    This must be very basic. I googled but found no help.

    We set up a PIX 501 as a VPN Server.
    We used the PDM - VPN Wizard and the VPN side of the equation works fine: we
    can access the required servers from remote VPN CLients (Cisco software VPN
    Client).

    The same PIX 501 was used for our internet access.
    This worked fine before we set up the VPN Server.
    Now there is no more internet access possible from the inside.

    What have I done wrong?

    I know that to have internet access on the client side, the PIX has to be
    configured for split-tunneling. Our problem lies on the server side.


    Best regards,

    Karel Vandenhove
     
    Karel Vandenhove, Apr 7, 2005
    #1
    1. Advertisements

  2. Karel Vandenhove

    òTTó Guest

    Show me your config

    Regards Otto
     
    òTTó, Apr 7, 2005
    #2
    1. Advertisements

  3. Hi,

    Thank you for wanting to help me out!

    It is basically the standard configuration, followed by the PDM- VPN Wizard
    generated VPN config:


    Building configuration...
    : Saved
    :
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname pixfirewall
    domain-name ciscopix.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list inside_outbound_nat0_acl permit ip host 192.168.254.2
    192.168.254.96 255.255.255.224
    access-list inside_outbound_nat0_acl permit ip any 192.168.254.96
    255.255.255.224
    access-list FRTLADON_splitTunnelAcl permit ip 192.168.255.0 255.255.255.0
    any
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute retry 4
    ip address inside 192.168.254.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool FRTLADON01 192.168.254.100-192.168.254.120
    pdm location 192.168.254.2 255.255.255.255 inside
    pdm location 192.168.0.107 255.255.255.255 outside
    pdm location 192.168.254.0 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) 192.168.254.2 192.168.254.2 netmask 255.255.255.255
    0 0
    access-group inside_access_in in interface inside
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.254.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map client authentication LOCAL
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup FRTLADON address-pool FRTLADON01
    vpngroup FRTLADON dns-server 192.168.254.1 195.238.2.22
    vpngroup FRTLADON split-tunnel FRTLADON_splitTunnelAcl
    vpngroup FRTLADON idle-time 1800
    vpngroup FRTLADON password ********
    telnet 192.168.254.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    management-access outside
    console timeout 0
    dhcpd address 192.168.254.2-192.168.254.33 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    username Karel password Wur7WOs2efPKblzy encrypted privilege 15
    terminal width 80
    Cryptochecksum:5e021413efbfea34808ca8a839e791ca
    : end
    [OK]
     
    Karel Vandenhove, Apr 7, 2005
    #3
  4. Karel Vandenhove

    òTTó Guest

    Hi Karel,

    I do not know what you are doing with this part

    static (inside,outside) 192.168.254.2 192.168.254.2 netmask
    255.255.255.255

    But you can't use a IP address in this line on the outside interface,
    because you get this address by dhcp on your outside interface. So try
    something like this

    static (inside,outside) tcp interface smtp 192.168.254.2 smtp netmask
    255.255.255.255

    Regards oTTo


     
    òTTó, Apr 8, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.