Intel PRO/2200bg problems - can't connect with office or home Wireless LAN

Discussion in 'Wireless Networking' started by JS, Jan 5, 2007.

  1. JS

    JS Guest

    Background: I have a Dell Latitude D600 with Pro/2200bg wireless connection
    on Windows XP professional with SP2. The radar like wireless icon of
    PRO/2200gb in the tray was fine (green signal and everything) but used to
    show Nordic( Swedish!) language so I asked my admin to change the language
    to English. He went ahead and uninstalled the driver completely and told me
    a re-install will get English language.

    However: Now I can't connect with any wireless connection anywhere - office
    or home despite many re-installs of 2200bg driver from both dell and Intel
    sites. Admin is clueless.

    When I right click on the Wireless icon -everything is greyed out except for
    - When I click the Troubleshooter the message is CURRENTLY THERE ARE NO
    -When I click on OPEN Intel proset Wireless the pop says Intel
    PROset/Wireless was unable to detect a supported wireless adapter. Pls.
    install a supported wireless adapter.

    * If I go to drivers and look at Network Adapters - it shows Intel
    PRO/Wireless 2200BG Network Connection in green but if I right click it, I
    see a pop-up that says ADAPTER STATE NOT FOUND IN REGISTRY. If I click OK
    button on the pop up, it shows a window with 5 tabs( General,
    Advanced,Driver, Details, Resources) - In the general category its says"
    This device is working properly" and the Device usage shows Device enabled
    * there is another Network Adapter that is marked with a red tag (and I
    believe this adapter was not there earlier at all) Intel PRO/Wireless 2200BG
    Network Connection - PACKET SCHEDULER MINIPORT that is shown as disabled. If
    I enable it , I get the message - " Windows successfully enabled this
    device, however, this device is still not working properly and the red tag
    changes to a yellow colored ! sign.

    could somebody pls. guide me how to rectify these errors.
    Thank you Very much for reading and responding.
    JS, Jan 5, 2007
    1. Advertisements

  2. JS

    Jim Guest

    Perhaps there the adapter cannot connect because it has a hardware problem.
    You could try reseating the adapter (although if this were the problem, I
    would not expect that XP would report that the device is working properly).
    Jim, Jan 5, 2007
    1. Advertisements

  3. JS

    David Hettel Guest

    It almost sounds as if your adapter is powered off. Do you have a switch to
    enable it on your Dell? If not you might try pressing Function F5 at the
    same time.

    David Hettel

    Please post any reply as a follow-up message in the news group for everyone
    to see. I'm sorry, but I don't answer questions addressed directly to me in
    E-mail or news groups.

    Microsoft Most Valuable Professional Program

    DISCLAIMER: This posting is provided "AS IS" with no warranty of any kind,
    either expressed or implied, made in relation to the accuracy, reliability
    or content of this post. The author shall not be liable for any direct,
    indirect, incidental or consequential damages arising out of the use of, or
    inability to use, information or opinions expressed in this post and confers
    no rights.
    David Hettel, Jan 6, 2007
  4. JS

    Pavel A. Guest

    Probably you installed the latest PROset software. It does not support
    2200 adapters any longer. Get an earlier version that supports 2200.

    Pavel A., Jan 6, 2007
  5. JS


    Oct 29, 2008
    Likes Received:
    Sorry to bring this post back from the dead, but I'm having a similar problem.

    Curious if you ever got this problem solved?

    I'm not too sure about the latest version of PROset not supporting the 2200bg anymore. It is still listed as a supported card on the website. They actually just announced the EOL of the product earlier this year.

    I've narrowed this down to an XP problem - I dual boot (XP and Vista) and the card works fine in Vista.

    Both OS also have Odyssey Client (Juniper) installed - however I do not have PROset installed on Vista.

    After attempting to install PROset on XP, it seems to have completely killed my wireless adapter. It is recognized in device manager as fully functional. It shows up in Network Connections and even acts like it is attempting to connect.

    Running ipconfig /all only shows my ethernet adapter.

    Odyssey opens but reports that no adapters are installed.

    PROset opens and tells me that no valid adapters are installed.

    Opening the adapter in Device Manager gives me the "adapter state not found in registry" message.

    I cleaned the registry of any references to PROset and reinstalled the adapter (as XP recognizes it as new hardware) but I'm still presented with the same problems.

    Any clues?

    Haywood_U, Oct 29, 2008
  6. JS


    Dec 16, 2008
    Likes Received:
    I found a clue:


    Recommended Service Packs for Windows XP*
    Service Pack for Microsoft Windows XP*

    For the driver and software to function correctly on Windows XP, the recommendation is to install Service Pack 1 or later.
    Windows Installer 3.1 v2 for Microsoft Windows XP

    For the driver and software to function correctly on Windows XP, ensure that the Windows Installer 3.1 v2 or greater is installed.


    I think the key is a new MSI since you probably already have at least SP1 installed. Look for the 3.1 v2 or even the 4.5 redistributable on the Microsoft site:

    Windows Installer 3.1 Redistributable (v2)


    Windows Installer 4.5 Redistributable
    2bz, Dec 16, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.