Intel Ham v92 modem driver

Discussion in 'NZ Computing' started by Warwick, Sep 6, 2004.

  1. Warwick

    Warwick Guest

    Hi,

    I am having problems with this modem, originally supplied by the pc
    company.

    I have their original driver, and two more I got off the net.
    The driver is causing the machine to not shut down, and then again it won't
    boot properly either. Usually the machine freezes, and requires a reboot
    and then boot from the safe mode etc menu, that is popped up when windows
    does not shut down properly.

    In any case when windows does start there is about 5 minutes before the
    connection icon using the modem appears, if I am foolish enough to click on
    that before time is up, the entire machine and start menu freeze until the
    'waiting period' is over.

    Anyone got any experience with this beast and win xp?
    Failing that can anyone point me to a good site for drivers, my googling
    for them is leaving me bewildered, and most links seem to point to
    driverguide.com and the same driver - which is no good.

    cheers
    Warwick
     
    Warwick, Sep 6, 2004
    #1
    1. Advertisements

  2. The modem may be faulty.
    It may save you a lot of grief if you just replace
    it
     
    Steve Robertson, Sep 6, 2004
    #2
    1. Advertisements

  3. Warwick

    joe_90 Guest

    Can't help with experience using the beast, but a quick Google found
    this page (assuming this is the right model modem) which seems quite
    comprehensive, including Intel drivers for most OS's -

    http://www.modem-help.co.uk/chips/amb563.html
     
    joe_90, Sep 6, 2004
    #3
  4. Warwick

    Dave Taylor Guest

    From Intel?
    Intel Hardware should be supported by them or by the PC Company. Perhaps
    it is simply not supported under XP? Intel has feedback pages and they do
    read their technical inquiry feedbacks. Doesn't XP have the driver already
    built in?
    Ciao, Dave
     
    Dave Taylor, Sep 6, 2004
    #4
  5. Warwick

    Warwick Guest

    thx Joe :)
    I need to take the card out to properly id the chipset, but these look like
    the business and from the manufacturers site to boot.
    Buggered if I know why the searchstring "Intel Ham V92 Modem driver
    download' yielded such a crap pile of hits for me in google :(
     
    Warwick, Sep 6, 2004
    #5
  6. Warwick

    Malcolm Guest

    Hi
    "Intel Ham Chipset" would have been a better one to use...there are
    drivers on the DSE web site...

    Cheers
    Malcolm
     
    Malcolm, Sep 6, 2004
    #6
  7. I used to use one, mainly because it worked in Linux too.
    I grabbed the driver rom support.intel.com from memory.
    I'll have a look for it today, although from memory, there were a few
    models, and I had to have that to grab the right one.

    FYI - one of the best(held connections, no disconnects etc.) PCI modems
    I've ever used.
     
    Dave - Dave.net.nz, Sep 6, 2004
    #7
  8. Warwick

    C Guest

    I had the exact same problems with the DSE Intel Ham Modem in Win98.
    Couldn't sort it so stuck a Dynalink external outside the box. No
    worries - except have a modem sitting here still.
     
    C, Sep 7, 2004
    #8
  9. Warwick

    Warwick Guest

    Thanks Dave.
    I could use some more advice.
    I took the card out of the box and identified the chip as MD5628D.
    Then I went here
    http://developer.intel.com/design/modems/support/drivers.htm
    then into archived drivers and picked the one that matched the chip ID.
    A mere 460 kb.
    Trouble is XP refuses to update with this driver, it says my current one is
    newer.
    However shut down and boot up problems persist, and I am nearly 100%
    confident the HAM driver is to blame.
    Should I uninstall the driver I have and install the intel one?
    Or trust windows to choose the best driver? (In which case windows appears
    to have made an odd choice).
    IIRC there was an issue with this, if drivers' version numbers were lower
    than the one installed, windows automatically dismisses it as older. This
    is not always the case.

    Any help appreciated

    cheers
     
    Warwick, Sep 7, 2004
    #9
  10. I searched for it and got this page
    http://downloadfinder.intel.com/scripts-df/Detail_Desc.asp?agr=Y&ProductID=1057&DwnldID=5992
    Ver: 4.47.2 Date: 7/22/2002 Size: 264 (KB)
    Isnt there a way to force it to use the driver you specify? Im sure
    there is. It might be right click on "my computer" choose manage, click
    on "device manager". select your modem, right click, choose properties,
    click on the driver tab, chose "update driver", click next, choose
    "display a list of drivers in a chosen location" or similar. browse to
    the location where you saved the files to, and you should be able to
    choose one from there.
    Try the above and get back to me.
     
    Dave - Dave.net.nz, Sep 7, 2004
    #10
  11. Warwick

    Warwick Guest

    No you can't force an update.
    I uninstalled the driver from the option on the same dialog.
    This actually removed the device completely from device manager.
    So I asked windows to scan for new hardware, it found the unknown PCI
    communications device. I then updated the driver from a specific location
    pointing it to the driver I thought was best.

    The machine now boots up, shuts down and restarts as it should.
    There is still some delay in the connection being available - the start
    menu connection link is dead for the first few minutes after boot. I can
    live with that. The start menu does not freeze like it used to if I tried
    to invoke the connection too soon.



    Other problems have also disappeared. The speaker is off as it should be -
    previously the speaker was always on no matter what, and at times it would
    switch on mid connection and make a hell of a racket. This was
    intermittent, and could be forced by picking up the phone.

    cheers
     
    Warwick, Sep 8, 2004
    #11
  12. ok, good then
    well thats mostly good.
    heh, that it a horrible problem... I once had to put up with it on an LT
    winmodem while I downloaded 5MB of driver updates for it.
    The owners had cancelled their internet connection because of it.
     
    Dave - Dave.net.nz, Sep 8, 2004
    #12
  13. Warwick

    Richard Guest

    Disable any unused ethernet interfaces, its awaiting a DHCP responce, mousing
    over the network connections menu makes it freeze till its times out.
    The speaker was coming on because it was retraining. I wasnt aware any current
    modems offered this feature.
     
    Richard, Sep 11, 2004
    #13
  14. Warwick

    Warwick Guest

    Jeeez, thank you very much Richard.

    I wondered about that when I set the Lan up - because no machines are
    acting as dhcp server, and there is an exclamation mark on the lan symbol
    on one machine, and it won't repair because it cant renew IP#.

    But it all works.

    How can I resolve this? I have two machines, a laptop with xp pro, and a
    desktop with xp home. I use dial up, each machine has a modem, and I want
    to keep it that way, ie no internet connection sharing.

    I'd prefer to assign each one a static IP from the private address range.

    Any help or pointers to online resources would be appreciated.

    cheers


    btw, I spoke to soon about the shut down problems. 24 hours after I posted
    the earlier resolution the misbehviour at shutdown and start on the desktop
    returned :(. Hangs at "Windows is saving your settings".
     
    Warwick, Sep 11, 2004
    #14
  15. retraining?
    Im more than willing to be corrected but I'm pretty sure that all modems
    support it, atleast all recent ones.
     
    Dave - Dave.net.nz, Sep 11, 2004
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.