Intalling Windows 7 on New System

Discussion in 'Computer Information' started by John, Sep 24, 2011.

  1. John

    John Guest

    I am in the middle of my new system build at the moment. I wish to
    install Windows 7 Home Premium but not totally sure how to do it yet
    boot wise.

    I have the Asrock Extreme 4 Gen 3 board and sata 3 drive connected on
    SATA 0 port which is going to be where I do the install.

    The board itself didn't have the long socket to connect my DVD-RW
    drive so I have had to put in a Belkin PCI card that has the ATA100
    long ribbon style connectors. I guess modern DVD-RW and Blu-Ray
    optical drives all must just use the new small SATA connectors now?

    How do I now get the bios to recognise this DVD-RW as a boot device
    from the Belkin PCI card so I can install windows 7?

    Failing that is there a way I can copy my windows 7 dvd to my patriot
    16gb flash drive and boot from usb instead?

    I have the Asrock Extreme 4 Gen 3 board.

    Thanks for any help with this,

    John, Sep 24, 2011
    1. Advertisements

  2. John

    Paul Guest

    One report of a problem here, with the Belkin F5U098V. See the customer

    Based on the angular picture, I think I'm seeing a SIL0680 chip.
    The card supports Soft RAID and regular IDE operation. The Amazon
    reviewer seems to indicate the manual says "jumper in" for IDE.

    The chip above the SIL0680, holds the firmware. The BIOS loads
    this during POST. The flash chip holds Extended INT 0x13 code
    which supports booting from the card. For this to work, there
    are some settings in the BIOS that must be enabled. Some motherboards
    turn off option ROM loading, out of the box. In the picture
    of the card, you can see there is room for a PLCC socket to hold
    the flash chip, but they decided to just solder the chip right to
    the card.|41FB1CTiKwL.jpg

    Multiple Asrock products have "Extreme 4 Gen 3" in the name, so I
    can't download the exact manual and look for the option ROM settings.
    (And in any case, the picture in the manual I did look at, was
    total illegible.)

    If I use my motherboard manual as an example, the setting is
    "Interrupt 19 Capture" and by default it is disabled, and
    needs to be enabled to make a bootable IDE card work.

    Interrupt 19 is decimal. You can find references to
    Interrupt 0x13, which is hexadecimal and 1x16 + 3 = 19
    when you do conversion to decimal. The BIOS screen may be
    using the decimal value for the software interrupt referred
    to in this case. You'll see either 19 or 0x13 used in BIOS screens.
    I presume a UEFI BIOS still supports this, but how it would appear
    on the screen is another question.

    An option ROM needs space to load. If you have a fancy motherboard,
    with many option ROMs already present (ethernet boot, VESA ROM on
    video card, SATA boot), they're loaded in bus discovery order, and
    there may not be sufficient room to load the ROM on the new card.
    In such cases (which happens on servers), sometimes you have to
    disable other ROMs manually, in order that the boot ROM get loaded.
    Disabling the Ethernet ROM is a slam dunk, but might not save much
    ROM loading space. The video card VESA ROM is a pig, but you can't
    do anything about that one.

    On my motherboard, I press F8 to bring up the popup boot menu.
    On an Asrock board, it might be F11. From that menu, if you
    connect an IDE DVD to your SIL0680, enable Int 0x13 loading
    in the BIOS, then the DVD should appear by name, in the popup
    boot menu.

    This is from an Asrock manual...

    "During POST at the beginning of system boot-up, press <F11> key,
    and then a window for boot devices selection appears. Please
    select CD-ROM as the boot device."

    If your IDE DVD is connected to your SIL0680, it should end up in
    that menu, if the option ROM loaded and executed as expected.

    CMD0680/SIL0680, has been known to do some strange stuff. Years
    ago, if a person installed a two port 0680 card, the motherboard
    two IDE connectors would be disabled. That really shouldn't happen.
    But that's another anomaly I've read about. That doesn't happen
    with other chip types (VIA 6421 etc).

    Paul, Sep 25, 2011
    1. Advertisements

  3. You can google slip stream win7 install and use a USB flash drive or
    spend another 20 bucks for a SATA DVD/CD drive
    Fat-Dumb and Happy, Sep 25, 2011

  4. ???

    The rest of us would use a USB based CD, or install a SATA-based CD. You're
    gonna need a CD/DVD again anyhow, you may as well break down and get one now
    so you can build your machine properly.
    Jeff Strickland, Sep 25, 2011
  5. John

    John Guest

    Unfortunately I don't see any option in the BIOS for enabling Int 0x13

    I also don't see anything for booting from USB either.
    John, Sep 25, 2011
  6. John

    John Guest

    I've downloaded DiskPart so I can hopefully just copy the Windows 7 CD/
    DVD (whichever it is?) to USB drive. Unfortunately I still don't see
    anything in the BIOS for even booting from USB never mind an older non
    SATA DVD-RW drive.

    I probably will end up getting a newer Blu-Ray BD-RW soon/eventually,
    I just wanted to get Windows 7 installed first of all. I don't even
    have dedicated graphics card yet just the bare components I needed to
    get the job done or at least thought I could get the job done with.

    John, Sep 25, 2011
  7. John

    John Guest

    Okay. If I use DiskPart and copy my Windows 7 installation disc onto a
    USB flash drive, how do I then install it on my new system???

    What do I need to select in the BIOS to boot from USB?

    John, Sep 25, 2011
  8. John

    Paul Guest

    Does the popup boot menu work ?

    You should also be able to edit the boot order in the BIOS
    setup screen, assuming the DVD "registered" via extended int 0x13 service.
    So you could add the DVD to the boot order there.

    The purpose of pressing <f11> is to quickly verify it is working.

    Some of these add in cards, during BIOS POST, they'll print a few lines
    on the screen. The print statements are coming from the add-in option ROM
    code. The printed lines should be noting whether drives were detected
    or not. So if you had a PCI IDE card, with two ribbon cables, there
    would be four lines on the screen. It might look something like this,
    with a declaration of the card name as the first line.

    Baloney Brand PCI IDE Card:

    Master 0 DVD Samsung 1234ABCD
    Slave 0
    Master 1
    Slave 1

    Speaking of which, you have to set your jumpers properly, for an
    IDE device to work and be detected. If there was a problem with
    the jumpering, that might also be a source of trouble. But a jumper
    problem should not prevent the BIOS POST printout from being seen.

    On my computer that has the Promise Ultra133 TX2 card, there is
    an appreciable delay while it attempts disk detection. Even when
    both connectors are unused, and no disks are connected. In that case,
    the four lines are printed on the screen, and the last thing the option
    ROM code prints on the screen, is that "it is unloading as no disks
    were detected". So even if the hardware end of things was botched,
    you'd still get informative messages on the screen. And the message
    stays on the screen long enough, you'd notice it.

    If the option ROM code is not being loaded, then chances are you would
    not see the four lines above, in any form. Either there isn't room
    for the option ROM to load (only something like 128KB of low memory
    is reserved for that), or the equivalent of the Interrupt 19 capture
    thing isn't enabled in the BIOS setup. I have a couple Asus motherboards,
    where "capture" isn't enabled by default, and one of the first things
    I do, is turn it on (even before thinking about adding any cards).
    It's just one of the things I do, as I believe it should always be
    turned on.

    Paul, Sep 25, 2011
  9. John

    Paul Guest

    If your system is ready to boot from USB, you can plug in the USB
    stick now, press <F11> early in POST, and see if the USB stick is
    listed in the popup boot menu. Seeing it listed, doesn't mean anything
    other than that the menu thinks it can handle a USB flash device.
    For a USB device to appear in the menu, the motherboard BIOS must
    be able to probe and read a USB mass storage device.

    (Example of a popup boot menu...)

    Only the motherboard USB ports are candidates for booting. If you
    add a four port PCI USB card, that won't boot (because typically
    there is no option ROM for such things). The motherboard manufacturer
    has a code module in the motherboard BIOS, which knows about USB mass
    storage devices connected to motherboard USB ports. At one time,
    that kind of code, had its own separate page in the BIOS screens
    (providing things such as choices for emulation modes), but that fad
    disappeared after a year or so, and USB became much less prominent.
    Now, you have to "pray it works".

    The flash device still has to have the appropriate kind of contents
    to boot. And if the USB device is empty, there should be an appropriate
    error message telling you the boot failed.

    Paul, Sep 25, 2011
  10. John

    John Guest

    I haven't actually checked the jumper settings but I will do and make
    sure it is on master. It is connected at the end of the ribbon on the
    primary and to IDE1 on the card.

    The pop up boot menu does work. The only thing it lists though is my
    blank SATA3 Hard Drive.

    If I leave it and don't F11 or F5 or anything it goes to a blank
    screen with two lines of text saying "Reboot and select proper boot
    device or insert boot media in selected boot device and press a key_"
    I believe this is a message from the Asrock Bios because I know what
    the Belkin post screen looks like from use on my old system. I believe
    it is the exact same belkin card you have too.

    I don't have a clue what the equivalent of the Interrupt 19 capture
    would be in the Asrock BIOS or how to enable it. I have search through
    the menus but can't seem to find anything that looks like it.

    If checking the jumpers etc doesn't work and it still doesn't
    recognise the DVD-RW connected to pci then I will use DiskPart and
    copy my Windows 7 disc onto USB flash drive and see if anything
    happens when I connect that to USB port and then switch on (and pray
    too :) )

    Cheers for the advice,
    John, Sep 25, 2011
  11. John

    John Guest

    Tried using diskpart and list disk but my usb doesn't show up in there

    RT Seven Lite won't work either.

    Is there a way to do this to create a USB boot disk without using RT
    Seven Lite? The computer I am trying to make a slipstream copy of my
    Windows 7 on is an XP Pro SP3 OS and RT Seven does not work on systems
    older than Vista I believe.

    All I want to do is to to get the Windows 7 boot disc onto a USB drive
    instead. I have also tried the Windows 7 USB/DVD download tool but
    that doesn't work either. I get the error message that files have
    copied sucessfully however there was a problem in making it bootable.

    Unfortunately I can't install off the DVD because my Asrock Extreme 4
    Gen 3 doesn't recognise my DVD-RW as it is old style ATA connector
    having to be connected via Belkin PCI ATA133 card as the Asrock boad
    has no ata connectors but does have the older floppy connector that
    nobody uses anymore go figure!

    No option in the Bios to boot from pci ata! No option I can see to
    select to boot from USB but was gonna try make a bootable USB flash
    drive with Windows 7 slipstreamed or copied onto it and see if it
    works or detects it.

    Any other ideas or advice greatly appreciated on how I can just get
    this Windows 7 installed to my new system build. Do you know if there
    is any other way to do this besides the RT Seven Lite and the Windows
    USB/DVD utility that actually works?

    Doesn't make sense that you can only do it from a SATA DVD drive. What
    a PITA.


    John, Sep 25, 2011
  12. if you have a friend who will let you use their Sata DVD/CD then
    borrow it for a while. This supposed to be an easy way to use a USB
    flash drive, try it and let us know if it works.
    Fat-Dumb and Happy, Sep 25, 2011
  13. John

    Paul Guest

    Microsoft made a tool, but I'm not up on the details. I can get a description

    "When you purchase Windows 7 from Microsoft Store, you have the option
    to download an ISO file or compressed files. The Windows 7 USB/DVD Download
    tool allows you to create a copy of your Windows 7 ISO file on a
    USB flash drive or a DVD. To create a bootable DVD or USB flash drive,
    download the ISO file and then run the Windows 7 USB/DVD Download tool.
    Once this is done, you can install Windows 7 directly from the USB flash
    drive or DVD.

    The tool itself, is available from the microsoftstore site. This store
    sells copies of Windows 7, but it's actually operated by a third party. I
    expect in Microsoft's name or with their permission, since otherwise
    they'd lose that domain name.

    The red link there, is the download.

    Dependencies are .NET 2.0 and IMAPI2, and it's possible both
    of those can be installed on something like WinXP.

    (.NET 2.0 , which you may already have, as it's used by some video card control panels)

    (IMAPI2 , used for optical disk burning, such as burning DVDs. Strictly
    speaking, you're only using the USB option of the Microsoft tool, so
    this isn't necessary for what you're doing. But the program won't even
    start, unless it's installed. So that makes it an [unnecessary] prerequisite.)

    "Image Mastering API v2.0 (IMAPIv2.0) for Windows XP (KB932716)"

    Now, currently, you have a DVD. You'll need to use some DVD burner program or
    other tool, to convert the DVD into an ISO9660 file. I'd check Imgburn, to see
    if the option was in there. Or, I'd use one of my Linux LiveCD environments,
    and something like K3B or other burner program, to convert the DVD into
    an ISO9660 file.

    With the ISO9660 file in hand, my WinXP computer with IMAP2 and .NET 2.0 installed,
    I'd then use Windows7-USB-DVD-tool.exe to prep a blank USB flash drive with the
    all the stuff needed to install Windows 7.

    The other posters posting, reminded me that Microsoft made a tool of
    sorts for this.

    Paul, Sep 25, 2011
  14. Okay. If I use DiskPart and copy my Windows 7 installation disc onto a
    USB flash drive, how do I then install it on my new system???

    What do I need to select in the BIOS to boot from USB?



    Your Win7 CD is already bootable. You need to set your BIOS Boot Priority so
    the drive that the CD is loaded into is the first boot device, and then you
    load Win7 directly from the CD.

    The solution for your problem is so painfully simple that I'm having trouble
    understanding what the question is.

    You need an external CD drive that connects via USB, or you need an internal
    CD. Either way, you need to set the Boot Priority so that wherever the CD is
    loaded is read before the motherboard goes out and looks for the hard disk.
    Jeff Strickland, Sep 25, 2011
  15. Paul banged his head on his keyboard to write :
    FYI, ImgBurn supports ISO9660

    -There are some who call me...

    "Make everything as simple as possible, but not simpler."
    - Albert Einstein (1879-1955)
    James D Andrews, Sep 26, 2011
  16. John

    John Guest


    I already tried this but unfortunately the Microsoft tool doesn't make
    the USB bootable. It comes up with an error message saying the

    Even if it did work sucessfully and make it bootable I'm not convinced
    the Asrock board will boot from USB.

    Thanks anyway,

    John, Sep 27, 2011
  17. John

    John Guest

    The Bios WILL NOT RECOGNISE the DVD-RW as already explained!
    The Bios will not recognise the DVD drive connected.

    It looks like I will have to buy a new one.
    John, Sep 27, 2011
  18. John

    Paul Guest

    First, I just tested the tool here and it worked. I have a Windows 7 32 bit ISO9660
    (from back when the test version was available for download), and installed it to
    an 8GB USB flash using WinXP Pro SP3 OEM x32. I left the USB stick plugged in,
    did a reboot, pressed F8 for my popup boot menu, selected the USB stick (which
    was in the list of drives) and was greeted by the "juggling balls" animation of
    a booting Windows 7 system. Eventually, I got the three line dialog where you
    specify install language and the like. I exited from there, to get back to WinXP.


    There is an answer for your symptoms here. It has to do with using a 32 bit host
    system, to copy the 64 bit ISO9660 to USB. The problem is, the microsoftstore
    tool extracts "bootsect.exe" from the 64 bit ISO, and that won't run on a 32 bit
    host. In my experiment, I had a 32 bit ISO9660 file, so when the bootsect.exe
    was extracted, it matched the bit type of my host OS WinXP x32 and so it would run.


    To make the USB device bootable, you need to run a tool named bootsect.exe.
    In some cases, this tool needs to be downloaded from your Microsoft Store account.
    This may happen if you're trying to create a 64-bit bootable USB device
    from a 32-bit version of Windows. To download bootsect:

    1. Login to your Microsoft Store account to view your purchase history
    2. Look for your Windows 7 purchase.
    3. Next to Windows 7, there is an "Additional download options" drop-down menu.
    4. In the drop-down menu, select "32-bit ISO."
    5. Right-click the link, and then save the bootsect.exe file to the location where
    you installed the Windows 7 USB/DVD Download Tool
    (e.g. C:\Users\username\AppData\Local\Apps\Windows 7 USB DVD Download Tool).
    6. Once the file has been saved, go back to the Windows 7 USB/DVD Download tool
    to create your bootable USB device.

    In this thread, someone posted a site to download a 32 bit version of bootsect.

    I immediately uploaded that to, and this is the scan report. I
    wouldn't unzip it, until checking it first. The zip uncompressed size is 111680,
    so it's bigger than my copy.

    The Answers thread also mentions this is the syntax, if "q:" was your USB flash.
    The NT60 thing, specifies a Vista/Win7 MBR as far as I know. At least by
    specifying a drive letter, it isn't likely to go off and zing your regular
    boot drive (I have nightmares about that, and was doing something similar
    today on yet another USB flash stick).

    bootsect.exe /nt60 q:

    In any case, if you can find a 32 bit version of bootsect.exe, and load that
    in your "Windows 7 USB DVD Download Tool" directory, it will then probably work.
    You don't have to apply the command manually, just let the tool run again and
    apply the line itself.

    What's really stupid about this, is they could have loaded their own copy of
    both the 32 bit and 64 bit versions of that application, in the tool zip itself.
    Why they had to go extracting it from the ISO, makes no sense at all (from
    a "bulletproof" tool design point of view).

    Hmmm. I tried downloading this, and using 7zip, I can see it has a bootsect.exe
    inside. This version of solution is smaller than the one on the microsoftstore site.

    Windows7-USB-DVD-tool.exe 969,504 bytes

    Wudt.msi\\BootsectExe 97280

    If you extract that, then rename the file to bootsect.exe , that should work.
    I just tested it here, with "bootsect.exe /?" and it dumped help info
    (meaning it must be the 32 bit version, because this machine is x32).

    So the CNET version is a pretty small download. You'll need something
    like 7ZIP, to be able to burrow down and extract it (with the "open inside"

    Paul, Sep 27, 2011
  19. The Bios WILL NOT RECOGNISE the DVD-RW as already explained!
    The Bios will not recognise the DVD drive connected.

    It looks like I will have to buy a new one.

    What does that mean?

    There is no option to set the boot priority so that the HDD is set after the
    CD or USB, OR there is an option but the device is not seen so the machine
    does not boot from it? If the latter, then the device is no good, if the
    former then I'm not sure Win7 is the OS you should be using.

    I missed a key word in my previous post...

    You need either an external DVD/CD device that connects via USB on an
    internal DVD/CD that connects via SATA (SATA is missing from the earlier
    post). I suppose you do't have to have a SATA CD drive, but I think that a
    motherboard that still supports IDE is probably not a good fit for Win7
    anyhow. The issues isn't the IDE support as much as the idea that if there
    is IDE support then the architecture of the board is probably too slow to
    get the best advantage from Win7.

    I bought a SATA-capable DVD-RW/CD just this past weekend from Best Buy for
    $45. If you have a Fry's Electronics near you, you can get one for about
    Jeff Strickland, Sep 27, 2011
  20. John

    John Guest

    Thanks for everyones help. I had to buy a new SATA DVD-RW drive
    because the Asrock board doesn't have ATA connection and wont
    recognise ATA 100/133/150 DVD-RW drive connected to Belkin PCI ATA
    adapter card. In addition the Microsoft Windows DVD/USB tool wouldn't
    work correctly and make a USB flash drive bootable so I couldn't even
    install Windows 7 from USB so there was really no other option and no
    other way to install Windows on this mainboard.
    John, Oct 5, 2011
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.