Installing to SATA (and there are also EIDE drives)

Discussion in 'Windows 64bit' started by Gary J. Dikkema, Jul 16, 2005.

  1. The SATA drive is partitioned and starts at E, F, G...

    The two EIDE drives are listed first and are C and D

    So why when installing to the SATA drive - whichever partition - does it
    always update boot.ini et al on the C drive.

    The SATA drive is the first bootable drive in the Bios...

    I just keep updating the boot.ini file on E but wonder how I can prevent
    this action...

    TIA

    Gary D
     
    Gary J. Dikkema, Jul 16, 2005
    #1
    1. Advertisements

  2. Hi Gary,

    Hard to help you without knowing a bit more about your config. I suspect a
    driver problem for your sata, depending of your Mobo.
    Did you use the F6 and the sata driver during setup ?

    Tell us more please

    Cheers
     
    Christian Hougardy, Jul 16, 2005
    #2
    1. Advertisements

  3. Gary J. Dikkema

    Rick Guest

    The EIDE drives are identified by the system as 80h and 81h. The SATA
    drive is identified as 82h. The order you designate in your boot
    sequence does not affect how the computer BIOS identifies the drives.

    The entry in the boot.ini is simply stating that you install to the SATA
    drive, the boot image is on disk(2) and the respective partition.

    What do you keep changing and what happens after you change it?
     
    Rick, Jul 16, 2005
    #3
  4. Rick,

    On the E drive I keep adding new bootable partitions/machines and I have to
    add their info to the E drive boot.ini file... it seems that every new
    bootable partition/machine I add to the SATA drive creates boot.ini on the C
    drive.... boot.ini ntldr et al...
     
    Gary J. Dikkema, Jul 16, 2005
    #4
  5. The SATA drive is found just fine... a single disk not part of an array...

    There are also 2 EIDE drives...

    I have partitioned the 160 GB SATA drive and add new bootable machines to it
    expecting the boot.ini on E to reflect this... instead, a boot.ini on C is
    created/updated each time and I have to add the records to the E drive
    boot.ini... the E drive is the first bootable drive according to the Bios
    settings.....

    Is there no way to prevent this?

    Gary D
     
    Gary J. Dikkema, Jul 16, 2005
    #5
  6. Gary J. Dikkema

    Rick Guest

    Because, like I said below, the system BIOS identifies the C: drive as
    80h and I am not aware of anything you can do to change that.

    The system BIOS could care less which drive you want to boot first, and
    I would guess that during installation the setup program is posting to
    the boot.ini based on the system BIOS hardware identification.

    Don't know if there is a solution or not.
     
    Rick, Jul 16, 2005
    #6
  7. See it much as you do... but I thought I'd ask just in case...

    Thanks!

    Regards!

    Gary D
     
    Gary J. Dikkema, Jul 16, 2005
    #7
  8. Gary J. Dikkema

    R. C. White Guest

    Hi, Gary.

    HOW are you editing boot.ini? If you go to System Properties | Advanced |
    Startup and Recovery / Settings, and click the Edit box there, the boot.ini
    that loads into Notepad should be the one that actually is used during the
    boot process. In other words, if E:\boot.ini is the "real" one, then that's
    the one that you should see automatically in Notepad.

    Of course, if your current boot was from C:\boot.ini, then that is the one
    that will be loaded automatically.

    RC
     
    R. C. White, Jul 17, 2005
    #8
  9. Gary J. Dikkema

    andy Guest

    Have you tried disabling the first IDE port in the BIOS setup? When I
    tried it with my motherboard, Windows setup did not see the drives
    connected to that port.
     
    andy, Jul 18, 2005
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.